Symptômes
Supposons que le SQL Server Agent Microsoft soit activé dans un SQL Server instance sur une installation Linux. Lorsque vous essayez de définir ou de modifier le nombre maximal de lignes pour le journal d’historique des travaux et le nombre maximal de lignes d’historique des travaux par travail, l’erreur suivante peut se produire :
Msg 0, Level 11, State 0, Line <LineNumber>Une erreur grave s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
Résolution
Deux nouvelles propriétés sqlagent.jobhistorymaxrows de l’agent SQL Server Agent et sqlagent.jobhistorymaxrowsperjobont été ajoutées à l’utilitaire mssql-conf de configuration. Ces paramètres vous permettent de définir respectivement le nombre maximum de lignes pour le journal d’historique des tâches et le nombre maximal de lignes d’historique des tâches par tâche.
Exemple : sudo /opt/mssql/bin/mssql-conf set sqlagent.jobhistorymaxrows 1000sudo /opt/mssql/bin/mssql-conf set sqlagent.jobhistorymaxrowsperjob 100
Remarque
Les deux propriétés ne peuvent pas être configurées à l’aide de SQL Server Management Studio (SSMS).
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2022
- Dernière mise à jour cumulative pour SQL Server 2019
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.