דלג לתוכן הראשי
היכנס דרך Microsoft
היכנס או צור חשבון.
שלום,
בחר חשבון אחר.
יש לך חשבונות מרובים
בחר את החשבון שברצונך להיכנס באמצעותו.

תופעות

שקול את התרחיש הבא:

  • אתה משתמש ב-Microsoft SQL Server 2016, 2014 או 2012.

  • יש לך מסד נתונים המהווה חלק מהקבוצה ' זמינות AlwaysOn '.

  • בעותק המשוכפל הראשי, עליך לכווץ את קבצי מסד הנתונים כדי להקטין את הגודל שלהם.

  • העותק המשוכפל הראשי שולח את כל השינויים המוקלטים ביומן הטרנזאקציות לעותק המשוכפל המשני.

  • בעותק המשוכפל המשני, הליכי המשנה ' בצע שוב ' מחילים את השינויים מיומן הטרנזאקציות למסד הנתונים המהווה חלק מהקבוצה ' זמינות '.

בתרחיש זה, העותק המשוכפל מושעה. בנוסף, ייתכן שתקבל הודעת שגיאה הדומה להודעה הבאה:

<time stamp> שגיאה spid41s: 3456, חומרה: 21, State: 1.<time stamp> spid41s לא היתה אפשרות לבצע שוב את רשומת יומן הרישום (), עבור מזהה הטרנזקציה (), בעמוד (), מסד נתונים ' <dbname> ' (מזהה מסד נתונים). Page: LSN = (), יחידת הקצאה =, הקלד =. Log: OpCode =, ההקשר, PrevPageLSN: (). שחזור מגיבוי של מסד הנתונים, או תיקון הdatabase.<time stamp> spid41s AlwaysOn זמינות תנועת הנתונים עבור מסד הנתונים ' <dbname> ' הושעה מהסיבה הבאה: "system" (מזהה מקור 2; מחרוזת מקור: ' SUSPEND_FROM_REDO '). כדי לחדש את תנועת הנתונים במסד הנתונים, יהיה עליך לחדש את מסד הנתונים באופן ידני. לקבלת מידע אודות אופן החידוש של מסד נתונים של זמינות, ראה Online.<time שגיאה של SQL Server stamp> שגיאת spid41s: 3313, חומרה: 21, State: 2.<time stamp> spid41s במהלך מהדורה מחדש של פעולה שנרשמה במסד הנתונים ' <dbname> ', אירעה שגיאה במזהה רשומת יומן (). בדרך כלל, הכשל הספציפי נרשם בעבר כשגיאה בשירות יומן האירועים של Windows. שחזר את מסד הנתונים מגיבוי מלא, או תקן את מסד הנתונים.

סיבה

בעיה זו מתרחשת כאשר שינויים מוחלים במהלך התהליך ' בצע שוב ' אם מנגנון מסד הנתונים נתקל LSNs ' מחוץ לסדר ' בדפי המערכת (גאם, PFS).

פתרון

הבעיה נפתרה לראשונה בעדכון המצטבר הבא של SQL Server:

כל עדכון מצטבר חדש עבור SQL Server מכיל את כל התיקונים החמים ואת כל תיקוני האבטחה שנכללו בעדכון המצטבר הקודם. אנו ממליצים להוריד ולהתקין את העדכונים המצטברים האחרונים עבור SQL Server:

העדכון מונע התרחשות של בעיה זו. אם הבעיה כבר התרחשה, בצע שלבים אלה כדי להצטרף מחדש לקבוצה זמינות של AlwaysOn:

  1. הסר את העותק המשוכפל המשני של AlwaysOn.

  2. הפעל את הפקודה הבאה בקבצי הנתונים המושפעים כדי להסיר שטח שלא הוקצה ממסד הנתונים:

    DBCC SHRINKFILE(<file_id>, TRUNCATEONLY)

  3. גבה את מסד הנתונים וקבצי יומן הרישום.

  4. שחזר את מסד הנתונים והיומנים בעותק המשוכפל המשני של AlwaysOn.

  5. הצטרפות לקבוצה ' זמינות AlwaysOn '.

מצב

Microsoft אישרה שזוהי בעיה במוצרי Microsoft המופיעים בסעיף "חל על".

הפניות

קבל מידע על המינוח שבו Microsoft משתמשת כדי לתאר עדכוני תוכנה.

זקוק לעזרה נוספת?

מעוניין באפשרויות נוספות?

גלה את יתרונות המנוי, עיין בקורסי הדרכה, למד כיצד לאבטח את המכשיר שלך ועוד.

קהילות עוזרות לך לשאול שאלות ולהשיב עליהן, לתת משוב ולשמוע ממומחים בעלי ידע עשיר.

האם מידע זה היה שימושי?

עד כמה אתם מרוצים מאיכות השפה?
מה השפיע על החוויה שלך?
בלחיצה על 'שלח', אתה מאפשר למשוב שלך לשפר מוצרים ושירותים של Microsoft. מנהל ה-IT שלך יוכל לאסוף נתונים אלה. הצהרת הפרטיות.

תודה על המשוב!

×