KB2953354 - FIX: Log Reader Agent fails when you have Oracle Publishing configured in SQL Server

Applies To
SQL Server 2008 R2 Service Pack 2 SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Standard SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptoms

Assume that you configure Oracle Publishing in Microsoft SQL Server 2008 R2, SQL Server 2012, SQL Server 2014, SQL Server 2016. When HREPL_SEQ goes beyond INT capacity of 2147483647, Log Reader Agent fails. Additionally, you receive the following error:

Note

ORA-01455: converting column overflows integer datatype (Source: MSSQL_REPL_ORACLE, Error number: 1455)
Get help: http:⁠//help/1455
Heterogeneous Logreader encountered an error in call to LoadReplCmds when processing state 'FETCH'. (Source: MSSQL_REPL, Error number: MSSQL_REPL22037)
Get help: http:⁠//help/MSSQL_REPL22037

Resolution

The issue was first fixed in the following cumulative updates of SQL Server.

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.