KB3170132 - FIX: Error 7330 when you query the view that is created by the Data Feed Publishing Wizard in SQL Server 2016

Applies To
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptoms

When you query a view that is created by the Data Feed Publishing Wizard, you may receive an error message that resembles the following:

Note

Msg 7330, Level 16, State 2, Line <LineNumber>
Cannot fetch a row from OLE DB provider "SSISOLEDB" for linked server "Default Linked Server for Integration Services".

Resolution

The issue was first fixed in the following cumulative update of SQL Server:

Recommendation: Install the latest cumulative update for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. We recommend that you download and install the latest cumulative updates for SQL Server:

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.