Stvaranje, učitavanje ili uređivanje upita u programu Excel (Power Query)

Power Query nudi nekoliko načina stvaranja i učitavanja upita dodatka Power u radnu knjigu. Zadane postavke učitavanja upita možete postaviti i u prozoru Mogućnosti upita.   

Savjet      Da biste pogledali je li Power Query oblikovao podatke na radnom listu, odaberite ćeliju podataka i ako se pojavi kartica Kontekstna vrpca upita, podaci su učitani iz dodatka Power Query. 

Odabir ćelije u upitu da bi se otkrila kartica Upit

Znati u kojem ste okruženju Power Query dobro je integriran u korisničko sučelje Excel, osobito kada uvozite podatke, radite s vezama i uređujete zaokretne tablice, Excel tablice i imenovane raspone. Da biste izbjegli zbrku, važno je znati u kojem se okruženju trenutno nalazite, Excel ili Power Query u bilo kojem trenutku.

Poznati radni Excel, vrpca i rešetka

Vrpca uređivača dodatka Power Query i pretpregled podataka 

Uobičajeni radni Excel radnog lista Uobičajeni prikaz uređivača dodatka Power Query

Na primjer, manipuliranje podacima na radnom Excel u osnovi se razlikuje od dodatka Power Query. Osim toga, povezani podaci koje vidite na Excel radnom listu mogu ili ne mogu imati Power Query koji radi iza scene da bi oblikovao podatke. To se događa samo kada podatke učitate na radni list ili podatkovni model iz dodatka Power Query.

Preimenovanje kartica radnog lista    Dobro je preimenovati kartice radnog lista na smislen način, osobito ako ih imate mnogo. Osobito je važno pojasniti razliku između radnog lista podataka i radnog lista učitanog iz uređivača dodatka Power Query. Čak i ako imate samo dva radna lista, jedan s tablicom Excel, pod nazivom List1,a drugi upit stvoren uvozom te tablice Excel, pod nazivom Tablica1, lako se zbuniti. Uvijek je dobro promijeniti zadane nazive kartica radnih listova u nazive koji vam više smisla čine. Primjerice, preimenujte List1 u Podatkovna tablica i Tablica1 u Tablicu upita. Sada je jasno koja kartica sadrži podatke i koja kartica sadrži upit.

Upit možete stvoriti iz uvezenih podataka ili stvoriti prazan upit.

Stvaranje upita iz uvezenih podataka

To je najčešći način stvaranja upita.

  1. Uvezite neke podatke. Dodatne informacije potražite u članku Uvoz podataka iz vanjskih izvora podataka.

  2. Odaberite ćeliju u podacima, a zatim Odaberite Upit > Uređivanje.

Stvaranje praznog upita

Možete početi ispočetka. To možete učiniti na dva načina.

  • Odaberite Podaci > za > iz drugih izvora >prazan upit.

  • Odaberite Data > Get Data > Launch Power Query Editor.

U ovom trenutku možete ručno dodavati korake i formule ako dobro znate jezik formule dodatka Power Query M.

Možete i odabrati Polazno, a zatim odabrati naredbu u grupi Novi upit. Učinite nešto od sljedećeg.

  • Odaberite Novi izvor da biste dodali izvor podataka. Ta je naredba baš kao i naredba> podaci na vrpci Excel podataka.

  • Odaberite Nedavni izvori da biste odabrali izvor podataka s kojeg ste radili. Ta je naredba kao i naredba Podaci> nedavni izvori na vrpci Excel.

  • Odaberite Unesite podatke da biste ručno unijeli podatke. Tu naredbu možete odabrati da biste uređivač dodatka Power Query isprobali neovisno o vanjskom izvoru podataka.

Uz pretpostavku da je upit valjan i da nema pogrešaka, možete ga ponovno učitati na radni list ili podatkovni model.

Učitavanje upita iz uređivača dodatka Power Query

U uređivaču dodatka Power Query učinite nešto od sljedećeg:

  • Da biste učitali radni list, odaberite Polazno > Zatvori & Učitaj > Zatvori & Učitaj.

  • Da biste učitali podatkovni model, odaberite Polazno > Zatvori & učitaj > Zatvori & Učitaj u.

    U dijaloškom okviru Uvoz podataka odaberite Dodaj ove podatke u podatkovni model.

Savjet   Ponekad je naredba Učitaj u zasivučena ili onemogućena. To se može dogoditi kada prvi put stvorite upit u radnoj knjizi. Ako se to dogodi, odaberite Zatvori & Učitaj, na novom radnom listu odaberite Podaci > Upiti & Veze > Upiti, desnom tipkom miša kliknite upit, a zatim odaberite Učitaj u. Osim toga, na vrpci uređivača dodatka Power Query odaberite Upit > učitaj u.

Učitavanje upita iz okna Upiti i veze 

U Excel, možda želite učitati upit na drugi radni list ili podatkovni model.

  1. U Excel odaberite Podaci> upiti & Veze, a zatim karticu Upiti.

  2. Na popisu upita pronađite upit, desnom tipkom miša kliknite upit, a zatim odaberite Učitaj u. Pojavit će se dijaloški okvir Uvoz podataka.

  3. Odlučite kako želite uvesti podatke, a zatim odaberite U redu. Da biste saznali više o korištenju tog dijaloškog okvira, odaberite upitnik (?).

Upit učitan na radni list možete urediti na nekoliko načina.

Uređivanje upita iz podataka na Excel radnom listu

  • Da biste uredili upit, pronađite prethodno učitan iz uređivača dodatka Power Query, odaberite ćeliju u podacima, a zatim odaberite Upit> Uređivanje.

Uređivanje upita iz okna & veze

Možda ćete pronaći okno Upiti & veze praktičnije je koristiti kada imate mnogo upita u jednoj radnoj knjizi i želite ga brzo pronaći.

  1. U Excel odaberite Podaci> upiti & Veze, a zatim karticu Upiti.

  2. Na popisu upita pronađite upit, desnom tipkom miša kliknite upit, a zatim odaberite Uređivanje.

Uređivanje upita iz dijaloškog okvira Svojstva upita

  • U Excel odaberite Data> Data & Connections > Queries tab, desnom tipkom miša kliknite upit i odaberite Svojstva, odaberite karticu Definicija u dijaloškom okviru Svojstva, a zatim odaberite Uređivanje upita.

Savjet    Ako ste na radnom listu s upitom, odaberite Podaci > Svojstva, u dijaloškom okviru Svojstva odaberite karticu Definicija,a zatim Uređivanje upita . 

Podatkovni model obično sadrži nekoliko tablica raspoređenih u odnos. Upit u podatkovni model učitavate pomoću naredbe Učitaj u da biste prikazali dijaloški okvir Uvoz podataka, a zatim potvrdite okvir Dodaj te podatke upodatkovni način l. Dodatne informacije o podatkovnim modelima potražite u članku Pronalaženje izvora podataka koji se koriste u podatkovnom modeluradne knjige , Stvaranje podatkovnog modela u programu Exceli Stvaranje zaokretne tablice pomoću više tablica.

  1. Da biste otvorili podatkovni model, odaberite Power Pivot >Upravljanje.

  2. Pri dnu prozora dodatka Power Pivot odaberite karticu radnog lista željene tablice.

    Provjerite prikazuje li se ispravna tablica. Podatkovni model može imati mnogo tablica.

  3. Zabilježite naziv tablice.

  4. Da biste zatvorili prozor dodatka Power Pivot, odaberite Datoteka > Zatvori. Za povrat memorije može potrajati nekoliko sekundi.

  5. Odaberite Data > Connections & Properties > Queries tab, desnom tipkom miša kliknite upit, a zatim odaberite Uređivanje.

  6. Kada završite s promjenama u uređivaču dodatka Power Query, odaberite Datoteka > Zatvori & učitaj.

Rezultat

Upit na radnom listu i tablica u podatkovnom modelu ažuriraju se.

Ako primijetite da učitavanje upita u podatkovni model traje mnogo dulje od učitavanja na radni list, provjerite korake dodatka Power Query da biste vidjeli filtrirate li tekstni stupac ili strukturirani stupac Popisa pomoću operatora Sadrži. Ta akcija Excel ponovno numeriranje kroz cijeli skup podataka za svaki redak. Osim toga, Excel ne može učinkovito koristiti višestrano izvršavanje. Kao zaobilazno rješenje pokušajte koristiti neki drugi operator kao što je Jednako ili Počinje sa.

Microsoft je upoznat s tim problemom i istražuje ga.

Power Query možete učitati:

  • Na radni list. U uređivaču dodatka Power Query odaberite Polazno > Zatvori & Učitaj > Zatvori & učitaj.

  • U podatkovni model. U uređivaču dodatka Power Query odaberite Polazno > Zatvori & Učitaj > Zatvori & Učitaj u.

    Power Query po zadanom učitava upite na novi radni list prilikom učitavanja jednog upita i istovremeno učitava više upita u podatkovni model.  Zadano ponašanje možete promijeniti za sve radne knjige ili samo trenutnu radnu knjigu. Prilikom postavljanja tih mogućnosti Power Query ne mijenja rezultate upita na radnom listu ni u podacima podatkovnog modela i primjedbama.

    Možete i dinamički nadjačati zadane postavke upita pomoću dijaloškog okvira Uvoz koji će se prikazati nakon što odaberete Zatvori & učitaju. 

Globalne postavke koje se odnose na sve radne knjige

  1. U uređivaču dodatka Power Query odaberite Mogućnosti > datoteka i postavke > mogućnosti upita.

  2. U dijaloškom okviru Mogućnosti upita na lijevoj strani u odjeljku GLOBAL  odaberite Učitavanje podataka.

  3. U odjeljku Zadano učitavanje Postavke upita učinite sljedeće:

    • Odaberite Koristi standardne postavke opterećenja

    • Odaberite Navedite prilagođene zadane postavke opterećenja, a zatim   odaberite ili poništite mogućnost Učitaj na radni list ili Učitaj u podatkovni model.

Savjet    Pri dnu dijaloškog okvira možete odabrati Vrati zadane postavke da biste se jednostavno vratili na zadane postavke.

Postavke radne knjige koje se odnose samo na trenutnu radnu knjigu

  1. U dijaloškom okviru Mogućnosti upita na lijevoj strani u odjeljku TRENUTNA RADNA KNJIGA odaberite Učitavanje podataka.

  2. Učinite nešto od sljedećeg:

    • U odjeljku Otkrivanjevrste odaberite ili poništite mogućnost Otkrivanje vrsta stupaca i zaglavlja za nestrukturirani izvori.

      Zadano je da ih otkrijete. Poništite tu mogućnost ako želite sami oblikovati podatke.

    • U odjeljku Odnosiodaberite ili poništite mogućnost Stvaranje odnosa između tablica prilikom prvog dodavanja u podatkovni model.

      Prije učitavanja u podatkovni model zadano je pronaći postojeće odnose između tablica, kao što su vanjski ključevi u relacijskim bazama podataka i uvesti ih s podacima. Poništite tu mogućnost ako to želite učiniti sami.

    • U odjeljku Odnosiodaberite ili poništite mogućnost Ažuriraj odnose prilikom osvježavanja upita učitanih u podatkovni model.

      Zadano je ponašanje ne ažurirati odnose. Prilikom osvježavanja upita koji su već učitani u podatkovni model Power Query pronalazi postojeće odnose između tablica kao što su vanjski ključevi u relacijskim bazama podataka i ažurira ih. Time se mogu ukloniti odnosi stvoreni ručno nakon uvoza podataka ili uvođenja novih odnosa. No ako to želite učiniti, odaberite tu mogućnost.

    • U odjeljku Pozadinskipodaci odaberite ili poništite mogućnost Dopusti preglede podataka za preuzimanje u pozadini.

      Zadano je ponašanje preuzimanje podatkovnih pregledima u pozadini. Poništite tu mogućnost ako odmah želite vidjeti sve podatke.

Dodatne informacije

Power Query za Excel pomoć

Upravljanje upitima u Excel

Excel za web sadrži tehnologiju Power Query (naziva se i Get & Transform) radi pružanja veće mogućnosti prilikom rada s uvezenim izvorima podataka. Upite i povezane detalje možete pogledati u oknu zadatka Upiti.

Napomena: Pogledajte dodatne najave o poboljšanjima Excel integracije weba i dodatka Power Query.

Prikaz okna zadatka Upiti 

  1. Provjerite jeste li u prikazu za uređivanje (odaberite Prikaz> uređivanje).

  2. Odaberite Podatkovni > Upiti.

Rezultat

Excel prikazuje okno zadatka Upiti i sve upite u trenutnoj radnoj knjizi zajedno s detaljima upita, kao što su broj redaka, datum zadnjeg osvježavanja, mjesto i stanje učitavanja. Ako je upit učitan u podatkovni model, a ne na rešetku, Excel "Connection Only".

Prikaz upita i okna zadatka Upiti

Dodatne informacije

Power Query za Excel pomoć

Potrebna vam je dodatna pomoć?

Proširite svoje vještine
Istražite osposobljavanje
Prvi koristite nove značajke
Pridružite se Microsoft Insidere

Jesu li ove informacije bile korisne?

Koliko ste zadovoljni kvalitetom prijevoda?
Što je utjecalo na vaše iskustvo?

Hvala vam na povratnim informacijama!

×