#SPILL hibát ad vissza, ha egy képlet több eredményt ad vissza, és Excel nem tudja visszaadni az eredményeket a rácsra. A hibatípusokról további információt az alábbi súgótémakban talál:

Ez a hiba akkor fordul elő, ha egy kiömlött tömbképlet teljes tartománya nem üres.

#KITÖLTÉS! hiba – A kiszivárgási tartomány nem üres

Ha a képlet ki van jelölve, szaggatott szegély jelzi a kiömlött tartományt.

Jelölje ki a Hiba lebegés jelölőnégyzetet, és válassza a Ne eltakaró cellák kijelölése lehetőséget, hogy azonnal eltömöredjen a cella(oka)t. Ezután a hiba törölhető a cella bejegyzésének törlésével vagy áthelyezésével. Amint törölték az akadályokat, a tömbképlet a kívántnak megfelelően ki lesz ásva.

Excel nem sikerült megállapítani a kiömlött tömb méretét, mert környezetben van, és átméretezi a számítási bérletek között. A következő képlet például kiváltja ezt a #SPILL! hibaértéket adja vissza.

=SORSZÁMSOR(VÉLETLEN.KÖZÖTT(1;1000))

A dinamikus tömbméretek további számítási adatokat is kiválthatnak, hogy a számolótábla teljesen ki legyen számítva. Ha a tömb mérete a további bérletek során sem változik, és nem megfelelő, a Excel a dinamikus tömböt ennek #SPILL!

Ez a hibaérték általában a RAND,a RANDARRAYés a RANDBETWEEN függvények használatával van társítva. Más gyorsan változó függvények (például AZ ELTOLÁS,AZ INDIREKTés a MA függvény) nem ad vissza különböző értékeket minden számítási lépéshez.  

Ha például az E2 cellába helyezi az alábbi példát, akkor az =FKERES(A:A,A:C,2,HAMIS) képlet korábban csak az A2 cellában lévő azonosítóban keres. A dinamikus tömbállandókban Excel képlet azonban problémákat #SPILL! hibát adja vissza, Excel a teljes oszlopot, 1 048 576 eredményt ad vissza, és a teljes Excel végére ér.

#KITÖLTÉS! hiba az E2 cellában az =FKERES(A:A,A:D,2,HAMIS) hiba miatt, mert az eredmények túlnyúlnak a munkalap szélén. Helyezze át a képletet az E1 cellába, és az megfelelően fog működni.

A probléma három egyszerű megoldással oldható meg:

#

Megközelítés

Képlet

1

Csak a keresési értékekre hivatkozik. Ez a képletstílus dinamikus tömböt ad vissza, de nem működik Excel táblázatokkal. 

Az =FKERES(A2:A7;A:C,2,HAMIS) segítségével olyan dinamikus tömböt ad vissza, amely nem eredményez eredményt #SPILL! hibát küld vissza.

=FKERES(A2:A7;A:C;2;HAMIS)

2

Csak az ugyanazon sorban lévő értékre hivatkozik, majd másolja lefelé a képletet. Ez a hagyományos képletstílus táblázatokban működik,de nem ad vissza dinamikus tömböt.

A hagyományos FKERES egyetlen hivatkozással lookup_value: =FKERES(A2;A:C;32;HAMIS). Ez a képlet nem dinamikus tömböt ad vissza, de táblázatokkal Excel használható.

=FKERES( A2 ;A:C;2;HAMIS)

3

Azt kéri, Excel végrehajtsa az implicit metszetet a @ operátor használatával, majd másolja le a képletet. Ez a képletstílus táblázatokban működik,de nem ad vissza dinamikus tömböt.

Használja az @ operátort, és másolja le a következőt: =FKERES(@A:A,A:C,2,HAMIS). Ez a hivatkozási stílus működik a táblázatokban, de nem ad vissza dinamikus tömböt.

=FKERES(@A:A,A:C,2,HAMIS)

A kiömlött tömbképletek nem támogatottak Excel táblázatokban. Próbálja meg áthozni a képletet a táblázatból, vagy alakítsa át tartományné (kattintson a Táblázattervező > Eszközök > Átalakítás tartományra parancsra).

#KITÖLTÉS! hiba – Táblázatképlet

A kiömlött tömbképlet, amelyet be próbál írni, Excel memória elfogyott. Próbáljon meg hivatkozni egy kisebb tömbre vagy tartományra.

A kiömlött tömbképletek nem tudnak kifedni az egyesített cellákba. Törölje a szóban forgó cellák egyesítését, vagy helyezze át a képletet egy olyan tartományba, amely nem metszi egymást egyesített cellákkal.

#KITÖLTÉS! hiba – Ki van ásva az egyesített cellába

Ha a képlet ki van jelölve, szaggatott szegély jelzi a kiömlött tartományt.

Jelölje ki a Hiba lebegés jelölőnégyzetet, és válassza a Ne eltakaró cellák kijelölése lehetőséget, hogy azonnal eltömöredjen a cella(oka)t. Amint törli az egyesített cellákat, a tömbképlet a kívánt kiosztást fogja kifedni.

Excel nem ismeri fel vagy nem tudja egyeztetni a hiba okát. Győződjön meg arról, hogy a képlet tartalmazza az esethez szükséges összes argumentumot.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

SZŰRŐ függvény

VÉLETLENTÖMB függvény

SORSZÁMLISTA függvény

SORBA.RENDEZ függvény

RENDEZÉS.ALAP.SZERINT függvény

EGYEDI függvény

Dinamikus tömbök és kibontott tömb viselkedése

Implicit metszetoperátor: @

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?

Mi befolyásolta a felhasználói élményét?

Szeretne további visszajelzéssel élni? (Nem kötelező)

Köszönjük visszajelzését!

×