További információ a SZUM függvényről

Ha szeretné gyorsan megkapni egy cellatartomány összegét, elég egyszerűen kijelölnie a tartományt, és egy pillantást vetnie az Excel ablakának jobb alsó részére.

Képernyőkép: cellatartomány kijelölése, majd az állapotsáv tartalmának megnézése


Ez az állapotsor, amely információkat jelenít meg a kijelölt elemekről, legyen szó akár egyetlen celláról, akár több celláról. Ha a jobb gombbal az állapotsorra kattint, megjelenik egy menü, amelyben az összes kiválasztható lehetőség látható. A kijelölt tartományra vonatkozóan is jelennek meg itt értékek, ha be van kapcsolva ezek megjelenítése. 

Legkönnyebben az AutoSzum varázslóval adhat hozzá SZUM képletet a munkalapjához. Jelöljön ki egy üres cellát közvetlenül az összeadni kívánt tartomány fölött vagy alatt, majd válassza a Kezdőlap vagy a Képletek lapon az AutoSzum > Szum lehetőséget. Az AutoSzum varázsló automatikusan érzékeli, hogy milyen tartományt szeretne összeadni, és létrehozza Ön helyett a képletet. Vízszintesen is működik, ha az összeadandó tartománytól jobbra vagy balra eső cellát jelöli ki. A nem folytonos tartományokon azonban nem működik, de a következő szakaszban bemutatjuk, hogyan küszöbölheti ezt ki.

Az AutoSzum varázslóval automatikusan felépíthet egy összegző képletet.  Jelöljön ki egy tartományt az összesítendő tartomány felett/alatt vagy attól balra/jobbra a menüszalag Képlet lapján, és válassza az AutoSzum, majd a SZUM elemet.


Az AutoSzum párbeszédpanelen egyéb gyakori függvényeket is választhat, például:

AutoSzum függőlegesen

A B6 cella megjeleníti az AutoSzum összegző képletet: =SZUM(B2:B5)

Az AutoSzum varázsló automatikusan észlelte a B2:B5 cellatartományt összefésülni. Csak annyit kell tennie, hogy lenyomja az Enter billentyűt a megerősítéshez. Ha további cellákat szeretne hozzáadni vagy kizárni, tartsa lenyomva a Shift billentyűt > nyílbillentyűt, amíg a kijelölés meg nem egyezik a kívánt beállításokkal, majd ha végzett, nyomja le az Enter billentyűt.

Intellisense függvény útmutatója: a SZUM(szám1;[szám2]; ...) floating tag beneath the function is its Intellisense guide. Ha a SZUM vagy a függvény nevére kattint, az kék hivatkozássá fog színre vált, amely az ahhoz a függvényhez kapcsolódó súgótémakörre vált. Ha az egyes függvényelemekre kattint, a képletben az adott elem jellemző elemei kiemelve jelennek meg. Ebben az esetben csak a B2:B5 hivatkozás lesz kiemelve, mivel ebben a képletben csak egy számhivatkozás van. Az Intellisense címke bármely függvényhez megjelenik.

AutoSzum vízszintesen

A D2 cella megjeleníti az AutoSzum összegző képletet: =SZUM(B2:C2)

A SZUM használata nem folytonos tartományokkal.  A C8 cellában szereplő képlet a következő: =SUM(C2:C3;C5:C6). Használhat elnevezett tartományokat is, így a képlet ilyen lesz: =SZUM(Hét1;Hét2).

Az AutoSzum varázsló csak folytonos tartományokkal működik, ezért ha üres sorok vagy oszlopok találhatók az összeadandó tartományában, az Excel meg fog állni az első üres területnél. Ilyen esetben manuális kijelöléssel kell használnia a SZUM függvényt: egyenként hozzá kell adnia a kívánt tartományokat. Ha a fenti példában a B4 cella tartalmazna adatot, az Excel a =SZUM(C2:C6) képletet hozná létre, mert felismerné a folytonos tartományt.

Gyorsan kijelölhet több, nem folytonos tartományt a Ctrl+Bal egérgomb lenyomásával. Először írja be a „=SZUM(” kezdőrészt, majd jelölje ki a kívánt tartományokat, és az Excel automatikusan hozzáadja az elválasztó pontosvesszőt a tartományok közé. Ha elkészült, nyomja le az Enter billentyűt.

TIPP: Az ALT+ = billentyűkombinációval gyorsan felveheti a SZUM függvényt egy cellába. Ezután csak annyit kell tennie, hogy kijelöli a tartomány(ak)t.

Megjegyzés: Észreveheti, hogy a Excel szín szerint kiemeli a különböző függvénytartományokat, és azok megegyeznek magában a képletben, így a C2:C3 egy szín, a C5:C6 pedig egy másik. Excel, kivéve ha a hivatkozott tartomány másik munkalapon vagy másik munkafüzetben található. A kisegítő technológiák továbbfejlesztett akadálymentessége érdekében használhatja a névvel bíró tartományokat (például "Hét1", "Hét2" stb.), majd hivatkozhat rájuk a képletben:

=SZUM(Hét1;Hét2)

  1. A SZUM függvényt más függvényekkel is kombinálhatja. Az alábbi képlet például havi átlagszámítást végez:

    A SZUM használata egyéb függvényekkel.  Az M2 cellában lévő képlet =SZUM(A2:L2)/DARAB2(A2:L2) .  Megjegyzés: az átláthatóság érdekében a május és november közötti hónapok rejtve vannak.
    • =SZUM(A2:L2)/DARAB2(A2:L2)

  2. Ez a képlet az A2:L2 tartomány összegét elosztja az A2:L2 tartomány nem üres celláinak számával (a képen a májustól decemberig tartó időszak üres).

  1. Időnként szükség lehet arra, hogy több munkalapon egy adott cellát összegessen. Nagy lehet a csábítás, hogy az egyes lapokra és a kívánt cellára kattint, és egyszerűen a "+" billentyűkombinációval adja hozzá a cellaértékeket, de ez fárasztó, és hibat okozhat.

    • =Munka1!A1+Munka2!A1+Munka3!A1

    Sokkal egyszerűbben megteheti ugyanezt háromdimenziós SZUM függvénnyel:

    3D Szum – A D2 cellában lévő képlet =SZUM(Munka1:Munka3!A2)
    • =SZUM(Munka1:Munka3!A1)

    Ez a képlet összeadja az A1 cellát a Munka1 munkalaptól a Munka3 munkalapig.

    Különösen hasznos lehet olyan esetekben, amikor az egyes hónapok számára külön munkalapot hozott létre, és egy összesítő munkalapon szeretne összegző adatokat megjeleníteni.

    3d SUM across Named Sheets.  A D2 cellákban a képlet a következő: =SZUM(Január:December! A2)
    • =SZUM(Január:December!A2)

    Ez a képlet összeadja az A2 cellákat a Január munkalaptól a December munkalapig.

    Megjegyzések: Ha a munkalapjai nevében szóköz szerepel (például „Januári értékesítés”), akkor idézőjelekbe kell foglalnia a munkalapneveket a képletében. Figyelje meg az aposztróf karaktert az első munkalap neve előtt és az utolsó munkalap neve után.

    • =SZUM('Januári értékesítés:Decemberi értékesítés'!A2)

    A háromdimenziós módszer más függvényekkel is működik, ideértve például az ÁTLAG, a MIN és a MAX függvényt.

    • =ÁTLAG(Munka1:Munka3!A1)

    • =MIN(Munka1:Munka3!A1)

    • =MAX(Munka1:Munka3!A1)

Egyszerűen végrehajthat matematikai műveleteket az Excellel külön vagy a SZUM függvényhez hasonló Excel-függvényekkel együtt. Az alábbi táblázatban megtalálja a használható operátorokat, valamint néhány kapcsolódó függvényt. Az operátorokat a billentyűzet számsora vagy, ha van ilyenje, a 10 billentyűs számbillentyűzet használatával írhatja be. A Shift+8 billentyűkombinációval például a szorzáshoz használható csillag (*) karaktert adhatja meg.

Operátor

Művelet

Példák

+

Összeadás

=1+1

=A1+B1

=SZUM(A1:A10)+10

=SZUM(A1:A10)+B1

-

Kivonás

=1-1

=A1-B1

=SZUM(A1:A10)-10

=SZUM(A1:A10)-B1

*

Szorzás

=1*1

=A1*B1

=SZUM(A1:A10)*10

=SZUM(A1:A10)*B1

=SZORZAT(1,1) - SZORZAT függvény

/

Osztás

=1/1

=A1/B1

=SZUM(A1:A10)/10

=SZUM(A1:A10)/B1

=KVÓCIENS(1,1) - KVÓCIENS függvény

^

Hatványra emelés

=1^1

=A1^B1

=SZUM(A1:A10)^10

=SZUM(A1:A10)^B1

=HATVÁNY(1,1) - HATVÁNY függvény

További információt Az Excel használata számológépként című témakörben talál.

Egyéb példák

  1. Tegyük fel, hogy szeretné csökkenteni bizonyos százalékkal egy cellatartomány összegét.

    Operátorok használata a SZUM függvénnyel.  A B16 cellában szereplő képlet =SZUM(A2:A14)*-25%.  A képlet kialakítása nem lesz megfelelő, ha a -25% cellahivatkozás volt a =SZUM(A2:A14)*E2 helyett
    • =SZUM(A2:A14)*-25%

    Ez a képlet 25%-kal csökkenti a tartomány összegét, de a 25% közvetlenül a képletbe lett beírva, ami miatt nehéz lehet később megtalálni és módosítani. Érdemesebb a 25% értéket egy cellában elhelyezni, majd hivatkozni az adott cellára; így az érték később könnyen megtalálható és módosítható:

    • =SZUM(A2:A14)*E2

    Ha osztani szeretne szorzás helyett, egyszerűen cserélje a „*” operátort a „/” operátorra: =SZUM(A2:A14)/E2

  2. A SZUM függvény kombinálása hozzáadással vagy kivonással

    i. Egyszerűen felvehet vagy kivonhat egy összegből a + vagy - használhatja az így:

    • =SZUM(A1:A10)+E2

    • =SZUM(A1:A10)-E2

SZUM függvény

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük visszajelzését!

×