Mengimpor data dari folder dengan beberapa file (Power Query)

Gunakan Power Query untuk menggabungkan beberapa file dengan skema yang sama yang disimpan dalam satu folder menjadi satu tabel. Misalnya, setiap bulan Anda ingin menggabungkan buku kerja anggaran dari beberapa departemen, dengan kolom yang sama, tetapi jumlah baris dan nilai berbeda di setiap buku kerja. Begitu Anda menyiapkannya, Anda bisa menerapkan transformasi tambahan seperti yang Anda lakukan dengan sumber data tunggal yang diimpor lalu merefresh data untuk melihat hasil setiap bulan.  

Gambaran umum konseptual Tentang Menggabungkan file folder

Catatan    Topik ini memperlihatkan cara menggabungkan file dari folder. Anda juga dapat mengombinasikan file yang disimpan di SharePoint, Penyimpanan Blob Azure, dan Penyimpanan Azure Data Lake. Prosesnya sama.

Sederhanakan:

  • Pastikan bahwa semua file yang ingin digabungkan terdapat dalam folder khusus tanpa file yang tidak diperlukan. Jika tidak, semua file dalam folder dan subfolder apa pun yang Anda pilih disertakan dalam data yang akan digabungkan.

  • Setiap file harus memiliki skema yang sama dengan header kolom, tipe data, dan jumlah kolom yang konsisten. Kolom tidak harus berada dalam urutan yang sama seperti yang cocok dilakukan oleh nama kolom.

  • Jika memungkinkan, hindari objek data yang tidak terkait untuk sumber data yang dapat memiliki lebih dari satu objek data, seperti file JSON, buku kerja Excel, atau database Access.

Setiap file ini mengikuti pola sederhana, hanya satu tabel data dalam setiap file.

  1. Pilih Data > Dapatkan Data > Dari File >Dari Folder. Kotak dialog Telusuri akan muncul.

  2. Temukan folder berisi file yang ingin Anda gabungkan.

  3. Daftar file dalam folder muncul di kotak dialog <Folder jalur> folder. Verifikasi bahwa semua file yang diinginkan telah tercantum.

    Kotak dialog contoh impor teks

  4. Pilih salah satu perintah di bagian bawah kotak dialog, misalnya Gabungkan> Gabungkan & Muat. Terdapat perintah tambahan yang dibahas di bagian Tentang semua perintah tersebut.

  5. Jika Anda memilih perintah Kombinasikan, kotak dialog Gabungkan File akan muncul. Untuk mengubah pengaturan file, pilih setiap file dari kotak File Sampel, atur Asal File, Pembatas, dan Deteksi Tipe Data seperti yang diinginkan. Anda juga dapat memilih atau mengosongkan kotak centang Lewati file dengan kesalahan di bagian bawah kotak dialog.

  6. Pilih OK.

Hasil

Power Query secara otomatis membuat kueri untuk mengonsolidasi data dari setiap file ke dalam lembar kerja. Langkah-langkah kueri dan kolom yang dibuat bergantung pada perintah yang Anda pilih. Untuk informasi selengkapnya, lihat bagian Tentang semua kueri tersebut.

  1. Pilih Data > Dapatkan Data > Dari File >Dari Folder. Kotak dialog Telusuri akan muncul.

  2. Temukan folder berisi file yang ingin Anda gabungkan.

  3. Daftar file dalam folder muncul di kotak dialog <Folder jalur> folder. Verifikasi bahwa semua file yang diinginkan telah tercantum.

  4. Pilih salah satu perintah di bagian bawah kotak dialog, misalnya Gabungkan > Gabungkan & Transformasi. Terdapat perintah tambahan yang dibahas di bagian Tentang semua perintah tersebut.

    Editor Power Query muncul.

  5. Kolom Nilai adalah kolom Daftar terstruktur. Pilih ikon Perluas Ikon perluas kolom , lalu pilih Perluas ke Baris baru. 

    Memperluas Daftar JSON

  6. Kolom Nilai sekarang merupakan kolom Catatan terstruktur.  Pilih ikon Ikon perluas kolom Perluas. Kotak dialog turun bawah akan muncul.

    Memperluas Rekaman JSON

  7. Mempertahankan semua kolom yang dipilih. Anda mungkin ingin mengosongkan kotak centang Gunakan nama kolom asli sebagai prefiks. Pilih OK.

  8. Pilih semua kolom yang berisi nilai data. Pilih Beranda, panah di samping Hapus Kolom, lalu pilih Hapus Kolom Lain.

  9. Pilih Pengaturan> Tutup & Muat.

Hasil

Power Query secara otomatis membuat kueri untuk mengonsolidasi data dari setiap file ke dalam lembar kerja. Langkah-langkah kueri dan kolom yang dibuat bergantung pada perintah yang Anda pilih. Untuk informasi selengkapnya, lihat bagian Tentang semua kueri tersebut.

Setiap sumber data ini bisa memiliki lebih dari satu objek untuk diimpor. Sebuah Excel kerja dapat memiliki beberapa lembar kerja, Excel tabel, atau rentang bernama. Database Access dapat memiliki beberapa tabel dan kueri. 

  1. Pilih Data > Dapatkan Data > Dari File >Dari Folder. Kotak dialog Telusuri akan muncul.

  2. Temukan folder berisi file yang ingin Anda gabungkan.

  3. Daftar file dalam folder muncul di kotak dialog <Folder jalur> folder. Verifikasi bahwa semua file yang diinginkan telah tercantum.

  4. Pilih salah satu perintah di bagian bawah kotak dialog, misalnya Gabungkan> Gabungkan & Muat. Terdapat perintah tambahan yang dibahas di bagian Tentang semua perintah tersebut.

  5. Dalam kotak dialog Gabungkan File:

    • Dalam kotak File Sampel, pilih file untuk digunakan sebagai sampel data yang digunakan untuk membuat kueri. Anda tidak dapat memilih objek atau memilih satu objek saja. Namun, Anda tidak bisa memilih lebih dari satu.

    • Jika Anda memiliki banyak objek, gunakan kotak Pencarian untuk menemukan objek atau Opsi Tampilan bersama dengan tombol Refresh untuk memfilter daftar.

    • Pilih atau kosongkan kotak centang Lewati file dengan kesalahan di bagian bawah kotak dialog.

  6. Pilih OK.

Hasil

Power Query secara otomatis membuat kueri untuk mengonsolidasi data dari setiap file ke dalam lembar kerja. Langkah-langkah kueri dan kolom yang dibuat bergantung pada perintah yang Anda pilih. Untuk informasi selengkapnya, lihat bagian Tentang semua kueri tersebut.

Agar lebih fleksibel, Anda bisa secara eksplisit menggabungkan file di Editor Power Query dengan menggunakan perintah Gabungkan File. Katakanlah folder sumber memiliki campuran tipe file dan subfolder, dan Anda ingin menargetkan file tertentu dengan tipe dan skema yang sama tetapi tidak dengan orang lain. Ini bisa meningkatkan kinerja dan membantu menyederhanakan transformasi Anda.

  1. Pilih Data > Dapatkan Data > Dari File > Dari Folder. Kotak dialog Telusuri akan muncul.

  2. Temukan folder berisi file yang ingin Anda gabungkan, lalu pilih Buka.

  3. Daftar semua file dalam folder dan subfolder muncul di kotak dialog jalur<folder> folder baru. Verifikasi bahwa semua file yang diinginkan telah tercantum.

  4. Pilih Transformasi Data di bagian bawah. Editor Power Query terbuka dan menampilkan semua file di folder dan subfolder apa pun.

  5. Untuk memilih file yang Anda inginkan, filter kolom, seperti Ekstensi atau Jalur Folder.

  6. Untuk menggabungkan file ke dalam satu tabel, pilih kolom Konten yang berisi setiap Biner (biasanya kolom pertama), lalu pilih Beranda >Gabungkan File. Kotak dialog Gabungkan File akan muncul.

  7. Power Query menganalisis file contoh, secara default file pertama dalam daftar, untuk menggunakan konektor yang benar dan mengidentifikasi kolom yang cocok.

    Untuk menggunakan file lain untuk file contoh, pilih file dari daftar menurun File Sampel.

  8. Jika perlu, di bagian bawah, pilih Lewati file dengankesalahan untuk tidak menyertakan file tersebut dari hasil.

  9. Pilih OK.

Hasil

Power Query secara otomatis membuat kueri untuk mengonsolidasi data dari setiap file ke dalam lembar kerja. Langkah-langkah kueri dan kolom yang dibuat bergantung pada perintah yang Anda pilih. Untuk informasi selengkapnya, lihat bagian Tentang semua kueri tersebut.

Ada beberapa perintah yang dapat Anda pilih dan masing-masing perintah memiliki tujuan yang berbeda.

  • Menggabungkan dan Mentransformasi Data    Untuk menggabungkan semua file dengan kueri, lalu meluncurkan Editor Power Query, pilih Gabungkan> Dan Transformasi Data.

  • Gabungkan dan Muat   Untuk menampilkan kotak dialog File sampel, buat kueri, lalu muat ke lembar kerja, pilih Gabungkan> Gabungkan dan Muat.

  • Gabungkan dan Muat Ke   Untuk menampilkan kotak dialog File sampel, buat kueri, lalu tampilkan kotak dialog Impor, pilih Gabungkan >Dan Muat Ke.

  • Memuat    Untuk membuat kueri dengan satu langkah, lalu memuat ke lembar kerja, pilih Muat > Memuat.

  • Muat Ke   Untuk membuat kueri dengan satu langkah, lalu menampilkan kotak dialog Impor, pilih Muat> Muat Ke.

  • Mentransformasi DataUntuk membuat kueri dengan satu langkah, lalu meluncurkan Editor Power Query, pilih Transformasi Data.

Namun, saat Anda menggabungkan file, beberapa kueri pendukung dibuat di panel Kueri di bawah grup "Kueri Bantuan".

Daftar kueri yang dibuat di panel Kueri

  • Power Query membuat kueri "File Sampel" berdasarkan kueri contoh.

  • Kueri fungsi "Transformasi File" menggunakan kueri "Parameter1" untuk menentukan setiap file (atau biner) sebagai input ke kueri "File Sampel". Kueri ini juga membuat kolom Konten yang berisi konten file dan secara otomatis memperluas kolom Rekaman terstruktur untuk menambahkan data kolom ke hasil. Kueri "Transformasi File" dan "File Sampel" ditautkan, sehingga perubahan pada kueri "File Sampel" terlihat di kueri "Transformasi File".

  • Kueri yang berisi hasil akhir berada di grup "Kueri lain". Secara default, folder diberi nama setelah folder tempat Anda mengimpor file.

Untuk penyelidikan lebih lanjut, klik kanan setiap kueri dan pilih Edit untuk memeriksa setiap langkah kueri dan untuk melihat cara kueri bekerja dalam konser.

Untuk memulai proses penggabungan beberapa file, pastikan terlebih dahulu bahwa semua file yang ingin digabungkan berada dalam satu folder file.

Catatan: Excel file, Teks, CSV, JSON, XML dan Access didukung.

  1. Klik tab Power Query, lalu Dari File > Dari Folder.

    Opsi > Dari File > Dari Folder Power Query
  2. Klik tombol Telusuri untuk menemukan folder Anda.

    Daftar file dalam folder akan muncul. Pilih opsi Edit untuk membuka Editor Kueri. Dalam kasus ini, kami telah memuat 4 Excel kerja.

    Dialog Gabungkan file Biner dengan file yang akan digabungkan
  3. Setelah Anda memverifikasi bahwa semua file yang Anda inginkan tercantum, klik tombol Gabungkan Biner dari kolom Konten.

    Tekan tombol Gabungkan Biner dari kolom konten kueri atau dari bagian Gabungkan di Pita Power Query
  4. Setiap file akan dianalisis, dan format file yang benar ditentukan, seperti teks, Excel atau JSON. Dalam kasus ini, daftar lembar kerja dari buku Excel kerja pertama ditampilkan. Pilih lembar kerja yang ingin Anda gunakan, lalu klik OK.

    Dialog Gabungkan Biner menampilkan lembar Excel kerja yang tersedia untuk memilih target konsolidasi utama
  5. Proses transformasi biner gabungan kemudian akan membuat kueri secara otomatis untuk menggabungkan data dari setiap file dan menampilkan pratinjau. Jika Anda puas dengan hasilnya, klik Tutup & Muat.

    Dialog Gabungkan Pratinjau Biner. Tekan Tutup & Muat untuk menerima hasil dan mengimpornya ke Excel.

    Proses gabungkan biner selanjutnya akan mengonsolidasikan lembar kerja yang tercantum ke dalam satu lembar kerja.

  6. Jika file data asli berubah, Anda selalu bisa melakukan refresh data yang diimpor. Klik di mana saja dalam rentang data, lalu masuk ke Alat Kueri >Refresh. Selain itu, Anda dapat dengan mudah menerapkan langkah-langkah transformasi tambahan atau ekstraksi dengan mengubah kueri contoh yang dibuat secara otomatis, tanpa perlu khawatir tentang langkah-langkah mengubah atau membuat fungsi kueri tambahan; perubahan apa pun pada kueri contoh secara otomatis dihasilkan dalam kueri fungsi yang ditautkan.

Masalah Umum

Saat memuat prosedur biner gabungan untuk Excel Anda mungkin melihat pesan kesalahan berikut:

Menggabungkan pesan kesalahan Biner. Hal ini merupakan bug diketahui yang sedang ditangani.

Jika Anda menghilangkan kesalahan dengan mengklik OK,proses biner gabungan akan selesai dan memuat data Anda dengan benar meski pun terjadi kesalahan. Kami sedang berupaya memperbaiki kesalahan tersebut.

Lihat Juga

Power Query untuk Excel Bantuan

Menambahkan kueri

Menggabungkan gambaran umum file (docs.com)

Menggabungkan file CSV di Power Query (docs.com)

Perlu bantuan lainnya?

Kembangkan keterampilan Office Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung ke Office Insiders

Apakah informasi ini bermanfaat?

×