Considerazioni di progettazione per l'aggiornamento dei dati

Si applica a
Access per Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Un database ben progettato non solo aiuta a garantire l'integrità dei dati, ma è più facile da mantenere e aggiornare. Un database di Access non è un file nello stesso senso di un documento di Microsoft Word o di una presentazione di Microsoft PowerPoint. Si tratta invece di una raccolta di oggetti, ovvero tabelle, maschere, report, query e così via, che devono funzionare insieme per funzionare correttamente.

Gli utenti immettono i dati principalmente tramite controlli. L'operazione da eseguire con un determinato controllo dipende dal tipo di dati impostato per il campo di tabella sottostante, dalle proprietà impostate per tale campo e dalle proprietà impostate per il controllo. Infine, è consigliabile usare altre tecniche di database, ad esempio la convalida, i valori predefiniti, gli elenchi e le ricerche e gli aggiornamenti a catena.

Per altre informazioni sull'aggiornamento dei dati dal punto di vista dell'utente, vedere Modalità di aggiunta, modifica ed eliminazione di record.

Contenuto dell'articolo

Influenza della progettazione dei database sull'immissione dei dati

Le informazioni conservate in un database vengono archiviate in tabelle contenenti dati riguardanti un argomento specifico, ad esempio risorse o contatti. Ogni record in una tabella contiene informazioni su un elemento, ad esempio un contatto specifico. Un record è costituito da campi quali nome, indirizzo e numero di telefono. Un record viene in genere denominato riga, mentre un campo viene in genere chiamato colonna. Questi oggetti devono rispettare un insieme di principi di progettazione, altrimenti il database funzionerà male o non funzionerà del tutto. A loro volta, questi principi di progettazione influiscono sulla modalità di immissione dei dati. Tenere presente quanto segue:

  • Tabelle Access archivia tutti i dati in una o più tabelle. Il numero di tabelle da usare dipende dalla struttura e dalla complessità del database. Anche se è possibile visualizzare i dati in una maschera, un report o nei risultati restituiti da una query, Access archivia i dati solo nelle tabelle e gli altri oggetti del database vengono creati su queste tabelle. Ogni tabella deve essere basata su un argomento. Ad esempio, una tabella di informazioni di contatto aziendale non deve contenere informazioni sulle vendite. In caso affermativo, trovare e modificare le informazioni corrette può diventare difficile, se non impossibile.
  • Tipi di dati In genere, ogni campo di una tabella accetta un solo tipo di dati. Ad esempio, non è possibile archiviare le note in un campo impostato per accettare numeri. Se si prova a immettere testo in un campo di questo tipo, Access visualizza un messaggio di errore. Tuttavia, questa non è una regola ferrea. Ad esempio, è possibile archiviare numeri (ad esempio codici postali) in un campo impostato sul tipo di dati Testo breve, ma non è possibile eseguire calcoli su tali dati perché Access li considera una porzione di testo.
    Con alcune eccezioni, i campi di un record devono accettare un solo valore. Ad esempio, non è possibile immettere più di un indirizzo in un campo indirizzo. Ciò è in contrasto con Microsoft Excel, che consente di immettere un numero qualsiasi di nomi, indirizzi o immagini in una singola cella, a meno che non si imposti tale cella in modo da accettare tipi limitati di dati.
  • Campi multivalore Access offre una caratteristica denominata campo multivalore che consente di allegare più dati a un singolo record e creare elenchi che accettano più valori. È sempre possibile identificare un elenco multivalore perché Access visualizza una casella di controllo accanto a ogni voce di elenco. Ad esempio, è possibile allegare una presentazione di Microsoft PowerPoint e un numero qualsiasi di immagini a un record del database. È anche possibile creare un elenco di nomi e selezionare il numero di nomi necessario. L'uso di campi multivalore può sembrare una violazione delle regole di progettazione dei database perché è possibile archiviare più record per campo di tabella. Ma Access applica le regole "dietro le quinte", archiviando i dati in speciali tabelle nascoste.
  • Usare le maschere Le maschere vengono in genere create per semplificare l'uso di un database e per assicurarsi che gli utenti immettano i dati in modo accurato. Il modo in cui si usa una maschera per modificare i dati dipende dalla struttura della maschera. Le maschere possono contenere un numero indefinito di controlli, ad esempio elenchi, caselle di testo, pulsanti e persino fogli dati. A sua volta, ognuno di tali controlli nella maschera legge i dati da o scrive i dati in un campo tabella sottostante.

Per altre informazioni, vedere Nozioni fondamentali sulla progettazione di database e Creare una tabella e aggiungere campi.

Inizio pagina

Impostare un valore predefinito per un campo o un controllo

Se un numero elevato di record condivide lo stesso valore per un determinato campo, ad esempio una città o un paese/area geografica, è possibile risparmiare tempo impostando un valore predefinito per il controllo associato a tale campo o per il campo stesso. Quando si apre la maschera o la tabella per creare un nuovo record, viene visualizzato il valore predefinito in tale controllo o campo.

In una tabella

  1. Aprire la tabella in Visualizzazione Struttura.
  2. Nella parte superiore della visualizzazione selezionare il campo.
  3. Nella parte inferiore della vista selezionare la scheda Generale .
  4. Impostare la proprietà Valore predefinito sul valore desiderato.

In un modulo

  1. Aprire la maschera in visualizzazione Layout o Struttura.
  2. Fare clic con il pulsante destro del mouse sul controllo che si desidera usare, quindi scegliere Proprietà.
  3. Nella scheda Dati impostare la proprietà Valore predefinito sul valore desiderato.

Inizio pagina

Utilizzo delle regole di convalida per limitare i dati

Le regole di convalida consentono di convalidare i dati nei database desktop di Access durante l'immissione. Le regole di convalida possono essere configurate nella struttura della tabella o nella visualizzazione Foglio dati tabella. Esistono tre tipi di regole di convalida in Access:

  • Regola di convalida campo È possibile usare una regola di convalida campo per specificare un criterio che deve essere soddisfatto in tutti i valori dei campi validi. Non è necessario specificare il campo corrente come parte della regola, a meno che non si usi il campo in una funzione. Le restrizioni sui tipi di caratteri da immettere in un campo possono risultare più semplici usando una maschera di input. Ad esempio, un campo Data può avere una regola di convalida che non consente valori con date passate.
  • Regola di convalida record È possibile usare una regola di convalida record per specificare una condizione che tutti i record validi devono soddisfare. Con questa regola si possono confrontare i valori in campi diversi. Nel caso di un record con due campi data è possibile specificare che i valori di un campo debbano sempre precedere quelli dell'altro campo, ad esempio il valore di DataInizio deve essere precedente a quello di DataFine.
  • Convalida in un modulo È possibile usare la proprietà Valido se di un controllo in una maschera per specificare un criterio che deve essere soddisfatto in tutti i valori immessi in tale controllo. Il funzionamento della proprietà del controllo Valido se è analogo a quello di una regola di convalida campo. In genere viene usata una regola di convalida modulo invece di una regola di convalida campo se la regola si applica solo al modulo e non alla tabella, indipendentemente da dove viene usata.

Per ulteriori informazioni, vedere Limitare l'input di dati utilizzando regole di convalida.

Inizio pagina

Uso degli elenchi di valori e dei campi di ricerca

Esistono due tipi di dati elenco in Access:

  • Elenchi valori Contengono un set di valori a codifica fissa che viene immesso manualmente. I valori si trovano nella proprietà Origine riga del campo.
  • Campi di ricerca Questi usano una query per recuperare valori da un'altra tabella. La proprietà Origine riga del campo contiene una query anziché un elenco di valori hardcoded. La query recupera valori da una o più tabelle in un database. Per impostazione predefinita, il campo di ricerca presenta questi valori sotto forma di elenco. A seconda di come si imposta il campo di ricerca, è possibile selezionare uno o più elementi da tale elenco.
    Avvertenza I campi di ricerca possono confondere i nuovi utenti di Access perché un elenco di elementi viene visualizzato in una posizione (l'elenco creato da Access dai dati nel campo di ricerca), ma i dati possono trovarsi in un'altra posizione (la tabella che contiene i dati).

Per impostazione predefinita, Access visualizza i dati dell'elenco in un controllo casella combinata, anche se è possibile specificare un controllo casella di riepilogo. Una casella combinata si apre per presentare l'elenco e quindi si chiude dopo aver effettuato una selezione. Una casella di riepilogo, al contrario, rimane sempre aperta.

Per modificare gli elenchi, è anche possibile eseguire il comando Modifica voci di elenco oppure modificare i dati direttamente nella proprietà Origine riga della tabella di origine. Quando si aggiornano i dati in un campo di ricerca, si aggiorna la tabella di origine.

Se la proprietà Tipo di origine riga della casella di riepilogo o della casella combinata è impostata su Elenco valori, è possibile modificare l'elenco di valori mentre la maschera è aperta in visualizzazione Maschera, evitando di dover passare alla visualizzazione Struttura o Layout, aprire la finestra delle proprietà e modificare la proprietà Origine riga per il controllo ogni volta che è necessario apportare una modifica all'elenco. Per modificare l'elenco di valori, la proprietà Consenti modifiche a elenco valori della casella di riepilogo o della casella combinata deve essere impostata su Sì.

Per altre informazioni, vedere Creare un elenco di scelte usando una casella di riepilogo o una casella combinata.

Impedire la modifica dell'elenco di valori in visualizzazione Maschera

  1. Fare clic con il pulsante destro del mouse sulla maschera nel riquadro di spostamento e quindi scegliere Visualizzazione Struttura o Visualizzazione Layout.
  2. Fare clic sul controllo per selezionarlo e quindi premere F4 per visualizzare la finestra delle proprietà.
  3. Nella scheda Dati della finestra delle proprietà impostare la proprietà Consenti modifiche a elenco valori su No.
  4. Fare clic su File e quindi su Salva o premere Ctrl+S Immagine del pulsante .

Specificare una maschera diversa per la modifica dell'elenco di valori

Per impostazione predefinita, in Access è disponibile una maschera incorporata per la modifica dell'elenco di valori. Se si preferisce usare una maschera diversa, è possibile immetterne il nome nella proprietà Maschera di modifica voci di elenco come illustrato di seguito:

  1. Fare clic con il pulsante destro del mouse sulla maschera nel riquadro di spostamento e quindi scegliere Visualizzazione Struttura o Visualizzazione Layout dal menu di scelta rapida.
  2. Fare clic sul controllo per selezionarlo e quindi premere F4 per visualizzare la finestra delle proprietà.
  3. Nella scheda Dati della finestra delle proprietà fare clic sulla freccia dell'elenco a discesa nella casella della proprietà Maschera di modifica voci di elenco.
  4. Fare clic sulla maschera da usare per la modifica dell'elenco di valori.
  5. Fare clic sul file e quindi su Salva o premere Ctrl+S Immagine del pulsante .

Esaminare un campo di ricerca in una maschera

  1. Aprire la maschera in visualizzazione Layout o Struttura.

  2. Fare clic con il pulsante destro del mouse sul controllo casella di riepilogo o casella combinata e quindi scegliere Proprietà.

  3. Nella finestra delle proprietà fare clic sulla scheda Tutto e individuare le proprietà Tipo di origine riga e Origine riga . La proprietà Tipo di origine riga deve contenere Elenco valori o Tabella/Query e la proprietà Origine riga deve contenere un elenco di elementi separati da punto e virgola o una query. Per avere più spazio, fare clic con il pulsante destro del mouse sulla proprietà e selezionare Zoom o premere MAIUSC+F2.
    In genere, gli elenchi di valori usano questa sintassi di base: "elemento";" item";" elemento"
    In questo caso, l'elenco è un insieme di elementi racchiusi tra virgolette doppie e separati da punti e virgola.
    Le query di selezione usano questa sintassi di base: SELECT [table_or_query_name].[ field_name**] DAL [table_or_query_name]**.
    In questo caso la query contiene due clausole (SELECT e FROM). La prima clausola fa riferimento a una tabella o query e a un campo in tale tabella o query. La seconda clausola fa riferimento solo alla tabella o alla query. Ecco un punto chiave da ricordare: le clausole SELECT non devono contenere il nome di una tabella o di una query, sebbene sia consigliabile, e devono contenere il nome di almeno un campo. Tuttavia, tutte le clausole FROM devono fare riferimento a una tabella o una query. È quindi sempre possibile trovare la tabella di origine o la query di origine per un campo di ricerca leggendo la clausola FROM.

  4. Eseguire una delle operazioni seguenti.

    • Se si utilizza un elenco di valori, modificare gli elementi nell'elenco. Racchiudere ogni elemento tra virgolette doppie e separare ogni elemento con un punto e virgola.
    • Se la query nell'elenco di ricerca fa riferimento a un'altra query, aprire la seconda query in visualizzazione Struttura facendo clic con il pulsante destro del mouse sulla query nel riquadro di spostamento e quindi scegliendo Visualizzazione Struttura. Prendere nota del nome della tabella visualizzata nella sezione superiore di Progettazione query e quindi procedere al passaggio successivo.
      In caso contrario, se la query nel campo di ricerca fa riferimento a una tabella, prendere nota del nome della tabella e procedere al passaggio successivo.
  5. Aprire la tabella in visualizzazione Foglio dati e quindi modificare le voci di elenco in base alle esigenze.

Esaminare un campo di ricerca in una tabella

  1. Aprire la tabella in Visualizzazione Struttura.

  2. Nella sezione superiore della colonna Tipo di dati della griglia di struttura della query fare clic o posizionare lo stato attivo su un campo di tipo Testo, Numero o Sì/No.

  3. Nella sezione inferiore della griglia di struttura della tabella fare clic sulla scheda Ricerca e quindi esaminare le proprietà Tipo di origine riga e Origine riga .
    La proprietà Tipo di origine riga deve essere Value List o Table/Query. La proprietà Origine riga deve contenere un elenco di valori o una query.
    Gli elenchi di valori usano questa sintassi di base: "item";" item";" elemento"
    In questo caso, l'elenco è un insieme di elementi racchiusi tra virgolette doppie e separati da punti e virgola.
    In genere, le query di selezione usano questa sintassi di base: SELECT [table_or_query_name].[ field_name**] DAL [table_or_query_name]**.
    In questo caso la query contiene due clausole (SELECT e FROM). La prima clausola fa riferimento a una tabella o query e a un campo in tale tabella o query. La seconda clausola fa riferimento solo alla tabella o alla query. Ecco un punto chiave da ricordare: le clausole SELECT non devono contenere il nome di una tabella o di una query, sebbene sia consigliabile, e devono contenere il nome di almeno un campo. Tuttavia, tutte le clausole FROM devono fare riferimento a una tabella o una query. È quindi sempre possibile trovare la tabella di origine o la query di origine per un campo di ricerca leggendo la clausola FROM.

  4. Eseguire una delle operazioni seguenti.

    • Se si utilizza un elenco di valori, modificare gli elementi nell'elenco. Racchiudere ogni elemento tra virgolette doppie e separare ogni elemento con un punto e virgola.
    • Se la query nel campo di ricerca fa riferimento a un'altra query, nel riquadro di spostamento aprire la seconda query in visualizzazione Struttura, facendo clic con il pulsante destro del mouse sulla query e quindi scegliendo Visualizzazione Struttura. Prendere nota del nome della tabella visualizzata nella sezione superiore di Progettazione query e quindi procedere al passaggio successivo.
      In caso contrario, se la query nel campo di ricerca fa riferimento a una tabella, prendere nota del nome della tabella e procedere al passaggio successivo.
  5. Aprire la tabella in visualizzazione Foglio dati e quindi modificare le voci di elenco in base alle esigenze.

Inizio pagina

Eliminazione dei dati da un elenco di valori o da un campo di ricerca

Gli elementi nell'elenco di valori si trovano nella stessa tabella degli altri valori di un record. Al contrario, i dati in un campo di ricerca si trovano in una o più altre tabelle. Per rimuovere dati da un elenco di valori, aprire la tabella e modificare gli elementi.

La rimozione dei dati da un elenco di ricerca richiede altri passaggi, che variano a seconda che la query per gli elenchi di ricerca usi i dati da una tabella o da un'altra query. Se la query per l'elenco di ricerca è basata su una tabella, identificare la tabella e il campo che contiene i dati visualizzati nell'elenco. Aprire quindi la tabella di origine e modificare i dati in questo campo. Se la query per l'elenco di ricerca è basata su un'altra query, è necessario aprire la seconda query, trovare la tabella di origine e il campo da cui la seconda query recupera i dati e modificare i valori in questa tabella.

Rimuovere i dati da un elenco di valori

  1. Aprire la tabella in Visualizzazione Struttura.
  2. Nella sezione superiore della griglia di struttura selezionare il campo della tabella che contiene l'elenco di valori.
  3. Nella sezione inferiore della griglia fare clic sulla scheda Ricerca e trovare la proprietà Origine riga.
    Per impostazione predefinita, gli elementi di un elenco di valori sono racchiusi tra virgolette doppie e i singoli elementi sono separati da punto e virgola: "Excellent";"Fair";"Average";"Poor"
  4. Se necessario, rimuovere gli elementi dall'elenco. Ricordare di eliminare le virgolette che si trovano intorno a ogni elemento eliminato. Inoltre, rimuovere il punto e virgola iniziale, non lasciare più punti e virgola consecutivi (;;) e, se si rimuove l'ultimo elemento dell'elenco, eliminare il punto e virgola finale.
    Consigli Se si elimina un elemento da un elenco di valori e tale elemento viene già utilizzato nei record della tabella, tale elemento eliminato rimane incluso fino a quando non viene modificato. Ad esempio, si supponga che la società abbia un magazzino nella città A, ma decide di vendere l'edificio. Se si rimuove "città A" dall'elenco dei magazzini, resterà comunque nella tabella finché non vengono modificati i valori.

Rimuovere dati da un campo di ricerca

  1. Aprire la tabella in Visualizzazione Struttura.

  2. Nella sezione superiore della griglia di struttura selezionare il campo di ricerca.

  3. Nella sezione inferiore della griglia di struttura fare clic sulla scheda Ricerca e trovare le proprietà Tipo origine riga e Origine riga.
    La proprietà Tipo origine riga dovrebbe visualizzare Tabella/Query, mentre Origine riga deve contenere una query che fa riferimento a una tabella o a un'altra query. Le query per i campi di ricerca iniziano sempre con la parola SELECT.
    In genere (ma non sempre), una query di selezione utilizza questa sintassi di base: SELECT [table_or_query_name].[ field_name*] DA [table_or_query_name]*.
    In questo caso la query contiene due clausole (SELECT e FROM). La prima clausola fa riferimento a una tabella e a un campo della tabella, mentre la seconda clausola fa riferimento esclusivamente alla tabella. Ricordare che: La clausola FROM indicherà sempre il nome della tabella o della query di origine. Le clausole SELECT non contengono sempre il nome di una tabella o di una query, anche se contengono sempre il nome di almeno un campo. Tuttavia, tutte le clausole FROM devono fare riferimento a una tabella o una query.

  4. Eseguire una delle operazioni seguenti:

    • Se la query nel campo di ricerca fa riferimento a un'altra query, fare clic sul pulsante Genera nella scheda Dati della finestra delle proprietà fare clic sul pulsante Generatore accanto per aprire la query in visualizzazione Struttura. Prendere nota del nome della tabella visualizzato nella sezione superiore della finestra Progettazione query, quindi procedere al passaggio 5.
    • Se la query nel campo di ricerca fa riferimento a una tabella, prendere nota del nome della tabella, quindi procedere al passaggio 5.
  5. Aprire la tabella di origine in visualizzazione Foglio dati.

  6. Trovare il campo che contiene i dati usati nell'elenco di ricerca, quindi modificare i dati in base alle esigenze.

Inizio pagina

Influenza dei tipi di dati sulla modalità di immissione dei dati

Quando si progetta una tabella di database, si seleziona un tipo di dati per ogni campo della tabella. Un processo che consente di immettere i dati in modo più accurato.

Visualizzare i tipi di dati

Eseguire una delle operazioni seguenti:

Usa visualizzazione Foglio dati

  1. Aprire la tabella in Visualizzazione Foglio dati.
  2. Nel gruppo Formattazione della scheda Campi esaminare il valore nell'elenco Tipo di dati. Il valore cambia quando si posiziona il cursore nei vari campi della tabella:
    Elenco Tipo di dati

Usare la visualizzazione Struttura

  1. Aprire la tabella in Visualizzazione Struttura.
  2. Osservare la griglia di struttura. Nella sezione superiore della griglia sono indicati il nome e il tipo di dati di ogni campo di tabella.
    Campi in visualizzazione Struttura

Influenza dei tipi di dati sull'immissione di dati

Il tipo di dati impostato per ogni campo di tabella fornisce il primo livello di controllo sul tipo di dati consentiti in un campo. In alcuni casi, ad esempio per un campo di testo lungo, è possibile immettere i dati desiderati. In altri casi, ad esempio nel caso in cui si tratti di un campo di tipo Numerazione automatica, l'impostazione relativa al tipo di dati per il campo impedisce l'immissione di qualsiasi informazione. Nella tabella seguente sono elencati i tipi di dati disponibili in Access e viene descritto il modo in cui influiscono sull'immissione di dati.

Per altre informazioni, vedere Tipi di dati per i database desktop di Access e Modificare o cambiare l'impostazione del tipo di dati per un campo.

Tipo di dati Effetto sull'immissione di dati
Testo breve I campi Testo breve accettano sia testo che caratteri numerici, inclusi elenchi delimitati di elementi. Un campo di testo accetta un numero di caratteri inferiore rispetto a un campo di testo lungo, da 0 a 255 caratteri. In alcuni casi è possibile usare le funzioni di conversione per eseguire calcoli sui dati in un campo di testo breve.
Testo lungo In questo tipo di campo è possibile immettere grandi quantità di dati di testo e numerici, fino a 64.000 caratteri. Inoltre, se impostato il campo in modo da supportare la formattazione RTF, è possibile applicare i tipi di formattazione che si trovano normalmente nei programmi di elaborazione di testo, ad esempio Word. Ad esempio, è possibile applicare tipi di carattere e dimensioni di carattere diversi a caratteri specifici del testo, renderli in grassetto o corsivo e così via. Puoi anche aggiungere tag HTML (Hypertext Markup Language) ai dati. Per ulteriori informazioni, vedere Inserire o aggiungere un campo RTF.
Inoltre, i campi di testo lungo hanno una proprietà denominata Solo accodamento. Quando si abilita questa proprietà, è possibile accodare nuovi dati a un campo di testo lungo, ma non modificare i dati esistenti. La funzionalità è progettata per essere utilizzata in applicazioni come i database di rilevamento dei problemi, in cui potrebbe essere necessario mantenere un record permanente che rimane immutabile. Quando si posiziona il cursore in un campo di testo lungo con la proprietà Solo accodamenti abilitata, per impostazione predefinita il testo nel campo non è più visibile. Non è possibile applicare formattazione o altre modifiche al testo.
Come per i campi di testo breve, è possibile eseguire funzioni di conversione sui dati in un campo di testo lungo.
Numero In questo tipo di campo è possibile immettere solo numeri ed eseguire calcoli sui valori inclusi in un campo numerico.
Numero grande
Nota: i tipi di dati Numero grande sono disponibili solo nella versione di Access con abbonamento a Microsoft 365.
In questo tipo di campo è possibile immettere solo numeri ed eseguire calcoli sui valori in un campo Numero grande.
Per ulteriori informazioni, vedere Uso del tipo di dati Numero grande.
Data e ora In questo tipo di campo è possibile immettere solo date e ore.
È possibile impostare una maschera di input per il campo (ovvero una serie di caratteri letterali e segnaposto che vengono visualizzati quando si seleziona il campo), è necessario immettere i dati negli spazi e nel formato fornito dalla maschera. Se ad esempio viene visualizzata una maschera come MMM_DD_YYYY, è necessario digitare 11 ottobre 2017 negli appositi spazi. Non è possibile immettere un nome completo del mese o un valore dell'anno a due cifre. Per ulteriori informazioni, vedere Controllare i formati di immissione dati con le maschere di input.
Se non si crea una maschera di input, è possibile immettere il valore con qualsiasi formato di data e ora valido. Ad esempio, è possibile digitare 11 ottobre 2017, 11/10/17, 11 ottobre 2017 e così via.
È anche possibile applicare un formato di visualizzazione al campo. In tal caso, se non è presente alcuna maschera di input, è possibile immettere un valore in quasi tutti i formati, ma le date verranno visualizzate in base al formato di visualizzazione. Ad esempio, è possibile immettere 10/11/2017, ma il formato di visualizzazione potrebbe essere impostato in modo che il valore venga visualizzato come 11-Oct-2017.
Per altre informazioni, vedere Inserire la data odierna.
Valuta In questo tipo di campo è possibile immettere solo valori di valuta. Inoltre, non è necessario immettere manualmente un simbolo di valuta. Per impostazione predefinita, Access applica il simbolo di valuta ( ¥, £, $ e così via) specificato nelle impostazioni internazionali di Windows. Se necessario, è possibile modificare questo simbolo di valuta per riflettere una valuta diversa.
Contatore Non è possibile immettere o modificare i dati in questo tipo di campo in nessun momento. Access incrementa i valori in un campo Numerazione automatica ogni volta che si aggiunge un nuovo record a una tabella.
Valore calcolato Non è possibile immettere o modificare i dati in questo tipo di campo in nessun momento. I risultati di questo campo sono determinati da un'espressione definita dall'utente. Access aggiorna i valori in un campo calcolato ogni volta che si aggiunge o si modifica un nuovo record in una tabella.
Sì/No Quando si fa clic su un campo impostato su questo tipo di dati, Access visualizza una casella di controllo o un elenco a discesa, a seconda di come viene formattato il campo. Se si formatta il campo per visualizzare un elenco, è possibile selezionare Sì o No, Vero o Falso oppure Attivato o Disattivato dall'elenco, sempre a seconda del formato applicato al campo. Non è possibile immettere valori nell'elenco o modificare i valori nell'elenco direttamente da una maschera o una tabella.
Oggetto OLE Questo tipo di campo viene utilizzato per visualizzare i dati di un file creato con un altro programma. Ad esempio, è possibile visualizzare un file di testo, un grafico di Excel o una presentazione di PowerPoint in un campo Oggetto OLE.
Gli allegati forniscono un modo più rapido, semplice e flessibile per visualizzare i dati di altri programmi.
Collegamento ipertestuale È possibile immettere qualsiasi tipo di dati in questo tipo di campo e Access li incapsula in un indirizzo Web. Se ad esempio si digita un valore nel campo, il testo viene racchiuso tra http://www,your_text**.com**. Se immetti un indirizzo Web valido, il collegamento funzionerà. In caso contrario, il collegamento genererà un messaggio di errore.
Inoltre, la modifica dei collegamenti ipertestuali esistenti può essere di difficile effetto perché facendo clic con il mouse su un campo di collegamento ipertestuale si avvia il browser e si accede al sito specificato nel collegamento. Per modificare un campo di collegamento ipertestuale, selezionare un campo adiacente, usare TAB o i tasti di direzione per spostare lo stato attivo sul campo del collegamento ipertestuale e quindi premere F2 per abilitare la modifica.
Allegato È possibile allegare dati di altri programmi a questo tipo di campo, ma non è possibile digitare o immettere in altro modo testo o dati numerici.
Per ulteriori informazioni, vedere Allegare file e grafica ai record del database.
Ricerca guidata La Ricerca guidata non è un tipo di dati. La procedura guidata consente invece di creare due tipi di elenchi a discesa, ovvero elenchi di valori e campi di ricerca. Un elenco di valori usa un elenco delimitato di elementi immesso manualmente quando si usa la Ricerca guidata. Questi valori possono essere indipendenti da qualsiasi altro oggetto o dato presente nel database.
Al contrario, un campo di ricerca usa una query per recuperare dati da una o più altre tabelle in un database. Il campo di ricerca visualizza quindi i dati in un elenco a discesa. Per impostazione predefinita, la Ricerca guidata imposta il campo della tabella sul tipo di dati Numerico.
I campi di ricerca possono essere usati direttamente nelle tabelle, ma anche in maschere e report. Per impostazione predefinita, i valori in un campo di ricerca vengono visualizzati in un tipo di controllo elenco denominato casella combinata, ovvero un elenco con una freccia a discesa:
Elenco di ricerca vuoto
È anche possibile usare una casella di riepilogo che mostra diversi elementi con una barra di scorrimento per visualizzare più elementi:
Controllo Casella di riepilogo in una maschera
A seconda di come si impostano il campo di ricerca e la casella combinata, è possibile modificare gli elementi nell'elenco e aggiungerli all'elenco disattivando la proprietà Limita a elenco del campo di ricerca.
Se non è possibile modificare direttamente i valori in un elenco, è necessario aggiungere o modificare i dati nell'elenco di valori predefinito o nella tabella che funge da origine per il campo di ricerca.
Infine, quando si crea un campo di ricerca, è possibile impostarlo facoltativamente per supportare più valori. Quando si esegue questa operazione, nell'elenco risultante viene visualizzata una casella di controllo accanto a ogni voce di elenco ed è possibile selezionare o deselezionare il numero di elementi necessario. Questa figura illustra un tipico elenco multivalore:
Elenco con casella di controllo.
Per informazioni sulla creazione di campi di ricerca multivalore e sull'utilizzo degli elenchi risultanti, vedere Creare o eliminare un campo multivalore.

Inizio pagina

Influenza delle proprietà dei campi di tabella sulla modalità di immissione dei dati

Oltre ai principi di progettazione che controllano la struttura di un database e ai tipi di dati che controllano cosa è possibile immettere in un determinato campo, anche diverse proprietà dei campi possono influire sulla modalità di immissione dei dati in un database di Access.

Visualizzare le proprietà di un campo di tabella

Access offre due modi per visualizzare le proprietà di un campo di tabella.

In visualizzazione Foglio dati

  1. Aprire la tabella in Visualizzazione Foglio dati.
  2. Fare clic sulla scheda Campi e usare i controlli del gruppo Formattazione per visualizzare le proprietà di ogni campo di tabella.

Nella visualizzazione Struttura

  1. Aprire la tabella in Visualizzazione Struttura.
  2. Nella parte inferiore della griglia fare clic sulla scheda Generale , se non è già selezionata.
  3. Per visualizzare le proprietà di un campo di ricerca, fare clic sulla scheda Ricerca .

Impatto delle proprietà sull'immissione di dati

Nella tabella seguente sono elencate le proprietà che hanno un maggiore impatto sull'immissione di dati e viene spiegato in che modo influiscono sull'immissione di dati.

Proprietà Posizione nella griglia di struttura della tabella Valori possibili Comportamento quando si tenta di immettere dati
Dimensione campo Scheda Generale 0-255 Il limite di caratteri si applica solo ai campi impostati per il tipo di dati Testo. Se si prova a immettere un numero di caratteri superiore a quello specificato, il campo li taglia.
Obbligatorio Scheda Generale Sì/No Quando è attivata, questa proprietà impone l'immissione di un valore in un campo e Access non consente di salvare i nuovi dati finché non viene completato un campo obbligatorio. Quando è disattivata, il campo accetta valori Null, ovvero il campo può rimanere vuoto.
Un valore nullo non equivale a un valore zero. Zero è una cifra e "Null" è un valore mancante, non definito o sconosciuto.
Consenti stringhe di lunghezza zero Scheda Generale Sì/No Quando è attivata, è possibile immettere stringhe di lunghezza zero, ovvero stringhe che non contengono caratteri. Per creare una stringa di lunghezza zero, immettere una coppia di virgolette doppie nel campo ("").
Indicizzato Scheda Generale Sì/No Quando si indicizza un campo di tabella, Access impedisce l'aggiunta di valori duplicati. È anche possibile creare un indice da più campi. Se si esegue questa operazione, è possibile duplicare i valori di un campo, ma non di entrambi.
Maschera di input Scheda Generale Set predefiniti o personalizzati di caratteri letterali e segnaposto Una maschera di input impone l'immissione di dati in un formato predefinito. Le maschere vengono visualizzate quando si seleziona un campo in una tabella o un controllo in una maschera. Si supponga, ad esempio, di fare clic su un campo di tipo Data e di visualizzare questo set di caratteri: MMM-GG-AAAA. Questa è una maschera di input. Impone di immettere i valori del mese con abbreviazioni di tre lettere, ad esempio lo Strumento di personalizzazione di Office, e il valore dell'anno come formato di quattro cifre, ad esempio OCT-15-2017.
Le maschere di input controllano solo la modalità di immissione dei dati e non la modalità di archiviazione o visualizzazione di tali dati in Access.
Per ulteriori informazioni, vedere Controllare i formati di immissione dati con le maschere di input e Formattare un campo di data e ora.
Limita all'elenco Scheda Ricerca Sì/No Abilita o disabilita le modifiche apportate agli elementi in un campo di ricerca. A volte gli utenti tentano di modificare manualmente gli elementi in un campo di ricerca. Se Access impedisce di modificare gli elementi in un campo, questa proprietà viene impostata su Sì. Se questa proprietà è abilitata ed è necessario modificare gli elementi di un elenco, è necessario aprire l'elenco (se si desidera modificare un elenco di valori) o la tabella che contiene i dati di origine per l'elenco (se si desidera modificare un campo di ricerca) e modificarvi i valori.
Consenti modifiche a elenco valori Scheda Ricerca Sì/No Abilita o disabilita il comando Modifica voci di elenco per gli elenchi di valori, ma non per i campi di ricerca. Per abilitare questo comando per i campi di ricerca, immettere un nome di modulo valido nella proprietà Modifica modulo voci elenco . Il comando Consenti modifiche elenco valori viene visualizzato in un menu di scelta rapida che si apre facendo clic con il pulsante destro del mouse su un controllo casella di riepilogo o casella combinata. Quando si esegue il comando, viene visualizzata la finestra di dialogo Modifica voci di elenco . In alternativa, se si specifica il nome di una maschera nella proprietà Modifica maschera voci di elenco, la maschera verrà avviata anziché essere visualizzata nella finestra di dialogo.
È possibile eseguire il comando Modifica voci di elenco dai controlli casella di riepilogo e casella combinata presenti nelle maschere e dai controlli casella combinata situati nelle tabelle e nei set di risultati della query. Le maschere devono essere aperte in visualizzazione Struttura o Sfoglia. Le tabelle e i set di risultati della query devono essere aperti in visualizzazione Foglio dati.
Maschera di modifica voci di elenco Scheda Ricerca Nome di un modulo di immissione dati Se si immette il nome di una maschera di immissione dati come valore nella proprietà della tabella, la maschera viene aperta quando un utente esegue il comando Modifica voci di elenco . In caso contrario, quando gli utenti eseguono il comando, viene visualizzata la finestra di dialogo Modifica voci di elenco .

Inizio pagina

Usare gli aggiornamenti a catena per modificare i valori di chiave primaria ed esterna

A volte può essere necessario aggiornare un valore di chiave primaria. Se si usa la chiave primaria come chiave esterna, è possibile aggiornare automaticamente le modifiche tramite tutte le istanze figlio della chiave esterna.

Come promemoria, una chiave primaria è un valore che identifica in modo univoco ogni riga (record) in una tabella di database. Una chiave esterna è una colonna che corrisponde alla chiave primaria. In genere, le chiavi esterne si trovano in altre tabelle e consentono di creare una relazione (un collegamento) tra i dati nelle tabelle.

Si supponga, ad esempio, di usare un numero ID prodotto come chiave primaria. Un numero ID identifica in modo univoco un prodotto. Tale numero ID può essere usato anche come chiave esterna in una tabella di dati degli ordini. In questo modo, puoi trovare tutti gli ordini che coinvolgono ogni prodotto, perché ogni volta che qualcuno effettua un ordine per quel prodotto, l'ID diventa parte dell'ordine.

A volte, questi numeri ID (o altri tipi di chiavi primarie) cambiano. In questo caso, è possibile modificare il valore della chiave primaria e fare in modo che la modifica si propaga automaticamente a tutti i record figlio correlati. Questo comportamento viene abilitato attivando l'integrità referenziale e gli aggiornamenti a catena tra le due tabelle.

Tenere presente queste importanti regole:

  • È possibile abilitare gli aggiornamenti a catena solo per i campi di chiave primaria impostati sui tipi di dati Testo o Numerico. Non è possibile utilizzare gli aggiornamenti a catena per i campi impostati con il tipo di dati Numerazione automatica.
  • È possibile abilitare gli aggiornamenti a catena solo tra tabelle con una relazione uno-a-molti.

Per altre informazioni sulla creazione di relazioni. Vedere Guida alle relazioni tra tabelle e Creare, modificare o eliminare una relazione.

Le procedure seguenti vengono descritte di pari passo e come creare prima di tutto una relazione e quindi abilitare gli aggiornamenti a catena per tale relazione.

Creare la relazione

  1. Nel gruppo Mostra/Nascondi della scheda Strumenti database fare clic su Relazioni.
  2. Nel gruppo Relazioni della scheda Progettazione fare clic su Aggiungi tabelle (Mostra tabella in Access).
  3. Selezionare la scheda Tabelle , selezionare le tabelle che si desidera modificare, fare clic su Aggiungi e quindi su Chiudi.
    È possibile premere MAIUSC per selezionare più tabelle oppure aggiungere ogni tabella singolarmente. Selezionare solo le tabelle sui lati "uno" e "molti" della relazione.
  4. Nella finestra Relazioni trascinare la chiave primaria dalla tabella sul lato "uno" della relazione e rilasciarla nel campo chiave esterna della tabella sul lato "molti" della relazione.
    Verrà visualizzata la finestra di dialogo Modifica relazioni. La figura seguente mostra la finestra di dialogo:
    Finestra di dialogo Modifica relazioni con una relazione esistente
  5. Selezionare la casella di controllo Applica integrità referenziale e fare clic su Crea.

Abilitare gli aggiornamenti a catena nelle chiavi primarie

  1. Nel gruppo Mostra/Nascondi della scheda Strumenti database fare clic su Relazioni.
  2. Viene visualizzata la finestra Relazioni con i join (indicati come linee di connessione) tra le tabelle nel database. La figura seguente mostra una relazione tipica:
  3. Fare clic con il pulsante destro del mouse sulla linea di join tra le tabelle padre e figlio e quindi scegliere Modifica relazione.
    Relazione tra due tabelle
    Verrà visualizzata la finestra di dialogo Modifica relazioni. La figura seguente mostra la finestra di dialogo:
    Finestra di dialogo Modifica relazioni
  4. Selezionare Aggiorna campi correlati a catena, verificare che la casella di controllo Applica integrità referenziale sia selezionata e quindi fare clic su OK.

Inizio pagina

Perché a volte i numeri ID sembrano omettere un numero

Quando si crea un campo impostato sul tipo di dati Numerazione automatica, Access genera automaticamente un valore per tale campo in ogni nuovo record. Il valore viene incrementato per impostazione predefinita, in modo che ogni nuovo record ottenga il successivo numero sequenziale disponibile. Lo scopo del tipo di dati Numerazione automatica è fornire un valore adatto per essere utilizzato come chiave primaria. Per ulteriori informazioni, vedere Aggiungere, impostare, modificare o rimuovere la chiave primaria.

Quando si elimina una riga da una tabella che contiene un campo impostato sul tipo di dati Numerazione automatica, il valore del campo Numerazione automatica per tale riga non viene sempre riutilizzato automaticamente. Per questo motivo, il numero generato da Access potrebbe non essere quello previsto e nella sequenza di numeri ID potrebbero comparire degli spazi vuoti. Si tratta di un'impostazione predefinita. In un campo di tipo Numerazione automatica è consigliabile fare affidamento solo sull'univocità dei valori e non sulla loro sequenza.

Inizio pagina

Aggiornamento in blocco dei dati tramite query

Le query di accodamento, aggiornamento ed eliminazione sono modi efficaci per aggiungere, modificare o rimuovere record in blocco. Inoltre, gli aggiornamenti in blocco sono più facili ed efficienti da eseguire quando si utilizzano principi validi di progettazione dei database. L'uso di una query di accodamento, aggiornamento o eliminazione consente di risparmiare tempo perché è anche possibile riutilizzare la query.

Consigli Eseguire un backup dei dati prima di usare queste query. Avere un backup a portata di mano può aiutarti a correggere rapidamente eventuali errori che potresti commettere inavvertitamente.

Query di accodamento Consente di aggiungere molti record a una o più tabelle. Una query di accodamento viene spesso usata per aggiungere un gruppo di record da una o più tabelle in un database di origine a una o più tabelle in un database di destinazione. Si supponga, ad esempio, di acquisire alcuni nuovi clienti e un database contenente una tabella di informazioni su tali clienti. Per evitare di immettere manualmente i nuovi dati, è possibile accodarli alla tabella o alle tabelle appropriate del database. Per altre informazioni, vedere Aggiungere record a una tabella usando una query di accodamento.

Query di aggiornamento Consente di aggiungere, modificare o eliminare parte (ma non tutto) di molti record esistenti. Le query di aggiornamento possono essere considerate un equivalente estremamente efficace della finestra di dialogo Trova e sostituisci. Immetti un criterio di selezione (l'equivalente approssimativo di una stringa di ricerca) e un criterio di aggiornamento (l'equivalente approssimativo di una stringa di sostituzione). A differenza della finestra di dialogo, le query di aggiornamento possono accettare più criteri, consentire di aggiornare un numero elevato di record in un solo passaggio e consentire di modificare i record in più di una tabella. Per altre informazioni, vedere Creare ed eseguire una query di aggiornamento.

Query di eliminazione Quando si desidera eliminare rapidamente molti dati o eliminare un set di dati su base regolare, l'eliminazione è utile perché le query consentono di specificare criteri per trovare ed eliminare rapidamente i dati. Per altre informazioni, vedere Modalità di aggiunta, modifica ed eliminazione di record.

Inizio pagina