Risoluzione dei problemi di installazione dei service pack per Windows Vista e Windows Server 2008

Il supporto per Windows Vista senza alcun Service Pack installato non è più disponibile dal 13 aprile 2010. Per continuare a ricevere gli aggiornamenti della protezione per Windows, utilizzare Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento alla pagina Web Microsoft riportata di seguito: Per alcune versioni di Windows, il supporto non è più disponibile

Sintomi
In questo articolo vengono descritti i problemi che potrebbero verificarsi durante l'installazione di un service pack per Windows Vista o Windows Server 2008.

Quando si tenta di installare un service pack, è possibile che venga visualizzato un messaggio di errore analogo a uno dei seguenti:
Installazione non riuscita.
Errore interno durante l'installazione del service pack.
Il messaggio di errore può inoltre fare riferimento a uno dei seguenti codici di errore:
  • 0x80070002
  • 0x8007000D
  • 0x80073712
  • 0x800B0100
  • 0x8024200D
Nota In questo articolo non vengono elencati tutti i possibili codici errore o messaggi di errore che potrebbero essere visualizzati. Si consiglia di fare riferimento alle soluzioni presenti in questo articolo per la risoluzione dei problemi di installazione, indipendentemente dal codice o dal messaggio di errore visualizzato.

Nota Se viene visualizzato il codice di errore "0x80070490", visitare il seguente sito Web Microsoft per la risoluzione dei problemi:
958044 Viene visualizzato un codice di errore "0x80070490" quando si utilizzano i siti Web Windows Update o Microsoft Update per installare gli aggiornamenti
Cause
È possibile che questo problema si verifichi in presenza di una delle seguenti condizioni:
  • Un programma presente sul computer interferisce con l'installazione di Service Pack.
  • È stata rilevata un'incoerenza nell'archivio di manutenzione di Windows. L'archivio di manutenzione di Windows è un componente necessario alla corretta installazione di Service Pack.
Risoluzione dei problemi di installazione dei service pack per Windows Vista e Windows Server 2008
Per risolvere questo problema, provare ciascuna delle soluzioni nelle sezioni "Risoluzione generale dei problemi" e "Risoluzione avanzata dei problemi" nell'ordine in cui tali soluzioni vengono presentate. Dopo aver eseguito una soluzione, provare a installare nuovamente Service Pack. Se non è possibile installare Service Pack, provare a utilizzare la soluzione successiva.

Risoluzione generale dei problemi

Soluzione 1: Installare il pacchetto autonomo per il service pack anziché utilizzare Windows Update per installare il service pack

Nota Se si è già tentato di installare il pacchetto autonomo per il service pack e si è verificato il problema, saltare questa soluzione e passare alla Soluzione 2.

Se non si è certi di aver tentato l'installazione del pacchetto autonomo per il service pack, si consiglia di effettuare la seguente procedura per installarlo. L'utilizzo del pacchetto autonomo per il service pack consente di escludere eventuali problemi di installazione relativi a Windows Update. In questo modo si semplifica il processo di risoluzione dei problemi.

Come ottenere il pacchetto autonomo per il service pack

Per ottenere il service pack, fare riferimento ai seguenti articoli della Microsoft Knowledge Base in base al sistema operativo in uso, quindi individuare l'opzione per l'installazione del service pack dall'Area Download Microsoft.
935791 Come ottenere il Service Pack più recente per Windows Vista
968849 Come ottenere il Service Pack più recente per Windows Server 2008

Soluzione 2: Eseguire lo strumento System Update Readiness Tool, riavviare il computer e installare il service pack

Lo strumento System Update Readiness Tool consente di analizzare il computer in uso e tenta di risolvere alcuni problemi che potrebbero interferire con l'installazione degli aggiornamenti o di un altro software. Tuttavia, prima di scaricare lo strumento, occorre sapere se sul computer è in esecuzione la versione a 32 bit o la versione a 64 bit del sistema operativo Windows Vista. Se sul computer è installato Windows Vista e la versione in esecuzione è nota, accedere alla sezione "Download dello strumento System Update Readiness Tool".

In caso di dubbi sul tipo di versione installata nel computer, attenersi alla seguente procedura

  1. Fare clic sul pulsante StartPulsante Start.
  2. Nella casella di ricerca, digitare sistema, quindi fare clic su Sistema nell'elenco Programmi.

Il sistema operativo viene visualizzato come segue:
  • Per una versione del sistema operativo a 32 bit, nella colonna Sistema viene visualizzato Sistema operativo a 32 bit come tipo di sistema.
  • Nel caso di una versione a 64 bit del sistema operativo, come tipo di sistema compare Sistema operativo a 64 bit in Sistema.


Nota Sistema operativo a 32 bit = Sistema operativo basato su x86 e Sistema operativo a 64 bit = Sistema operativo basato su x64.


Dopo aver determinato la versione di Windows Vista in esecuzione sul computer, scaricare lo strumento System Update Readiness Tool.

Download dello strumento System Update Readiness Tool

È possibile fare clic qui per scaricare lo strumento System Update Readiness Tool dall'Area download Microsoft sul sito Web di seguito indicato.I seguenti file sono disponibili per il download nell'Area download Microsoft:
DownloadDownload del pacchetto System Update Readiness Tool per Windows Vista (KB947821).

DownloadDownload del pacchetto System Update Readiness Tool per Windows Vista x64 (KB947821).

DownloadDownload del pacchetto System Update Readiness Tool per Windows Server 2008 (KB947821).

DownloadDownload del pacchetto System Update Readiness Tool per Windows Server 2008 x64 (KB947821).

DownloadDownload del pacchetto System Update Readiness Tool per sistemi basati su Itanium (KB947821).

Una volta scaricato lo strumento System Update Readiness Tool, riavviare il computer. Quindi, provare a installare il pacchetto di download completo per il service pack precedentemente scaricato dall'Area download Microsoft all'indirizzo seguente:Per ulteriori informazioni sullo strumento System Update Readiness Tool, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
947821 Descrizione dello strumento System Update Readiness Tool per Windows Vista e Windows Server 2008

Soluzione 3: Chiudere o disattivare tutte le applicazioni in esecuzione, riavviare il computer, quindi installare Service Pack

Importante Questa procedura può aumentare i rischi per la protezione. L'esecuzione di questa procedura potrebbe inoltre rendere il computer o la rete più vulnerabile agli attacchi di utenti malintenzionati o programmi software dannosi, quali i virus. Si consiglia di attenersi alla procedura descritta nel presente articolo per attivare i programmi perché funzionino secondo lo scopo per cui sono stati progettati o per implementare specifiche funzionalità delle applicazioni. Prima di apportare tali modifiche, si consiglia di valutare i rischi derivanti dall'implementazione di questo processo in un ambiente particolare. Se si decide di implementare questo processo, adottare ogni ulteriore procedura che faciliti la protezione del sistema. Si consiglia di utilizzare la presente procedura solo se è effettivamente necessaria.

Nel corso dell'installazione, una delle cause più comuni di esito negativo si verifica quanto un file richiesto dal programma di installazione del Service Pack è aperto o bloccato da un'applicazione di terze parti. Questo problema potrebbe essere causato, ad esempio, da un programma antivirus o un'applicazione antispyware di terze parti. Per ridurre tale possibilità, attenersi alla seguente procedura:
  1. Chiudere tutte le applicazioni, quindi riavviare il computer.
  2. Dopo il riavvio del computer, disattivare qualsiasi applicazione antivirus o antispyware di terze parti eventualmente caricata durante il processo di riavvio. In genere queste applicazioni possono essere disattivate dall'area di notifica. L'area si trova nell'angolo in basso a destra dello schermo. Per disattivare l'applicazione dall'area di notifica, attenersi alla procedura riportata di seguito:
    1. Fare clic con il pulsante destro del mouse sull'icona del programma di terze parti.
    2. Fare clic su Chiudi, Disabilita, Esci, o sulla voce più simile a una di queste. Se tale opzione non fosse disponibile, potrebbe essere necessario avviare l'applicazione, quindi chiudere o disabilitare l'opzione dall'interno dell'applicazione stessa.
  3. Non appena viene chiusa l'applicazione antivirus o antispyware, provare a fare clic qui per installare il pacchetto di download completo per il service pack precedentemente scaricato dall'Area download Microsoft all'indirizzo seguente.
  4. Dopo avere completato l'installazione di Service Pack, attivare l'applicazione antivirus o antispyware disattivata nel passaggio precedente.
Risoluzione avanzata dei problemi
Se il problema non risulta ancora risolto, provare i passaggi descritti nella sezione relativa alla risoluzione avanzata dei problemi, oppure contattare il supporto tecnico Microsoft.

Soluzione 4: Disinstallare ogni applicazione di protezione, riavviare il computer, quindi installare il service pack

Importante Questa procedura può aumentare i rischi per la protezione. L'esecuzione di questa procedura potrebbe inoltre rendere il computer o la rete più vulnerabile agli attacchi di utenti malintenzionati o programmi software dannosi, quali i virus. Si consiglia di attenersi alla procedura descritta nel presente articolo per attivare i programmi perché funzionino secondo lo scopo per cui sono stati progettati o per implementare specifiche funzionalità delle applicazioni. Prima di apportare tali modifiche, si consiglia di valutare i rischi derivanti dall'implementazione di questo processo in un ambiente particolare. Se si decide di implementare questo processo, adottare ogni ulteriore procedura che faciliti la protezione del sistema. Si consiglia di utilizzare la presente procedura solo se è effettivamente necessaria.

Un'applicazione di protezione di terze parti (ad esempio un'applicazione antivirus, un firewall o un'applicazione antispyware), continui a impedire la corretta installazione anche dopo che si è tentato di disabilitarla. L'installazione di Windows Vista SP1 richiede diversi riavvii del computer ed è possibile che l'applicazione di protezione venga ricaricata dopo il primo riavvio. Anche le applicazioni che forniscono funzionalità di ripristino del Registro di sistema possono impedire l'installazione.

È possibile disinstallare l'applicazione di protezione di terze parti prima di installare Service Pack. Effettuare tale operazione solo qualora sia possibile reinstallare l'applicazione al termine dell'installazione di Service Pack. Per reinstallare l'applicazione di protezione di terze parti, sarà necessario disporre del relativo supporto di installazione originale o della versione scaricata originale. Per la reinstallazione di tale applicazione potrebbe inoltre essere necessario un codice "Product Key".

Se si è certi di poter reinstallare l'applicazione di terze parti in uso, disinstallarla utilizzando Programmi e funzionalità nel Pannello di controllo. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Chiudere tutte le applicazioni, quindi riavviare il computer.
  2. Una volta riavviato il computer, fare clic su Startpulsante Start.
  3. Nella casella di ricerca, digitare programmi.
  4. Fare clic su Programmi e funzionalità.
  5. Fare clic sul nome del programma di protezione da disinstallare.
  6. Scegliere Disinstalla.
  7. Dopo avere disinstallato il programma, riavviare il computer.
  8. Provare a fare clic qui per installare il pacchetto di download completo del service pack precedentemente scaricato dall'Area download Microsoft all'indirizzo seguente.
    Nota Dopo avere disinstallato il software di protezione, il computer sarà più vulnerabile agli attacchi di utenti malintenzionati o programmi software dannosi, ad esempio i virus. Si consiglia di non esplorare il Web, utilizzare la posta elettronica o Messaggistica immediata, finché non sarà stata completata la procedura di risoluzione del problema e non si sarà reinstallato il software di protezione.
  9. Dopo avere completato l'installazione di Windows Vista SP1, reinstallare il programma di protezione disinstallato nel passaggio precedente.
Nota Se il problema non viene risolto, non è possibile ottenere ulteriore assistenza tramite questo contenuto. Visitare quindi il seguente sito Web Microsoft:
Problemi e soluzioni analoghi
Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
971204 L'installazione del service pack di Windows Vista e Windows Server 2008 non riesce con l'errore 0x80004005
939399 Messaggio di errore quando si tenta di effettuare un'operazione di backup su un computer che esegue Windows Vista: "0x80071A91"
931712 In Windows Vista, la finestra di dialogo "Funzionalità di Windows" è vuota o quando si tenta di utilizzare Windows Update viene visualizzato un messaggio di errore contenente il codice seguente: "0x80073712"
Se il problema non viene risolto, non è possibile ottenere ulteriore assistenza tramite questo contenuto. Cercare quindi nella Microsoft Knowledge Base per altre soluzioni. visitando il sito Web Microsoft riportato di seguito:
vista sp1
Proprietà

ID articolo: 947366 - Ultima revisione: 02/22/2013 09:53:00 - Revisione: 10.0

Windows Vista Service Pack 1, Windows Vista Service Pack 2

  • kbproductlink kbexpertisebeginner kbtshoot kbpubtypekc kberrmsg kbprb kbcip KB947366
Feedback