Formule e funzioni

CERCA.X

CERCA.X (funzione CERCA.X)

Usare la funzione CERCA.X per trovare elementi in una tabella o un intervallo per riga. Ad esempio è possibile cercare il prezzo di un componente di un’auto in base al numero del pezzo o trovare il nome di un dipendente in base al suo ID dipendente. Con CERCA.X è possibile cercare un termine di ricerca in una colonna e ottenere un risultato nella stessa riga ma in un'altra colonna, indipendentemente dal lato in cui si trova la colonna del risultato.

Il browser in uso non supporta le funzionalità video.

Sintassi

La funzione CERCA.X esegue la ricerca in un intervallo o in una matrice e quindi restituisce l'elemento corrispondente alla prima corrispondenza che trova. Se non esiste alcuna corrispondenza, CERCA.X può restituire la corrispondenza più vicina (approssimativa). 

=CERCA.X(valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca]) 

Argomento

Descrizione

valore

Obbligatorio*

Valore da cercare

*Se questo argomento viene omesso, CERCA.X restituirà le celle vuote che trova nella lookup_array.   

matrice

Obbligatorio

La matrice o l’intervallo in cui effettuare la ricerca

matrice_restituita

Obbligatorio

La matrice o l’intervallo da restituire

[se_non_trovato]

Facoltativo

Se non è stata trovata una corrispondenza valida, restituire il testo [se_non_trovato] che si specifica.

Se non viene trovata una corrispondenza valida e [if_not_found] non è presente, #N/A.

[modalità_confronto]

Facoltativo

Specificare il tipo di corrispondenza:

0 - Corrispondenza esatta. Se non trovata, restituisce #N/D. Questa è l’impostazione predefinita.

-1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più piccolo.

1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più grande.

2 - Una corrispondenza jolly in cui *, ? e ~ hanno un significato speciale.

[modalità_ricerca]

Facoltativo

Specificare la modalità di ricerca da usare:

1 - Effettuare una ricerca a partire dal primo elemento. Questa è l’impostazione predefinita.

-1 - Effettuare una ricerca inversa a partire dall’ultimo elemento.

2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine crescente. Se non è classificata, vengono restituiti risultati non validi.

- 2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine decrescente. Se non è classificata, vengono restituiti risultati non validi.

Esempi

Nell'esempio 1    viene utilizzata la funzione CERCA.X per cercare il nome di un paese in un intervallo e restituire il relativo codice paese telefonico. Include gli argomenti lookup_value (cella F2), lookup_array (intervallo B2:B11) e return_array (intervallo D2:D11). Non include l'argomento match_mode, perché per impostazione predefinita CERCA.X restituisce una corrispondenza esatta.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:C14).

Nota: CERCA.X utilizza una matrice di ricerca e una matrice restituita, mentre CERCA.OK usa una singola matrice di tabella seguita da un numero di indice di colonna. La formula CERCA.V equivalente in questo caso sarà: =CERCA.V(F2;B2:D11;3;FALSO)

———————————————————————————

Nell'esempio 2    vengono cercate le informazioni sui dipendenti in base al numero di ID di un dipendente. A differenza di CERCA.V, CERCA.X può restituire una matrice con più elementi, quindi una singola formula può restituire sia il nome del dipendente che il reparto dalle celle C5:D14.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1)

———————————————————————————

Nell'esempio 3    viene if_not_found un argomento della tabella all'esempio precedente.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente con l’argomento se_non_trovato. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1, “dipendente non trovato”)

———————————————————————————

L'esempio 4    cerca nella colonna C il reddito personale immesso nella cella E2 e trova un'aliquota di imposta corrispondente nella colonna B. Imposta l'argomento if_not_found restituire 0 (zero) se non viene trovato alcun valore. L match_mode argomento è impostato su 1,ovvero la funzione cerca una corrispondenza esatta e, se non trova una corrispondenza, restituisce l'elemento successivo più grande. Infine, l search_mode asalto è impostato su 1,il che significa che la funzione cerca dal primo all'ultimo elemento.

Immagine della funzione CERCA.X usata per restituire un'aliquota di imposta in base al reddito massimo. Si tratta di una corrispondenza approssimativa. La formula è: =CERCA.X(E2,C2:C7,B2:B7,1,1)

Nota: La colonna di lookup_array XARRAY si trova a destra della colonna return_array, mentre CERCA.DESCRIZIONE può cercare solo da sinistra a destra.

———————————————————————————

Esempio 5    usa una funzione CERCA.X annidata per eseguire una corrispondenza verticale e orizzontale. Cerca prima di tutto il Profitto lordo nella colonna B, quindi cerca Il trimestre nella riga superiore della tabella (intervallo C5:F5) e infine restituisce il valore all'intersezione delle due. È simile all'uso delle funzioni INDICEe MATCH insieme.

Suggerimento: È anche possibile usare CERCA.X al posto della funzione CERCA.ORIZZ.

Immagine della funzione CERCA.X usata per restituire dati orizzontali da una tabella annidando due CERCA.X. La formula è: =CERCA.X(D2,$B6:$B17,CERCA.X($C3,$C5:$G5,$C6:$G17))

Nota: La formula nelle celle D3:F3 è: =CERCA.X(D2,$B 6:$B 17,CERCA.X($C 3,$C 5:$G 5,$C 6:$G 17)).

———————————————————————————

Esempio 6    usa la funzione SOMMAe due funzioni CERCA.X annidate per sommare tutti i valori compresi tra due intervalli. In questo caso, si vogliono sommare i valori di uva e banane e includere quelli delle pere, che si trovano tra di essi.

Utilizzo di CERCA.X con SOMMA per sommare un intervallo di valori compresi tra due selezioni

La formula nella cella E3 è: =SOMMA(CERCA.X(B3,B6:B10,E6:E10):CERCA.X(C3,B6:B10,E6:E10))

Come funziona? CERCA.X restituisce un intervallo, quindi, quando esegue il calcolo, la formula finisce per avere l'aspetto seguente: =SOMMA($E$7:$E$9). Per vedere come funziona, selezionare una cella con una formula CERCA.X simile alla seguente, quindi selezionare Formule >Verifica formule > Valuta formula e valutare l'esecuzione del calcolo.

Nota: Grazie all'MVP di Microsoft Excel, Bill Jelen,per aver suggerito questo esempio.

———————————————————————————

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

CONFRONTA.X (funzione CONFRONTA.X)

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×