Sommario
×

Usare la funzione CERCA.X per trovare elementi in una tabella o in un intervallo per riga. Ad esempio è possibile cercare il prezzo di un componente di un’auto in base al numero del pezzo o trovare il nome di un dipendente in base al suo ID dipendente. Con CERCA.X è possibile cercare un termine di ricerca in una colonna e ottenere un risultato nella stessa riga ma in un'altra colonna, indipendentemente dal lato in cui si trova la colonna del risultato.

Il browser in uso non supporta le funzionalità video.

Sintassi

La funzione CERCA.X cerca in un intervallo o in una matrice e quindi restituisce l'elemento corrispondente alla prima corrispondenza trovata. Se non esiste alcuna corrispondenza, CERCA.X può restituire la corrispondenza più vicina (approssimativa). 

=CERCA.X(valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca]) 

Argomento

Descrizione

valore

Obbligatorio*

Valore da cercare

*Se omesso, CERCA.X restituirà le celle vuote che trova in lookup_array.   

matrice

Obbligatorio

La matrice o l’intervallo in cui effettuare la ricerca

matrice_restituita

Obbligatorio

La matrice o l’intervallo da restituire

[se_non_trovato]

Facoltativo

Se non è stata trovata una corrispondenza valida, restituire il testo [se_non_trovato] che si specifica.

Se non viene trovata una corrispondenza valida e [if_not_found] non è presente, viene restituita #N/D.

[modalità_confronto]

Facoltativo

Specificare il tipo di corrispondenza:

0 - Corrispondenza esatta. Se non trovata, restituisce #N/D. Questa è l’impostazione predefinita.

-1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più piccolo.

1 - Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più grande.

2 - Una corrispondenza jolly in cui *, ? e ~ hanno un significato speciale.

[modalità_ricerca]

Facoltativo

Specificare la modalità di ricerca da usare:

1 - Effettuare una ricerca a partire dal primo elemento. Questa è l’impostazione predefinita.

-1 - Effettuare una ricerca inversa a partire dall’ultimo elemento.

2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine crescente. Se non è classificata, vengono restituiti risultati non validi.

- 2 - Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine decrescente. Se non è classificata, vengono restituiti risultati non validi.

Esempi

Nell'esempio 1    viene utilizzato CERCA.X per cercare un nome di paese in un intervallo e quindi restituire il relativo codice del paese del telefono. Include gli argomenti lookup_value (cella F2), lookup_array (intervallo B2:B11) e return_array (intervallo D2:D11). Non include l'argomento match_mode, perché CERCA.X produce una corrispondenza esatta per impostazione predefinita.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:C14).

Nota: CERCA.X usa una matrice di ricerca e una matrice restituita, mentre CERCA.V usa una singola matrice di tabella seguita da un numero di indice di colonna. La formula CERCA.V equivalente in questo caso sarebbe: =CERCA.V(F2;B2:D11,3,FALSO)

———————————————————————————

L'esempio 2    cerca le informazioni sui dipendenti in base a un numero di ID dipendente. A differenza di CERCA.V, CERCA.X può restituire una matrice con più elementi, quindi una singola formula può restituire sia il nome del dipendente che il reparto dalle celle C5:D14.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1)

———————————————————————————

L'esempio 3    aggiunge un if_not_found argomenti all'esempio precedente.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente con l’argomento se_non_trovato. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1, “dipendente non trovato”)

———————————————————————————

L'esempio 4    cerca nella colonna C il reddito personale immesso nella cella E2 e trova un'aliquota d'imposta corrispondente nella colonna B. Imposta l'if_not_found per restituire 0 (zero) se non viene trovato alcun elemento. L match_mode argomento è impostato su 1,il che significa che la funzione cerca una corrispondenza esatta e, se non ne trova una, restituisce l'elemento più grande successivo. Infine, l'argomento search_mode è impostato su 1,il che significa che la funzione cerca dal primo all'ultimo elemento.

Immagine della funzione CERCA.X usata per restituire un'aliquota di imposta in base al reddito massimo. Si tratta di una corrispondenza approssimativa. La formula è: =CERCA.X(E2,C2:C7,B2:B7,1,1)

Nota: La colonna lookup_array XARRAY si trova a destra della colonna return_array, mentre CERCA.V può eseguire l'aspetto solo da sinistra a destra.

———————————————————————————

Esempio 5    usa una funzione XLOOKUP annidata per eseguire una corrispondenza verticale e orizzontale. Cerca prima il Profitto lordo nella colonna B, quindi cerca Iltr1 nella prima riga della tabella (intervallo C5:F5) e infine restituisce il valore all'intersezione dei due. È simile all'uso delle funzioni INDICEe MATCH.

Suggerimento: È anche possibile usare CERCA.X al posto della funzione CERCA.ORIZZ.

Immagine della funzione CERCA.X usata per restituire dati orizzontali da una tabella annidando due CERCA.X. La formula è: =CERCA.X(D2,$B6:$B17,CERCA.X($C3,$C5:$G5,$C6:$G17))

Nota: La formula nelle celle D3:F3 è: =CERCA.X(D2,$B 6:$B 17;CERCA.X($C 3.$C 5:$G 5,$C 6:$G 17)).

———————————————————————————

Esempio 6    usa la funzione SOMMAe due funzioni CERCA.X annidate per sommare tutti i valori tra due intervalli. In questo caso, si vogliono sommare i valori di uva e banane e includere quelli delle pere, che si trovano tra di essi.

Utilizzo di CERCA.X con SOMMA per sommare un intervallo di valori compresi tra due selezioni

La formula nella cella E3 è: =SOMMA(CERCA.X(B3;B6:B10;E6:E10):CERCA.X(C3;B6:B10;E6:E10))

Come funziona? CERCA.X restituisce un intervallo, quindi quando viene calcolato, la formula finisce con l'aspetto seguente: =SOMMA($E$7:$E$9). Per vedere come funziona da soli, selezionare una cella con una formula CERCA.X simile a questa, quindi selezionare Formule > Controllo formule > Valuta formulae quindi scegliere Valuta per eseguire il calcolo.

Nota: Grazie a Microsoft Excel MVP, Bill Jelen,per aver suggerito questo esempio.

———————————————————————————

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

CONFRONTA.X (funzione CONFRONTA.X)

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×