MATR.SOMMA.PRODOTTO (funzione MATR.SOMMA.PRODOTTO)

La funzione MATR.SOMMA.PRODOTTO restituisce la somma dei prodotti di matrici o intervalli corrispondenti. L'operazione predefinita è la moltiplicazione, ma è anche possibile eseguire addizioni, sottrazioni e divisioni.

In questo esempio verrà utilizzata la funzione MATR.SOMMA.PRODOTTO per restituire il totale delle vendite per un determinato articolo e le relative dimensioni:

Esempio dell'uso della funzione MATR.SOMMA.PRODOTTO per restituire il totale delle vendite quando vengono forniti i valori relativi al nome del prodotto, alle dimensioni e ai singoli valori di vendita per ognuno.

MATR.SOMMA.PRODOTTO corrisponde a tutte le istanze dell'elemento Y/Dimensione M e le somma, quindi per questo esempio 21 più 41 è uguale a 62.

Sintassi

Per usare l'operazione predefinita (moltiplicazione):

=MATR.SOMMA.PRODOTTO(matrice1; [matrice2]; [matrice3]; ...)

Gli argomenti della sintassi della funzione MATR.SOMMA.PRODOTTO sono i seguenti:

Argomento

Descrizione

matrice1   

Obbligatorio

Il primo argomento matrice di cui si desidera moltiplicare e quindi sommare gli elementi.

[matrice2], [matrice3],...    

Facoltativo

Argomenti matrice da 2 a 255 di cui si desidera moltiplicare e quindi sommare gli elementi.

Per eseguire altre operazioni aritmetiche

Utilizzare la funzione MATR.SOMMA.PRODOTTO come al solito, ma sostituire le virgole che separano gli argomenti matrice con gli operatori aritmetici desiderati (*, /, +, -). Dopo aver eseguito tutte le operazioni, i risultati vengono sommati come al solito.

Nota: Se si usano operatori aritmetici, è consigliabile racchiudere gli argomenti della matrice tra parentesi e usare le parentesi per raggruppare gli argomenti della matrice per controllare l'ordine delle operazioni aritmetiche.

Osservazioni

  • Gli argomenti matrice devono avere le stesse dimensioni. In caso contrario, MATR.SOMMA.PRODOTTO restituisce il #VALUE! . Ad esempio, =MATR.SOMMA.PRODOTTO(C2:C10,D2:D5) restituirà un errore perché gli intervalli non hanno le stesse dimensioni.

  • MATR.SOMMA.PRODOTTO considera le voci di matrice non numeriche come se fossero zeri.

  • Per prestazioni ottimali, la funzione MATR.SOMMA.PRODOTTO non deve essere usata con riferimenti a colonne complete. Si consideri =MATR.SOMMA.PRODOTTO(A:A;B:B), qui la funzione moltiplica 1.048.576 celle nella colonna A per 1.048.576 celle della colonna B prima di sommarle. 

Esempio 1

Esempio della funzione MATR.SOMMA.PRODOTTO usata per restituire la somma degli articoli venduti quando vengono forniti il costo unitario e la quantità.

Per creare la formula usando l'elenco di esempio precedente, digitare =MATR.SOMMA.PRODOTTO(C2:C5;D2:D5) e premere INVIO. Ogni cella della colonna C viene moltiplicata per la cella corrispondente nella stessa riga della colonna D e i risultati vengono sommati. L'importo totale della spesa è di $ 78,97.

Per scrivere una formula più lunga che restituisce lo stesso risultato, digitare =C2*D2+C3*D3+C4*D4+C5*D5 e premere INVIO. Dopo aver premuto INVIO, il risultato è lo stesso: $ 78,97. La cella C2 viene moltiplicata per D2 e il risultato viene aggiunto al risultato della cella C3 per la cella D3 e così via.

Esempio 2

L'esempio seguente usa MATR.SOMMA.PRODOTTO per restituire il totale delle vendite nette per agente di vendita, dove sono disponibili sia il totale delle vendite che le spese per agente. In questo caso viene utilizzata una tabella di Excel,che usa riferimenti strutturati anziché intervalli standard di Excel. Qui si può vedere che gli intervalli Vendite, Spese e Agente sono referenziati per nome.

Esempio della funzione MATR.SOMMA.PRODOTTO per restituire il totale delle vendite per venditore quando vengono fornite le vendite e le spese per ognuno.

La formula è: =MATR.SOMMA.PRODOTTO(((Tabella1[Vendite])+(Tabella1[Spese]))*(Tabella1[Agente]=B8)) e restituisce la somma di tutte le vendite e le spese per l'agente elencato nella cella B8.

Esempio 3

In questo esempio si vuole restituire il totale di un determinato articolo venduto da una determinata area geografica. In questo caso, quante ciliegie hanno venduto l'area orientale?

Esame dell'uso della funzione MATR.SOMMA.PRODOTTO per restituire la somma degli elementi per area geografica. In questo caso, il numero di ciliegie vendute nell'area orientale.

La formula è: =MATR.SOMMA.PRODOTTO((B2:B9=B12)*(C2:C9=C12)*D2:D9). Moltiplica prima di tutto il numero di occorrenze di Est per il numero di occorrenze corrispondenti di ciliegie. Infine, somma i valori delle righe corrispondenti nella colonna Vendite. Per vedere come excel calcola questo risultato, selezionare la cella della formula, quindi passare a Formule > Valuta formula > Valuta.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Eseguire calcoli condizionali su intervalli di celle

Somma basata su più criteri con SOMMA.PIÙ.SE

Contare in base a più criteri con CONTA.PIÙ.SE

Media basata su più criteri con MEDIA.PIÙ.SE

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×