MATR.SOMMA.PRODOTTO (funzione MATR.SOMMA.PRODOTTO)

La funzione MATR.SOMMA.PRODOTTO restituisce la somma dei prodotti di intervalli o matrici corrispondenti. L'operazione predefinita è la moltiplicazione, ma sono possibili anche addizioni, sottrazioni e divisioni.

In questo esempio si userà MATR.SOMMA.PRODOTTO per restituire il totale delle vendite per un determinato articolo e dimensioni:

Esempio di utilizzo della funzione MATR.SOMMA.PRODOTTO per restituire il totale delle vendite quando vengono forniti il nome del prodotto, le dimensioni e i singoli valori di vendita per ogni prodotto.

MATR.SOMMA.PRODOTTO corrisponde a tutte le istanze dell'elemento Y/Dimensioni M e le somma, quindi per questo esempio 21 più 41 è uguale a 62.

Sintassi

Per usare l'operazione predefinita (moltiplicazione):

=MATR.SOMMA.PRODOTTO(matrice1; [matrice2]; [matrice3]; ...)

Gli argomenti della sintassi della funzione MATR.SOMMA.PRODOTTO sono i seguenti:

Argomento

Descrizione

matrice1   

Obbligatorio

Il primo argomento matrice di cui si desidera moltiplicare e quindi sommare gli elementi.

[matrice2], [matrice3],...    

Facoltativo

Argomenti di matrice da 2 a 255 di cui si vogliono moltiplicare i componenti e quindi aggiungerli.

Per eseguire altre operazioni aritmetiche

Usare MATR.SOMMA.PRODOTTO come al solito, ma sostituire le virgole che separano gli argomenti di matrice con gli operatori aritmetici desiderati (*, /, +, -). Dopo aver eseguito tutte le operazioni, i risultati vengono sommati come al solito.

Nota: Se si usano operatori aritmetici, è consigliabile racchiudere gli argomenti di matrice tra parentesi e usare le parentesi per raggruppare gli argomenti di matrice per controllare l'ordine delle operazioni aritmetiche.

Osservazioni

  • Gli argomenti di matrice devono avere le stesse dimensioni. In caso contrario, MATR.SOMMA.PRODOTTO restituirà #VALUE! valore di errore. Ad esempio, =MATR.SOMMA.PRODOTTO(C2:C10;D2:D5) restituirà un errore perché gli intervalli non hanno le stesse dimensioni.

  • MATR.SOMMA.PRODOTTO considera le voci di matrice non numeriche come se fossero zeri.

  • Per prestazioni ottimali, SUMPRODUCT non deve essere usato con riferimenti di colonna completi. Considerare =MATR.SOMMA.PRODOTTO(A:A;B:B), qui la funzione moltiplicherà le 1.048.576 celle nella colonna A per le 1.048.576 celle nella colonna B prima di aggiungerle. 

Esempio 1

Esempio della funzione MATR.SOMMA.PRODOTTO usata per restituire la somma degli articoli venduti quando vengono forniti il costo unitario e la quantità.

Per creare la formula usando l'elenco di esempio precedente, digitare =MATR.SOMMA.PRODOTTO(C2:C5;D2:D5) e premere INVIO. Ogni cella nella colonna C viene moltiplicata per la cella corrispondente nella stessa riga della colonna D e i risultati vengono sommati. L'importo totale per la spesa è di $ 78,97.

Per scrivere una formula più lunga che restituisce lo stesso risultato, digitare =C2*D2+C3*D3+C4*D4+C5*D5 e premere INVIO. Dopo aver premuto INVIO, il risultato è lo stesso: $ 78,97. La cella C2 viene moltiplicata per D2 e il risultato viene aggiunto al risultato della cella C3 per la cella D3 e così via.

Esempio 2

L'esempio seguente usa MATR.SOMMA.PRODOTTO per restituire il totale delle vendite nette per agente di vendita, in cui sono disponibili sia le vendite totali che le spese per agente. In questo caso viene utilizzata una tabella di Excel,che usa riferimenti strutturati invece di intervalli standard di Excel. Qui si nota che gli intervalli Vendite, Spese e Agente fanno riferimento in base al nome.

Esempio della funzione MATR.SOMMA.PRODOTTO per restituire il totale delle vendite per rappresentante di vendita quando vengono fornite le vendite e le spese per ognuna.

La formula è: =MATR.SOMMA.PRODOTTO(((Tabella1[Vendite])+(Tabella1[Spese]))*(Tabella1[Agente]=B8)) e restituisce la somma di tutte le vendite e le spese per l'agente elencato nella cella B8.

Esempio 3

In questo esempio si vuole restituire il totale di un determinato articolo venduto da una determinata area geografica. In questo caso, quante ciliegie hanno venduto l'area orientale?

Esame dell'uso di MATR.SOMMA.PRODOTTO per restituire la somma degli elementi per area geografica. In questo caso, il numero di ciliegie vendute nell'area orientale.

La formula è: =MATR.SOMMA((B2:B9=B12)*(C2:C9=C12)*D2:D9). Moltiplica prima di tutto il numero di occorrenze di Est per il numero di occorrenze corrispondenti di ciliegie. Infine, somma i valori delle righe corrispondenti nella colonna Vendite. Per vedere come viene calcolato, selezionare la cella della formula, quindi passare a Formule > Valuta formula > Valuta.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Eseguire calcoli condizionali su intervalli di celle

Somma basata su più criteri con SOMMA.PIÙ.SE

Contare in base a più criteri con CONTA.PIÙ.SE

Media basata su più criteri con MEDIA.PIÙ.SE

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×