Quando si immette una formula in forma di matrice,nella maggior parte dei casi si usa un intervallo di celle nel foglio di lavoro, ma non è necessario. È anche possibile usare costanti di matrice,valori immessi nella barra della formula tra parentesi graffe: {}. È quindi possibile assegnare un nome alla costante in modo che sia più facile usarla di nuovo.

È possibile usare costanti nelle formule di matrice o da sole.

  1. Nella formula di matrice digitare una parentesi graffa di apertura, i valori desiderati e una parentesi graffa di chiusura. Ecco un esempio: =SOMMA(A1:E1*{1,2,3,4,5})

    La costante è all'interno delle parentesi graffe ({)}, e sì, le parentesi graffe vengono digitate manualmente.

  2. Immettere il resto della formula e premere CTRL+MAIUSC+INVIO.

    La formula avrà un aspetto simile a {=SUM(A1:E1*{1,2,3,4,5})}e i risultati saranno simili al seguente:


    Costante di matrice annidata in una formula SOMMA

    La formula ha moltiplicato A1 per 1 e B1 per 2 e così via, senza dover inserire 1,2,3,4,5 nelle celle del foglio di lavoro.

Usare una costante per immettere valori in una colonna

Per immettere valori in una singola colonna, ad esempio 3 celle nella colonna C, è possibile:

  1. Selezionare le celle da usare.

  2. Immettere un segno di uguale e la costante. Separare i valori della costante con punti e virgola e non virgole e, se si immette testo, racchiuderlo tra virgolette doppie. Ad esempio: ={"Trimestre 1";" Trimestre2";" Trimestre 3"}

  3. Premere CTRL+MAIUSC+INVIO. La costante è simile alla seguente:

    Costante di matrice verticale che utilizza testo

    In termini geek, si tratta di una costante verticale unidimensionale.

Usare una costante per immettere valori in una riga

Per immettere rapidamente i valori in una singola riga, ad esempio le celle F1, G1 e H1, è possibile:

  1. Selezionare le celle da usare.

  2. Immettere un segno di uguale e la costante, ma questa volta i valori vengono separati da virgole, non da punti e virgola. Ad esempio: ={1,2,3,4,5}

  3. Premere CTRL+MAIUSC+INVIO e la costante ha l'aspetto seguente:

    Costante di matrice orizzontale unidimensionale

    In termini geek, si tratta di una costante orizzontale unidimensionale.

Usare una costante per immettere valori in più colonne e righe

  1. Selezionare le celle desiderate.

    Verificare che il numero di righe e colonne selezionate corrisponda al numero di valori nella costante. Ad esempio, se la costante scriverà dati in quattro colonne e tre righe, selezionare tale numero di colonne e righe.

  2. Immettere un segno di uguale e la costante. In questo caso, separare i valori di ogni riga con virgole e usare un punto e virgola alla fine di ogni riga. Ad esempio:

    ={1\2\3\4.5\6\7\8.9\10\11\12}

  3. Premere CTRL+MAIUSC+INVIO e:

    Costante di matrice bidimensionale

    In termini geek, si tratta di una costante bidimensionale perché riempie colonne e righe. Se si vuole, non è possibile creare una costante tridimensionale, quindi non è possibile annidare una costante all'interno di un'altra.

Usare una costante in una formula

Ora che si ha familiarità con le costanti di matrice, ecco un esempio funzionante.

  • In una cella vuota immettere (o copiare e incollare) questa formula e quindi premere CTRL+MAIUSC+INVIO:

    =SOMMA(A1:E1*{1\2\3\4\5})

    Nella cella A3 viene visualizzato il valore 85.

    Che cosa è successo? Il valore in A1 è stato moltiplicato per 1, il valore nella cella B2 per 2 e così via, quindi la funzione SOMMA ha aggiunto i risultati. È anche possibile immettere la formula come =SOMMA(A1*1;B1*2,C1*3,D1*4;E1*5)

Se si vuole, è possibile immettere entrambi i set di valori come costanti di matrice:

=SOMMA({3\4\5\6\7}*{1\2\3\4\5})

Per provare a eseguire questa operazione, copiare la formula, selezionare una cella vuota e incollare la formula nella barra della formula e quindi premere CTRL+MAIUSC+INVIO. Viene visualizzato lo stesso risultato.

Note: Se le costanti non funzionano, cercare questi problemi:

  • Assicurarsi di separare i valori con il carattere corretto. Se si omette una virgola o un punto e virgola o se ne viene inserito uno nella posizione sbagliata, la costante di matrice potrebbe non avere l'aspetto corretto o potrebbe essere visualizzato un messaggio di avviso.

  • È possibile che sia stato selezionato un intervallo di celle che non corrisponde al numero di elementi nella costante. Ad esempio, se si seleziona una colonna di sei celle da usare con una costante a cinque celle, nella cella vuota verrà visualizzato l'errore #N/A. Se non si seleziona un numero sufficiente di celle, Excel omette i valori che non hanno una cella corrispondente.

  • Per altre informazioni sulle formule di matrice:

Inizio pagina

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?

Cosa ha influito sulla tua esperienza?

Altri commenti e suggerimenti? (Facoltativo)

Grazie per il feedback!

×