Usare costanti di matrice nelle formule in forma di matrice

Quando si immette una formulain forma di matrice, si usa spesso un intervallo di celle nel foglio di lavoro, ma non è necessario. È anche possibile usare costanti di matrice, valori immessi semplicemente nella barra della formula all'interno delle parentesi graffe: {}. Puoi quindi assegnare un nome alla costante in modo che sia più facile da usare di nuovo.

Puoi usare le costanti nelle formule di matrice o da sole.

  1. Nella formula in forma di matrice digitare una parentesi graffa di apertura, i valori desiderati e una parentesi graffa di chiusura. Ecco un esempio: = Sum (a1: E1 * {1; 2; 3; 4; 5})

    La costante è racchiusa tra parentesi graffe ({)} e sì, è possibile digitare le parentesi graffe manualmente.

  2. Immettere il resto della formula e premere CTRL + MAIUSC + INVIO.

    La formula avrà un aspetto simile a {= Sum (a1: E1 * {1, 2, 3, 4, 5})}e i risultati avranno un aspetto simile al seguente:


    Costante di matrice annidata in una formula SOMMA

    La formula ha moltiplicato a1 per 1 e B1 per 2 e così via, salvando l'utente da dover inserire 1, 2, 3, 4, 5 nelle celle del foglio di lavoro.

Usare una costante per immettere i valori in una colonna

Per immettere i valori in una singola colonna, ad esempio 3 celle nella colonna C, è possibile:

  1. Selezionare le celle da usare.

  2. Immettere un segno di uguale e la costante. Separare i valori della costante con punti e virgola, non le virgole e, se si immette il testo, racchiuderlo tra virgolette doppie. Ad esempio: = {"Quarter 1"; " Quarter2";" Trimestre 3 "}

  3. Premere CTRL+MAIUSC+INVIO. La costante ha un aspetto simile al seguente:

    Costante di matrice verticale che utilizza testo

    In termini di geek si tratta di una costante verticale unidimensionale .

Usare una costante per immettere i valori in una riga

Per immettere rapidamente i valori in una singola riga, ad esempio le celle F1, G1 e H1, è possibile:

  1. Selezionare le celle da usare.

  2. Immettere un segno di uguale e la costante, ma questa volta separare i valori con virgole e non con punti e virgola. Ad esempio: = {1; 2; 3; 4; 5}

  3. Premere CTRL + MAIUSC + INVIO e la costante ha un aspetto simile al seguente:

    Costante di matrice orizzontale unidimensionale

    In termini di geek si tratta di una costante orizzontale unidimensionale .

Usare una costante per immettere valori in più colonne e righe

  1. Selezionare le celle desiderate.

    Verificare che il numero di righe e colonne selezionato corrisponda al numero di valori della costante. Ad esempio, se la costante scriverà dati in quattro colonne e tre righe, selezionare il numero di colonne e righe.

  2. Immettere un segno di uguale e la costante. In questo caso, separare i valori di ogni riga con le virgole e usare un punto e virgola alla fine di ogni riga. Per esempio:

    ={1,2,3,4;5,6,7,8;9,10,11,12}

  3. Premere CTRL + MAIUSC + INVIO e:

    Costante di matrice bidimensionale

    In termini di geek, questa è una costante bidimensionale perché riempie le colonne e le righe. Se ti stai chiedendo, non puoi creare una costante tridimensionale, quindi non puoi annidare una costante all'interno di un'altra.

Usare una costante in una formula

Ora che hai familiarità con le costanti di matrice, ecco un esempio di lavoro.

  • In una cella vuota immettere (o copiare e incollare) la formula, quindi premere CTRL + MAIUSC + INVIO:

    =SOMMA(A1:E1*{1,2,3,4,5})

    Nella cella A3 viene visualizzato il valore 85.

    Che cosa è successo? È stato moltiplicato il valore in a1 per 1, il valore nella cella B2 per 2 e così via, quindi la funzione somma ha aggiunto i risultati. È anche possibile immettere la formula come = somma (a1 * 1, B1 * 2, C1 * 3, D1 * 4, E1 * 5)

Se si vuole, è possibile immettere entrambi i set di valori come costanti di matrice:

=SOMMA({3,4,5,6,7}*{1,2,3,4,5})

Per provare questa operazione, copiare la formula, selezionare una cella vuota e incollare la formula nella barra della formula, quindi premere CTRL + MAIUSC + INVIO. Viene visualizzato lo stesso risultato.

Note: Se le costanti non funzionano, cercare questi problemi:

  • Assicurati di separare i valori con il carattere appropriato. Se si omette una virgola o un punto e virgola oppure se ne viene inserita una nella posizione sbagliata, la costante di matrice potrebbe non essere visualizzata correttamente o potrebbe essere visualizzato un messaggio di avviso.

  • Potrebbe essere stato selezionato un intervallo di celle che non corrisponde al numero di elementi della costante. Se ad esempio si seleziona una colonna di sei celle da usare con una costante di cinque celle, nella cella vuota verrà visualizzato il messaggio di errore #N/A. Se non si selezionano celle sufficienti, Excel omette i valori che non dispongono di una cella corrispondente.

  • Per altre informazioni sulle formule in forma di matrice:

Inizio pagina

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×