È possibile usare la funzione VALORECAMPO per recuperare i dati del campo dai tipi di dati collegati, come Azioni o Geografia. Sono disponibili metodi più semplici per scrivere formule che fanno riferimento ai tipi di dati, quindi la funzione VALORECAMPO deve essere usata principalmente per la creazione di calcoli condizionali basati sui tipi di dati collegati.

Nota: 28 marzo 2019: i tipi di dati sono stati rilasciati per tutti Windows Microsoft 365 abbonati. Gli abbonati a Microsoft 365devono verificare di avere installato la versione più recente di Office.

Dettagli tecnici

Sintassi

=VALORECAMPO(valore, nome_campo)

Gli argomenti della sintassi della funzione VALORECAMPO sono i seguenti:

Argomento

Descrizione

valore

La funzione restituisce tutti i campi corrispondenti dal tipo di dati collegato specificato nell'argomento valore.

nome_campo

Il nome o i nomi dei campi da estrarre dal tipo di dati collegati.

Descrizione

  • La funzione VALORECAMPO restituisce tutti i campi corrispondenti dal tipo di dati collegato specificato nell'argomento valore.

  • La funzione VALORECAMPO appartiene alla famiglia di funzioni Ricerca e riferimento.

Esempi

Nell'esempio di base seguente la formula =VALORECAMPO(A2,"Prezzo") estrae il campo Prezzo dal tipo di dati Azioni per JM Smucker Co

Recuperare un prezzo delle azioni aziendali con =VALORECAMPO(A2,"Prezzo").

L'esempio successivo è un esempio più tipico per la funzione VALORE.CAMPO. In questo caso viene utilizzata la funzione SE.ERRORE per verificare la presenza di errori. Se nella cella A2 non è presente un nome di società, la formula VALORE.CAMPO restituirà un errore e in questo caso non si vuole visualizzare nulla (""). Se però è presente un nome di società, si vuole recuperare il prezzo dal tipo di dati in A2 con =SE.ERRORE(VALORE.CAMPO($A 2;B$1),"").

Recuperare un prezzo delle azioni aziendali e ignorare gli errori con =SE.ERRORE(VALORECAMPO($A2,B$1),"")

La funzione VALORECAMPO consente di fare riferimento a celle del foglio di lavoro per l'argomento nome_campo, quindi la formula precedente fa riferimento alla cella B1 per il prezzo invece di richiedere l'immissione manuale di "Prezzo" nella formula. 

Osservazioni

Se si prova a recuperare dati da un campo di tipo di dati inesistente, la funzione VALORE.CAMPO restituirà l'errore #FIELD!. Ad esempio, è possibile che sia stato immesso "Prezzi", quando il campo del tipo di dati effettivo è denominato "Prezzo". Controllare la formula per assicurarsi di usare un nome di campo valido. Se si vuole visualizzare un elenco di nomi di campo per un record, selezionare la cella del record e premere ALT+MAIUSC+F10.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Tipi di dati Azioni e Geografia

Come scrivere formule con riferimento ai tipi di dati

Errore #CAMPO! #BUSY!

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×