Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si connette un dispositivo USB a un computer che esegue Windows 8.1, tale dispositivo viene sospeso e non si ricarica.

Cause

Questo problema può verificarsi a causa dei miglioramenti sul risparmio energetico introdotti in Windows 8.1. Tali miglioramenti consentono di ridurre il consumo di energia e prolungare la durata della batteria dei computer portatili. Se il dispositivo USB viene visualizzato come una periferica Human Interface (HID) ma non risponde a Windows nel periodo di tempo impostato, Windows sospende il dispositivo.

Risoluzione

Per risolvere questo problema, installare un driver di dispositivo aggiornato. Per verificare se è disponibile un driver aggiornato, attenersi alla seguente procedura:

  1. Aprire l'elemento Windows Update nel Pannello di controllo. A questo scopo, scorrere rapidamente dal margine destro dello schermo, quindi toccare Cerca. In alternativa, nell'angolo superiore destro dello schermo, fare clic su Ricerca.

  2. Nella casella di ricerca, digitare Windows Update.

  3. Toccare o fare clic su Impostazioni, quindi toccare o fare clic su Installa gli aggiornamenti facoltativi.

  4. Toccare o fare clic su Verifica aggiornamenti e attendere mentre Windows cerca gli aggiornamenti più recenti per il computer.

Se vengono trovati aggiornamenti, toccare o fare clic su Installa aggiornamenti.

Workaround

Per risolvere questo problema, è possibile disabilitare le impostazioni Gestione avanzata del risparmio energetico per il dispositivo che non viene ricaricato.

Nota Questa impostazione consente di ridurre il consumo di energia e prolungare la durata della batteria per computer portatili. Se vengono disabilitate le impostazioni avanzate del risparmio energetico per il dispositivo, il consumo di energia dovrebbe aumentare e, se il dispositivo viene connesso a un computer portatile, la durata della batteria sarà inferiore.

Per disabilitare le impostazioni Gestione avanzata del risparmio energetico nel dispositivo, attenersi alla seguente procedura.

Importante Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di modificarlo,eseguire il backup del Registro di sistema per il ripristino nel caso in cui si verifichino problemi.

  1. Connettere il dispositivo USB al computer.

  2. Nel Pannello di controllo, aprire l'elemento di Gestione periferiche. A tale scopo, scorrere rapidamente da destra per aprire gli accessi, toccare o fare clic su Ricerca, quindi digitare gestione periferiche nella casella di ricerca. Oppure, digitare gestione periferiche nella schermata Start, quindi toccare o fare clic su Gestione periferiche nei risultati della ricerca.

  3. Per visualizzare l'elenco degli HID connessi, toccare o fare clic sulla freccia accanto a Periferica Human Interface.

    Nota Il dispositivo potrebbe essere elencato per nome o genericamente come "Periferica di Input USB".

  4. Nell'elenco dei dispositivi, fare clic con il pulsante destro del mouse o premere e tenere premuta la voce del dispositivo che non viene ricaricata, quindi fare clic su Proprietà.


    Nota Se tale voce è contrassegnata come "Periferica di input USB" invece che con il nome del dispositivo e se ci sono più voci "Periferica di input USB", attenersi alla seguente procedura per determinare la voce corretta:

    1. Scollegare il dispositivo che presenta il problema dal computer.

    2. Fare clic con il pulsante destro del mouse su ciascuna voce Dispositivo di input USB, quindi fare clic su Proprietà per visualizzare le descrizioni e i dettagli del dispositivo. Nota ogni dispositivo collegato.

    3. Riconnettere il dispositivo che presenta il problema.

    4. Esaminare nuovamente tutte le voci Dispositivo di input USB per determinare quella nuova che, quindi, rappresenta il problema.

  5. Nella casella di dialogo Proprietà relativa al dispositivo che presenta il problema, toccare o fare clic sulla scheda Dettagli.

  6. Nell'elenco in Proprietà, selezionare Percorso istanza dispositivo, quindi prendere nota delle informazioni ID. Ad esempio, tenere presente quanto segue:

    USB\VID_1234&PID_5678\0A1B2C3DNota Questa riga è una combinazione dei seguenti numeri ID:

    • ID fornitore (VID)

    • ID prodotto (PID)

    • ID istanza:

  7. Avviare l'editor del Registro di sistema. A tale scopo, scorrere rapidamente da destra per aprire gli accessi, toccare o fare clic su Ricerca, quindi digitare regedit.exe nella casella di ricerca. Oppure, digitare regedit.exe nella schermata Start, toccare o fare clic su regedit nei risultati della ricerca.

  8. Nel riquadro di spostamento, trovare la chiave del Registro di sistema corrispondente al dispositivo che presenta il problema. A questo scopo, attenersi alla seguente procedura:

    1. Toccare o fare clic sulla freccia accanto alla cartella HKEY_LOCAL_MACHINE per espanderla.

    2. Espandere SYSTEM.

    3. Espandere CurrentControlSet.

    4. Espandere Enum.

    5. Espandere USB.

    6. Individuare la cartella il cui nome contiene il VID PID annotato al passaggio 6 (ad esempio, individuare VID_1234&PID_5678), e poi espandere tale cartella.

    7. Espandere la cartella che corrisponde all'ID istanza dal passaggio 6.

    8. Toccare o fare clic su Device Parameters.

  9. Nel riquadro destro, fare clic con il pulsante destro del mouse o premere e tenere premuto EnhancedPowerManagementEnabled, quindi scegliere Modifica.

  10. Modificare il Valore dati su 0, quindi toccare o fare clic su OK.

  11. Uscire dall'editor del Registro di sistema.

Il dispositivo che presentava il problema ora dovrebbe ricaricarsi correttamente.

Se, dopo aver installato un driver aggiornato, è necessario abilitare nuovamente le impostazioni Gestione avanzata del risparmio energetico per il dispositivo, attenersi alla stessa procedura di questa sezione, tranne per il passaggio 10 dove è necessario modificare il Valore dati su 1.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×