Sintomi
Quando si tenta di stabilire una sessione di stampa TN3270 tramite il servizio Microsoft Host Integration Server 2013 TN3270, si potrebbe ricevere il seguente messaggio di errore:
Dispositivo in uso
Una traccia TN3270 acquisite tramite l'utilità analisi SNA contiene il messaggio di errore seguente, più dettagliati:
RIFIUTO DI TIPO DISPOSITIVO TN3270E BEGIN SUBNEG
Questo problema può verificarsi anche se la sessione viene visualizzata come disponibile nella Console di amministrazione di Host Integration Server.
Causa
In determinate condizioni di competizione, un timer di 1 secondo ripetuto viene avviato prima che la sessione è stata pulita. In questo modo una nuova sessione per l'unità logica viene stabilita immediatamente.
La correzione nella sezione "Risoluzione" consente di modificare il timer in modo che la sessione termina immediatamente. In questo modo per la creazione immediata di una nuova sessione per l'unità logica.
Risoluzione
Microsoft Host Integration Server 2013
La correzione che risolve questo problema è inclusa nell'aggiornamento cumulativo seguente:
Aggiornamento cumulativo 3 per Host Integration Server 2013
Aggiornamento rapido per l'aggiornamento cumulativo 2 per Host Integration Server 2013
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.
Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/default.aspx
Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Prerequisiti
È necessario disporre di pacchetto di aggiornamento cumulativo 2 per Microsoft Host Integration Server 2013 per applicare questo hotfix. Per ulteriori informazioni su come ottenere il pacchetto di aggiornamento cumulativo, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:
2929767 cumulativo aggiornamento 2 per Host Integration Server 2013
Stato
Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".