新しいデータベースを作成する

適用先
Access for Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

この記事では、Access を起動して、Web 経由ではなくデスクトップ コンピューターで使用するデータベースを作成する基本的なプロセスについて説明します。 テンプレートを使用してデスクトップ データベースを作成する方法と、独自のテーブル、フォーム、レポート、その他のデータベース オブジェクトを作成してデータベースを最初から構築する方法について説明します。 また、既存のデータを新しいデータベースに取り込むために使用できるいくつかの方法についても説明します。

この記事の内容

概要

Access を初めて起動するとき、または Access を閉じずにデータベースを閉じると、MicrosoftOffice Backstage ビューが表示されます。

Backstage ビューは、新しいデータベースの作成、既存のデータベースの開封、Office.com のおすすめコンテンツの表示など、Access を使用してデータベース ファイルまたはデータベース内ではなくデータベース外で実行できるあらゆる操作を行うための出発点です。

データベースを作成する

Access を開くと、Backstage ビューに [ 新規] タブが表示されます。[ 新規 ] タブでは、新しいデータベースを作成する方法がいくつかあります。

  • 空のデータベース 必要に応じて、最初から始めることができます。 これは、非常に特殊な設計要件がある場合や、対応または組み込む必要がある既存のデータがある場合に適したオプションです。
  • Access と共にインストールされるテンプレート 新しいプロジェクトを開始し、早く始めたい場合は、テンプレートの使用を検討してください。 Access には、既定でインストールされているいくつかのテンプレートが付属しています。
  • Office.com のテンプレート Access に付属しているテンプレートに加えて、Office.com ではさらに多くのテンプレートを見つけることができます。 ブラウザーを開く必要もありません。テンプレートは [ 新規 ] タブから利用できます。

データベースへの追加

データベースで作業したら、フィールド、テーブル、またはアプリケーション パーツを追加できます。

アプリケーション パーツは、複数の関連するデータベース オブジェクトを 1 つであるかのように一緒に使用できるようにする機能です。 たとえば、アプリケーションパーツは、テーブルと、そのテーブルに基づくフォームから構成される場合があります。 アプリケーションパーツを使用して、テーブルとフォームを同時に追加できます。

また、クエリ、フォーム、レポート、マクロなど、作業に慣れているすべてのデータベース オブジェクトを作成することもできます。

テンプレートを使用してデータベースを作成する

Access には、そのまま使用することも、開始点として使用できるさまざまなテンプレートが用意されています。 テンプレートは、特定のタスクを実行するために必要なすべてのテーブル、クエリ、フォーム、マクロ、およびレポートを含むすぐに使用できるデータベースです。 たとえば、問題の追跡、連絡先の管理、経費の記録の保持に使用できるテンプレートがあります。 一部のテンプレートには、その使用法を示すのに役立ついくつかのサンプル レコードが含まれています。

これらのテンプレートのいずれかがニーズに合っている場合は、通常、それを使用することがデータベースを開始する最も速い方法です。 ただし、Access にインポートする別のプログラムのデータがある場合は、テンプレートを使用せずにデータベースを作成する方が良いと判断する場合があります。 テンプレートには既にデータ構造が定義されており、既存のデータをテンプレートの構造に適合させるには多くの作業が必要になる場合があります。

  1. データベースを開いている場合は、[ ファイル ] タブで [閉じる] をクリックします。 Backstage ビューに [ 新規] タブが表示されます。
  2. [ 新規 ] タブでは複数のテンプレート セットを使用できます。そのうち、一部は Access に組み込まれています。 Office.com から追加のテンプレートをダウンロードできます。 詳細については、この記事の次のセクションを参照してください。
  3. 使用するテンプレートを選択します。
  4. Access によってデータベースのファイル名が [ ファイル名 ] ボックスに提案されます。必要に応じて、ファイル名を変更できます。 [ファイル名] ボックスの下に表示されているフォルダとは別のフォルダにデータベースを保存するには、[ ] をクリックし、保存するフォルダを参照して、[ OK] をクリックします。 必要に応じて、データベースを作成して SharePoint サイトにリンクできます。
  5. [Create] (作成) をクリックします。
    Access によって、選択したテンプレートからデータベースが作成され、データベースが開かれます。 多くのテンプレートでは、データの入力を開始できるフォームが表示されます。 テンプレートにサンプル データが含まれている場合は、レコード セレクター (レコードのすぐ左側にある網掛けのボックスまたはバー) をクリックし、次の操作を行うことにより、各レコードを削除できます。
    [ホーム] タブの [レコード] グループで、[削除] をクリックします。
  6. データの入力を開始するには、フォームの最初の空のセルをクリックして入力を開始します。 ナビゲーション ウィンドウを使用して、使用する可能性がある他のフォームやレポートを参照します。 一部のテンプレートには、さまざまなデータベース オブジェクト間を移動できるナビゲーション フォームが含まれています。

テンプレートの操作の詳細については、「 テンプレートを使用して Access デスクトップ データベースを作成する」の記事を参照してください。

ページの先頭へ

テンプレートを使用せずにデータベースを作成する

テンプレートの使用に関心がない場合は、独自のテーブル、フォーム、レポート、その他のデータベース オブジェクトを構築してデータベースを作成できます。 ほとんどの場合、これには次のいずれかまたは両方が含まれます。

  • 新しいデータベースを作成するときに作成されるテーブルにデータを入力、貼り付け、またはインポートし、[作成] タブの [テーブル] コマンドを使用して作成した新しいテーブルでこの処理を繰り返す操作。
  • 他のソースからデータをインポートし、そのプロセスで新しいテーブルを作成する。

空のデータベースを作成する

  1. [ ファイル ] タブで [ 新規作成] をクリックし、[ 空のデータベース] をクリックします。
  2. [ ファイル名 ] ボックスにファイル名を入力します。 ファイルの場所を既定の設定から変更するには、データベースを置く場所の参照 ([ファイル名] ボックスの横) をクリックして新しい場所を参照して、[OK] をクリックします。
  3. [Create] (作成) をクリックします。
    Table1 という名前の空のテーブルを含むデータベースが作成され、データシート ビューで Table1 が開きます。 カーソルが、[ クリックして追加 ] 列の最初の空のセルに置かれます。
  4. 「 別のソースから Access のテーブルにデータをコピーする」セクションの説明に従って、入力を開始してデータを追加するか、別のソースのデータを貼り付けることもできます。

データシート ビューでのデータの入力は、Excel ワークシートでの作業と非常によく似たように設計されています。 テーブル構造は、データの入力中に作成されます。 データシートに新しい列を追加すると、新しいフィールドがテーブル内で定義されます。 Access では、入力したデータに基づいて、各フィールドのデータ型が自動的に設定されます。

現時点では Table1 にデータを入力しない場合は、[閉じる]をクリックします。 テーブルに変更を加えた場合は、変更を保存するように求められます。 「 はい 」をクリックして変更を保存し、「 いいえ 」をクリックして変更を破棄するか、「 キャンセル」 をクリックしてテーブルを開いたままにします。

ヒント

Access は、[インストール ドライブ]:\Program Files\MicrosoftOffice\Templates\1033\Access\ にあるフォルダーで Blank.accdb という名前のファイルを検索します。 存在する場合、 Blank.accdb はすべての新しい空のデータベースのテンプレートになります。 含まれるすべてのコンテンツは、すべての新しい空のデータベースに継承されます。 これは、部品番号や会社の免責事項やポリシーなどの既定のコンテンツを配布する良い方法です。

重要

Table1 を一度も保存せずに閉じると、テーブル 1 にデータを入力したとしてもテーブル全体が削除されます。

表を追加する

[作成] タブの [テーブル] グループのコマンドを使用して、既存のデータベースに新しいテーブルを追加できます。

Access のリボンの画像

データシート ビューで開始してテーブルを作成する データシート ビューでは、すぐにデータを入力し、Access でテーブル構造をバックグラウンドで構築できます。 フィールド名は数値で割り当てられ (Field1、Field2 など)、入力したデータに基づいて各フィールドのデータ型が自動的に設定されます。

  1. [作成] タブの [テーブル] で、[テーブル] をクリックします。
    Access によってテーブルが作成され、[ クリックして追加 ] 列の最初の空のセルが選択されます。
  2. [ テーブルのフィールド] タブの [ 追加 & 削除 ] グループで、追加するフィールドの種類をクリックします。 目的のタイプが表示されない場合は、[その他のフィールド] をクリックします。
  3. よく使用されるフィールドの種類の一覧が表示されます。 目的のフィールドの種類をクリックすると、データシートの挿入ポイントに新しいフィールドが追加されます。
    フィールドをドラッグすると移動できます。 データシート内のフィールドをドラッグすると、フィールドが配置される場所に垂直挿入バーが表示されます。
  4. データを追加するには、「 別のソースから Access のテーブルにデータをコピーする」セクションの説明に従って、最初の空のセルで入力を開始するか、別のソースのデータを貼り付けます。
  5. 列 (フィールド) の名前を変更するには、列見出しをダブルクリックして、新しい名前を入力します。
    各フィールドにわかりやすい名前を付けておくと、[ フィールド リスト ] ウィンドウに表示されたときにそのフィールドに何が含まれているかがわかります。
  6. 列を移動するには、その見出しをクリックして列を選択し、列を目的の場所にドラッグします。 複数の連続する列を選択して、それらを一度に新しい場所にドラッグすることもできます。 複数の連続する列を選択するには、最初の列の列見出しをクリックし、Shift キーを押しながら最後の列の列見出しをクリックします。

テーブルを作成する、デザイン ビューで開始する デザイン ビューで、まずテーブル構造を作成します。 次に、データシート ビューに切り替えてデータの入力を入力するか、貼り付け、インポートなどの他の方法を使用してデータを入力します。

  1. [作成] タブで、[テーブル] グループの [テーブル デザイン] をクリックします。

  2. テーブルのフィールドごとに、[ フィールド名 ] 列に名前を入力し、[ データ型 ] ボックスの一覧からデータ型を選択します。

  3. 必要に応じて、[ 説明] 列に各フィールドの説明を入力できます。 データシート ビューのそのフィールドにカーソルが置かれると、説明がステータス バーに表示されます。 また、この説明は、[ フィールド リスト ] ウィンドウからフィールドをドラッグして作成するフォームまたはレポート内のコントロール、およびフォーム ウィザードまたはレポート ウィザードの使用時にそのフィールド用に作成されるすべてのコントロールのステータス バー テキストとしても使用されます。

  4. すべてのフィールドを追加したら、テーブルを保存します。

    • [ファイル] タブで [保存] をクリックします。
  5. データシート ビューに切り替えて最初の空のセルをクリックすることによって、いつでもテーブルへのデータの入力を開始できます。 「 別のソースのデータを Access のテーブルにコピーする」セクションの説明に従って、別のソースのデータを貼り付けることもできます。

フィールドのプロパティをデザイン ビューで設定する テーブルの作成方法にかかわらず、フィールド プロパティを調べて設定することをお勧めします。 一部のプロパティはデータシート ビューで使用できますが、一部のプロパティはデザイン ビューでのみ設定できます。 デザイン ビューに切り替えるには、ナビゲーション ウィンドウでテーブルを右クリックし、[ デザイン ビュー] をクリックします。 フィールドのプロパティを表示するには、デザイン グリッドでフィールドをクリックします。 プロパティは、デザイン グリッドの下の [フィールド プロパティ] の下に表示されます。

各フィールド プロパティの説明を表示するには、プロパティをクリックし、[ フィールド プロパティ] のプロパティ一覧の横のボックスの説明を読みます。 [ヘルプ] ボタンをクリックすると、より詳細な情報を取得できます。

次の表に、一般的に調整されるフィールド プロパティの一部を示します。

プロパティ 説明
フィールド サイズ テキスト フィールドの場合、このプロパティによりフィールドに格納できる最大文字数が設定されます。 最大値は 255 です。 数値型フィールドの場合、このプロパティは格納される数値の種類を設定します (長整数型、倍精度浮動小数点数型など)。 最も効率的なデータ ストレージのために、データに必要と思われる最小限の領域を割り当てるようにすることをお勧めします。 ニーズが変わった場合は、後で値を上向きに調整できます。
書式設定 このプロパティは、データの表示方法を設定します。 フィールドに格納されている実際のデータには影響しません。 定義済みの形式を選択するか、カスタム形式を入力できます。
定型入力 このプロパティを使用して、このフィールドに入力されるすべてのデータのパターンを指定します。 これにより、すべてのデータが正しく入力され、必要な数の文字が含まれていることを確認できます。 定型入力の作成に関するヘルプについては、プロパティ ボックスの右側にある [ビルダー] ボタン をクリックします。
既定値 このプロパティを使用して、新しいレコードが追加されるたびにこのフィールドに表示される既定値を指定します。 たとえば、レコードが追加された日付を常に記録する必要がある日付/時刻型フィールドがある場合は、既定値として「Date()」(引用符なし) を入力できます。
必須 このプロパティは、このフィールドに値が必要かどうかを設定します。 このプロパティを [はい] に設定すると、このフィールドに値が入力されていない限り、新しいレコードを追加できません。

ページの先頭へ

別のソースから Access のテーブルにデータをコピーする

データが現在 Excel などの別のプログラムに保存されている場合は、そのデータをコピーして Access の表に貼り付けることができます。 一般に、これは Excel ワークシート内のように、データが既に列に分かれている場合に最適です。 データがワープロ プログラムにある場合は、データをコピーする前に、タブを使用してデータの列を区切るか、ワープロ プログラムでデータをテーブルに変換することをお勧めします。 データを編集または操作する必要がある場合 (たとえば、フル ネームを名と姓に区切るなど) は、データをコピーする前にこれを行うことをお勧めします (特に、Access に慣れていない場合)。

空の表にデータを貼り付けると、Access はそこで見つかったデータの種類に応じて、各フィールドのデータ型を設定します。 たとえば、貼り付けたフィールドに日付の値しか入力されていない場合、Access はそのフィールドに日付/時刻型を適用します。 貼り付けたフィールドに "yes" と "no" という単語のみが含まれている場合は、そのフィールドに Yes/No データ型が適用されます。

Access では、貼り付けたデータの 1 行目に見つかった内容に応じてフィールドに名前が付けられます。 貼り付けたデータの最初の行の種類が次の次の行と似ている場合、Access では最初の行がデータの一部であると判断され、フィールドに汎用名 (F1、F2 など) が割り当てられます。 貼り付けたデータの 1 行目が次の行と異なる場合、Access では 1 行目はフィールド名で構成されていると判断されます。 Access はフィールドに適した名前を付け、データの最初の行は含みません。

Access で汎用フィールド名が割り当てられる場合は、混乱を避けるため、できるだけ早くフィールドの名前を変更してください。 次の手順で行います。

  1. Ctrl+S キーを押してテーブルを保存します。
  2. データシート ビューで、各列見出しをダブルクリックして、各列のわかりやすいフィールド名を入力します。
  3. テーブルをもう一度保存します。

注

また、デザイン ビューに切り替えてフィールド名を編集することで、フィールドの名前を変更することもできます。 デザイン ビューに切り替えるには、ナビゲーション ウィンドウでテーブルを右クリックし、[ デザイン ビュー] をクリックします。 データシート ビューに戻すには、ナビゲーション ウィンドウでテーブルをダブルクリックします。

ページの先頭へ

別のプログラムに格納されているデータがあり、そのデータを新しいテーブルにインポートするか、Access の既存のテーブルに追加する場合。 または、他のプログラムにデータを保存しているユーザーと一緒に作業し、そのデータをリンクして Access で操作したい場合もあります。 どちらの方法でも、Access によって他のソースのデータを簡単に操作できます。 Excel ワークシート、別の Access データベースのテーブル、SharePoint リスト、その他さまざまなソースからデータをインポートできます。 使用するプロセスは、ソースによって若干異なりますが、次の手順で開始できます。

  1. Access の [外部データ ] タブの [リンクのインポート & ] グループで [ 新しいデータ ソース] を選択し、インポートするファイルの種類のコマンドを選択します。
    たとえば、Excel ワークシートからデータをインポートする場合は、[新しいデータ ソース]>ファイルから>Excel をクリックします。

    注

    [ インポート & リンク ] グループで正しい形式の種類が見つからない場合、データを最初に作成したプログラムを起動して、そのプログラムを使用して一般的なファイル形式 (区切りテキスト ファイルなど) でデータを保存してから、そのデータを Access にインポートする必要があります。

  2. [ 外部データの取り込み ] ダイアログ ボックスで、[ 参照 ] をクリックしてソース データ ファイルを見つけるか、[ ファイル名 ] ボックスにソース データ ファイルの完全パスを入力します。

  3. [現在のデータベースでデータを格納する方法と場所を指定する] で、必要なオプションをクリックします (すべてのプログラムでインポートでき、一部のプログラムで追加またはリンクできます)。 インポートしたデータを使用する新しいテーブルを作成したり、(プログラムによっては) 既存のテーブルにデータを追加したり、ソース プログラムのデータへのリンクを維持するリンク テーブルを作成したりすることができます。

  4. ウィザードが起動したら、ウィザードの次の数ページの指示に従います。 ウィザードの最後のページで、[完了] をクリックします。
    Access データベースからオブジェクトをインポートするかテーブルをリンクする場合は、[ オブジェクトのインポート ] ダイアログ ボックスまたは [テーブルのリンク ] ダイアログ ボックスが表示されます。 目的のアイテムを選択し、[ OK] をクリックします。
    正確なプロセスは、データをインポート、追加、またはリンクするかどうかによって異なります。

  5. Access では、実行したばかりのインポート操作の詳細を保存するかどうかを確認するメッセージが表示されます。 今後、同じインポート操作を再度実行すると思われる場合は、[ インポート手順の保存] をクリックし、詳細を入力します。 その後、[外部データ] タブの [インポート & リンク] グループの [保存されたインポート] をクリックすると操作を簡単に繰り返すことができます。操作の詳細を保存しない場合は、[閉じる] をクリックします。

テーブルのインポートを選択した場合、Access によって新しいテーブルにデータがインポートされ、ナビゲーション ウィンドウの [テーブル ] グループにそのテーブルが表示されます。 既存のテーブルにデータを追加することを選択した場合は、そのテーブルにデータが追加されます。 データにリンクするように選択した場合は、ナビゲーション ウィンドウの [テーブル ] グループにリンク テーブルが作成されます。

ページの先頭へ

アプリケーション パーツを追加する

アプリケーションパーツを使用して、既存のデータベースに機能を追加できます。 アプリケーションパーツは、1 つのテーブルのように単純なものもあれば、テーブルやバインドされたフォームなどの複数の関連オブジェクトで構成することもできます。

たとえば、コメント アプリケーション パーツは、オートナンバー ID フィールド、日付フィールド、メモ フィールドを含むテーブルで構成されます。 任意のデータベースに追加して、そのまま使用することも、最小限のカスタマイズで使用することもできます。

  1. アプリケーションパーツを追加するデータベースを開きます。
  2. [作成] タブをクリックします。
  3. 「 テンプレート」 グループで、「 アプリケーション・パーツ」をクリックします。 使用可能な部品のリストが開きます。
  4. 追加するアプリケーション部品をクリックします。

ページの先頭へ

既存の Access データベースを開く

  1. [ファイル] タブの [開く] をクリックします。

  2. [ ファイルを開く ] ダイアログ ボックスで、開くデータベースを参照します。

  3. 次のいずれかの操作を行います。

    • データベースをダブルクリックして、[ Access のオプション] ダイアログ ボックスで指定された既定のモード、または管理ポリシーによって設定されたモードで開きます。
    • [ 開く ] をクリックしてマルチユーザー環境で共有アクセス用にデータベースを開き、自分と他のユーザーがデータベースを読み書きできるようにします。
    • [ 開く ] ボタンの横にある矢印をクリックし、[ 読み取り専用で開く ] をクリックしてデータベースを読み取り専用アクセスで開き、データベースを表示することはできますが、編集することはできます。 他のユーザーは引き続きデータベースの読み取りと書き込みを行うことができます。
    • [ 開く ] ボタンの横にある矢印をクリックし、[ 排他的開く] をクリックして、排他的アクセスを使用してデータベースを開きます。 排他的アクセスでデータベースを開いていると、データベースを開こうとした他のユーザーが "既に使用されているファイル" メッセージが表示されます。
    • [ 開く ] ボタンの横にある矢印をクリックし、[ 排他的読み取り専用を開く ] をクリックして、読み取り専用アクセスでデータベースを開きます。 他のユーザーは引き続きデータベースを開くことができますが、読み取り専用モードに制限されます。

注

dBASE、MicrosoftExchange、Excel などの外部ファイル形式のデータ ファイルを直接開くことができます。 MicrosoftSQL Server などの ODBC データ ソースを直接開くこともできます。 Access では、データ ファイルと同じフォルダーに新しい Access データベースが自動的に作成され、外部データベースの各テーブルへのリンクが追加されます。

ヒント

  • 最近開いたデータベースの 1 つを開くには、[ ファイル ] タブで [ 最近使用] をクリックし、そのデータベースのファイル名をクリックします。 Access では、前回データベースを開いたときと同じオプション設定を使用してデータベースを開きます。 最近使用したファイルのリストが表示されない場合は、[ ファイル ] タブで [オプション] をクリックします。 [ Access のオプション] ダイアログ ボックスで、[ クライアントの設定] をクリックします。 [ 表示] で、[最近使用したドキュメント] リストに表示するドキュメントの数を入力します。最大 50 個までを入力します。
    2 クリックで Backstage ビューのナビゲーション バーに最近使用したデータベースを表示することもできます。1) [ファイル ] タブ、2) 開く最近使用したデータベース。 [最近使ったファイル] タブの下部付近にある [この数の最近使ったデータベースにすばやくアクセスする] チェック ボックスをオンにして、表示するデータベースの数を調整します。
  • [ファイル] タブの [開く] コマンドをクリックしてデータベースを開く場合、[開く] ダイアログ ボックスの [最近使ったドキュメント] をクリックすると、以前に開いたデータベースへのショートカットの一覧を表示できます。

ページの先頭へ