以前のバージョンの Access のカスタム ツールバーとスタートアップ設定を使う

適用先
Access for Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

以前のバージョンの Microsoft Office Access でカスタム ツールバーとメニュー バーを作成した場合、この記事では、現在のバージョンの Access でこれらの設定を開いたときにどのように動作するかについて説明します。

この記事の内容

以前のバージョンのデータベースの現在のバージョンでの動作

以前のバージョンの Access データベース (.mdb ファイル) にカスタム ツールバー、カスタム メニュー バー、またはカスタム起動動作が含まれている場合は、データベースをより新しいバージョンで開くとき、またはそのレガシ データベースを .accdb ファイルまたは .accde ファイルに変換するときにオプションを保持できます。 たとえば、Access 2003 で作成されたデータベースで組み込みのツールバーをオフにして既定のメニュー バーを置き換えた場合、以前のバージョンの Access を使用して変更しない限り、現在のバージョンの Access でデータベースを開いたときにその動作は維持されます。

現在のバージョンで従来のファイル (.mdb、.mde、および .mda ファイル) を開くときにリボンを非表示にしたり、Access オプションを使用してリボンとツール バーの動作をカスタマイズすることで、以前のバージョンのファイルに対して異なる動作を定義したりできます。 詳細については、「カレント データベースのユーザー オプションを設定する」を参照してください。

以前のバージョンの Access データベースを開き、リボンの表示を選択すると、[ アドイン ] タブにカスタム ツールバーがグループとして表示されます。タブ内の各グループはカスタム ツールバーに対応し、各グループでは元のツールバーに割り当てられた名前が使用されます。 ただし、ツールバーは従来のデータベースに表示されている必要があります。そうでない場合は、タブに表示されません。

注

カスタム起動動作をバイパスするには、Shift キーを押しながらデータベースを開きます。

カスタム ツールバーを含む以前のバージョンのデータベースを開く

  1. [ファイル] タブをクリックし、[開く] をクリックします。
    [ファイルを開く] ダイアログ ボックスが表示されます。

  2. データベース ファイル (.mdb または .mde ファイル) を選択し、[ 開く] をクリックします。
    以前のバージョンのデータベースが開かれ、データベース オブジェクトがナビゲーション ウィンドウに表示されます。 フォーム、交換機、その他のオブジェクトを起動時に表示されるように設定している場合は、それらのオブジェクトもナビゲーション ウィンドウに表示されます。 また、カスタム ツールバーまたはメニュー バーを作成した場合、[ アドイン ] タブに 1 つ以上のグループとして表示されます。 各グループは、カスタム ツール バーまたはメニュー バーに最初に割り当てられた名前を使用します。

    注

    [ アドイン ] タブが表示されていない場合は、[ ファイル ] タブ、[ オプション]、[ リボンのユーザー設定] の順にクリックします。 [ リボンのユーザー設定] 領域で、[ アドイン ] オプションが選択されていることを確認します。

  3. [ アドイン] タブをクリックします。
    カスタム ツールバーは 1 つ以上のグループとして表示され、必要なときにツールバーを使用できます。 たとえば、カスタム ツールバーに [ リレーションシップの印刷 ] コマンドが含まれている場合、データベースのリレーションシップを表示するまで、Access ではそのコマンドは有効になりません。

カスタム メニュー バーのみを使用するように Access を設定する

  1. 以前のバージョンの Access データベースを現在のバージョンで開きます。
  2. [ファイル] タブをクリックし、[オプション] をクリックします。
  3. [Access のオプション] ダイアログ ボックスで [カレント データベース] をクリックします。
  4. [リボンとツールバーのオプション] で、[すべてのメニューを許可] オプションをオフにし、[OK] をクリックします。

ページの先頭へ