ダッシュボードは、主要な指標を視覚的に表現したものであり、データを 1 か所ですばやく表示および分析できます。 ダッシュボードは、統合されたデータ ビューを提供するだけでなく、ユーザーがデータをフィルタリングして重要なものだけを表示できるセルフサービスのビジネス インテリジェンスの機会を提供します。 以前は、Excel のレポートを作成するには、ニーズに応じて、さまざまな人や部門に対して複数のレポートを生成する必要がありました。
このトピックでは、複数のピボットテーブル、ピボットグラフ、ピボットテーブル ツールを使用して動的ダッシュボードを作成する方法について説明します。 次に、スライサーとタイムラインを使用して、ユーザーが希望どおりにデータをすばやくフィルター処理できるようにします。これにより、ピボットテーブルとグラフが自動的に拡大および縮小して、ユーザーが表示したい情報のみが表示されます。 さらに、データを追加または更新するときにダッシュボードをすばやく更新できます。 これは、ダッシュボード レポートを 1 回作成するだけでよいので、非常に便利です。
例として、1 つのデータ ソースから 4 つのピボットテーブルとピボットグラフを作成します。
ダッシュボードを作成したら、Microsoft グループを作成してユーザーとダッシュボードを共有する方法について説明します。 対話型の Excel ブックも用意されており、ダウンロードして自分で次の手順を実行することができます。
Excel ダッシュボードのチュートリアル ブックをダウンロードする。
データを取得する
データを直接コピーして Excel に貼り付けたり、データ ソースからクエリを設定したりできます。 このトピックでは、Microsoft Access 用の Northwind Traders テンプレートの Sales Analysis クエリを使用しました。 このファイルを使用する場合は、Access を開いて [ファイル>新規作成>検索] に移動し、[検索] に「Northwind」と入力してテンプレート データベースを作成します。 これを行うと、テンプレートに含まれるクエリにアクセスできるようになります。 このデータは既に Excel ブックに記述されていますので、アクセス権がなくても心配する必要はありません。
データが適切に構造化されていて、行や列が不足しないことを確認します。 各行が個別のレコードまたは項目を表しているはずです。 クエリの設定に関するヘルプが必要な場合、またはデータを操作する必要がある場合は、「 Excel で & 変換を取得する」を参照してください。
データが Excel の表として書式設定されていない場合は、書式設定します。 Access からインポートすると、データは表に自動的にインポートされます。
ピボットテーブルを作成する
データ範囲内の任意のセルを選択し、[挿入]>[ピボットテーブル]>新しいワークシートに移動します。 詳細については、「ピボットテーブルを作成してワークシート データを分析する」を参照してください。
必要なピボットテーブル フィールドを追加し、必要な書式を設定します。 このピボットテーブルは他のピボットテーブルの基礎となるため、スタイル、レポートのレイアウト、一般的な書式設定に必要な調整に時間を費やして、何度も行う必要がないようにしてください。 詳細については、「 ピボットテーブルのレイアウトと書式をデザインする」を参照してください。
今回のサンプルでは、売上を製品カテゴリ別にまとめています。売上フィールドを降順に並べています。
詳細については、「ピボット テーブルまたはピボット グラフのデータを並べ替える」を参照してください。
マスター ピボットテーブルを作成したら、マスター ピボットテーブルを選択し、必要な回数だけコピーして貼り付け、ワークシートの領域を空にします。 この例では、これらのピボットテーブルは行を変更できますが、列を変更できないため、間に空白列を置いて同じ行に配置しました。 ただし、ピボットテーブルが列を展開できる場合は、ピボットテーブルを互いに下に配置する必要がある場合があります。
重要
ピボットテーブルは互いに重なり合うことができないので、フィルタリング、追加、または削除された値に応じてピボットテーブル間を拡大および縮小できるように、ピボットテーブル間の十分なスペースを確保する設計にしてください。
この時点で、ピボットテーブルにわかりやすい名前を付けて、その動作を把握することができます。 それ以外の場合、Excel はそれらに PivotTable1、PivotTable2 などの名前を付けます。 それぞれを選択し、[ピボットテーブル分析]>ピボットテーブルの順に移動し、[ピボットテーブル名] ボックスに新しい名前を入力します。 分かりやすい名前があることは、ピボットテーブルをスライサー コントロールやタイムライン コントロールに接続するときに重要になります。
ピボットグラフを作成する
最初のピボットテーブルの任意の場所をクリックし、ピボットテーブルの[分析]>[ツール]>[ピボットグラフ] に移動し、グラフの種類を選択します。 ここでは、集合縦棒グラフとして売上高を、第 2 軸にプロットされた折れ線グラフとして [合計率 (% Total)] を含む複合グラフを選択しました。
グラフを選択し、 ピボットグラフの [分析]、[ デザイン]、[ 書式] タブから必要に応じてサイズと書式を設定します。 詳細については、 グラフの書式設定に関するシリーズをご覧ください。
残りのピボットテーブルにも同じ作業を繰り返します。
ここで、ピボットグラフの名前も変更する良い機会です。 [ピボットグラフ分析]>[ピボットグラフ] に移動し、[グラフ名] ボックスに新しい名前を入力します。
スライサーとタイムラインを追加する
スライサーとタイムラインを使用すると、ピボットテーブルとピボットグラフをすばやくフィルター処理して、意味のある情報だけを表示することができます。
いずれかのピボットテーブルを選択し、[ピボットテーブルの分析]>[フィルター]>[スライサーの挿入] に移動し、スライサーに使用する各項目をチェックします。 このダッシュボードでは、[ カテゴリ]、[ 製品名]、[ 従業員]、 および [顧客名] を選択しました。 [ OK] をクリックすると、スライサーが画面の中央に追加され、重なり合うため、必要に応じて配置やサイズを変更する必要があります。
スライサーのオプション: スライサーをクリックすると、[ スライサー] タブに移動し、[ スタイル] や表示される列数などのさまざまなオプションを選択できます。 Ctrl + 左クリックで複数のスライサーを選択して配置し、[スライサー ツール] タブの [配置ツール] を使用できます。
スライサー接続:スライサーは作成に使用したピボットテーブルにのみ接続されるため、各スライサーを選択し、[スライサー>スライサー>レポート接続] に移動して、それぞれに接続するピボットテーブルチェック必要があります。 スライサーとタイムラインは、ワークシートが非表示になっていても、任意のワークシートのピボットテーブルを制御できます。
タイムラインを追加します。任意のピボットテーブルを選択し、[ピボットテーブルの分析]>[フィルター]>[タイムラインの挿入] に移動し、使用する各アイテムをチェックします。 このダッシュボードでは、[ 注文日] を選択しました。
タイムライン オプション: [タイムライン] をクリックし、[ タイムライン ] タブに移動して、[ スタイル]、[ ヘッダー]、[ キャプション] などのオプションを選択します。 [レポートの接続] オプションを選択すると、選択したピボットテーブルにタイムラインがリンクされます。
スライサー コントロールの詳細はこちらで、タイムライン コントロールの詳細はこちらで確認できます。
次のステップ
これでダッシュボードは機能的には完成しましたが、希望どおりに配置し、最終的な調整を行う必要があります。 たとえば、レポート タイトルや背景などを追加できます。 ダッシュボードでは、ピボットテーブルの周囲に図形を追加し、[表示] タブから [見出し] と [グリッド線] をオフにしました。
必ず各スライサーとタイムラインをテストして、ピボットテーブルとピボットグラフが希望どおりに動作することを確認します。 あるピボットテーブルで別のピボットテーブルを調整して重なりたい場合に、特定の選択で問題が発生することがありますが、それができず、エラー メッセージが表示されます。 これらの問題は、ダッシュボードを配布する前に修正する必要があります。
ダッシュボードの設定が完了したら、このトピックの上部にある [ ダッシュボードを共有する ] タブをクリックして、ダッシュボードの配布方法を学習できます。
関連項目
このページで回答されていない質問はありますか?
Microsoft Answers コミュニティにアクセスしてください。