ピボットテーブルのレイアウトと書式のデザイン

適用先
Excel for Microsoft 365 Excel 2024 Excel 2024 for Mac Excel 2021 Excel 2021 for Mac Excel 2019 Excel 2016

ピボットテーブルを作成し、分析するフィールドを追加した後、データを見やすく表示したり、詳細を簡単にスキャンしたりできるように、レポートのレイアウトや書式を補正することが必要になる場合があります。 ピボットテーブルのレイアウトを変更するには、ピボットテーブル フォームを変更するか、フィールド、列、行、小計、空のセル、行の表示方法を変更することができます。 ピボットテーブルの書式を変更するには、定義済みのスタイル、縞模様の行、条件付き書式を適用できます。 

ピボットテーブルのレイアウト フォームの変更

ピボットテーブルまたはその各種フィールドのレイアウトを大幅に変更する場合は、次に示す 3 つの形式のいずれかを使用できます。

  • コンパクト形式 異なる行領域フィールドのアイテムが 1 つの列に表示され、異なるフィールドのアイテムを区別するためにインデントが使用されます。 コンパクト形式では、行ラベルで使用されるスペースが減り、より広いスペースを数値データに使用できます。 また、コンパクト形式では、[展開] ボタンと [折りたたみ] ボタンが表示され、詳細の表示/非表示を切り替えることができます。 コンパクト形式は領域の節約になり、ピボットテーブルをより読みやすくするため、ピボットテーブルの既定のレイアウト形式として指定されます。
    コンパクト形式のピボットテーブル
  • アウトライン形式 は表形式と似ていますが、次の列内のアイテムが現在のアイテムの下に表示されるので、各グループの最上部に小計を表示することができます。
    アウトライン形式のピボットテーブル
  • 表形式 1 つのフィールドに 1 つの列が表示され、フィールド見出し用のスペースが設けられます。
    表形式のピボットテーブル

ピボットテーブルの形式 (コンパクト、アウトライン、または表形式) を変更する

  1. ピボットテーブル内の任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ デザイン ] タブの [レイアウト ] グループで [ レポートのレイアウト] を選択し、次のいずれかの操作を行います。

    [ピボットテーブルのデザイン] タブの [レポートのレイアウト] メニュー

    • 関連データが画面の横方向にはみ出ないようにし、スクロールを最小限に抑えるには、[ コンパクト形式で表示] を選択します。
      コンパクト形式では、フィールドが 1 つの列内にあり、列の入れ子関係がわかるようにインデントされます。
    • データの概要を従来のピボットテーブル スタイルで表示するには、[ アウトライン形式で表示] を選択します。
    • すべてのデータを従来の表形式で表示し、セルを別のワークシートに簡単にコピーするには、[ 表形式で表示] を選択します。

レイアウト フォームでアイテム ラベルの表示方法を変更する

  1. ピボットテーブルで、行フィールドを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。
    アウトラインまたは表形式で行フィールドをダブルクリックして、手順 3 に進むこともできます。

  2. [ ピボットテーブルの分析 ] タブの [アクティブなフィールド ] グループで、[ フィールドの設定] を選択します。
    アイテム ラベルのレイアウトを変更するためのフィールド設定コマンド

  3. [ フィールドの設定 ] ダイアログ ボックスで、[レイアウト] & [ 印刷 ] タブを選択し、[ レイアウト] で次のいずれかの操作を行います。

    • アウトライン形式でフィールド アイテムを表示する には、[アイテム ラベルをアウトライン形式で表示する] を選択します。
    • コンパクト形式で隣のフィールドのラベルを同じ列内に表示したり非表示にしたりするには、[ アイテムのラベルをアウトライン形式で表示する] を選択し、[ 隣のフィールドのラベルを同じ列内に表示する (コンパクト形式)] を選択します。
    • フィールド アイテムを表形式で表示するには、[ アイテムのラベルを表形式で表示する] を選びます。

ピボットテーブルのフィールドの配置を変更する

最終的に希望どおりのレイアウト結果を得るために、ピボットテーブルのフィールド リストを使用してフィールドの追加、並べ替え、削除を行うことができます。

ピボットテーブルのフィールド リストが表示されない場合は、ピボットテーブルが選択されていることを確認します。 それでも表示されない場合、[ ピボットテーブルのフィールド リスト] タブの [ 表示 ] グループで、[ フィールド リスト] を選択します。

使用するフィールドがピボットテーブルのフィールド リストに表示されない場合、ピボットテーブルを更新して、最後の操作以降に追加した新しいフィールド、集計フィールド、メジャー、計算メジャー、またはディメンションを表示する必要が生じることがあります。 [ ピボットテーブルの分析 ] タブの [データ ] グループで、[ 更新] を選択します。

ピボットテーブルのフィールド リストを操作する方法の詳細については、「 フィールド リストを使ってピボットテーブル内でフィールドを配置する」を参照してください。

ピボットテーブルにフィールドを追加する

次のいずれか 1 つまたは複数の操作を行います。

  • フィールド セクションで各フィールド名の横にあるチェック ボックスをオンにします。 このフィールドは、レイアウト セクションの既定の領域に配置されますが、必要な場合はフィールドを並べ替えることができます。
    既定では、テキスト フィールドは [行ラベル] 領域に追加され、数値フィールドは [値] 領域に追加され、オンライン分析処理 (OLAP) の日付と時間の階層は [列ラベル] 領域に追加されます。
  • フィールド名を右クリックし、適切なコマンド ([レポート フィルターに追加]、[列ラベルに追加]、[行ラベルに追加]、または [値に追加]) を選択して、レイアウト セクションの特定の領域にフィールドを配置します。
  • フィールド名をクリックして押したままにし、フィールド セクションとレイアウト セクションの領域の間でフィールドをドラッグすることができます。

ピボットテーブルのフィールドをコピーする

Excel ワークシートのデータまたは OLAP 以外のソース データからの外部データに基づくピボットテーブルでは、[値の表示方法] 機能を使用して異なる計算を表示できるように、同じフィールドを [値] 領域に複数回追加することができます。 たとえば、売上総利益率と純利益率、売上高の最小値と最大値、顧客数と総顧客数に対する割合などの計算値を並べて表示し、比較することが必要な場合があります。 詳細については、「ピボット テーブルの値フィールドに別の計算を表示する」を参照してください。

  1. フィールド セクションでフィールド名をクリックして押したままにし、そのフィールドをレイアウト セクションの [値 ] 領域にドラッグします。

  2. 手順 1 を必要な回数だけ繰り返して、フィールドをコピーします。

  3. コピーした各フィールドで、集計関数またはユーザー設定の計算を目的に合わせて変更します。

    注

    • 同じフィールドのコピーであるか異なるフィールドのコピーであるかに関係なく、複数のフィールドを [値] 領域に追加すると、フィールド リストの [値] 領域に値列ラベルが自動的に追加されます。 このフィールドを使用して、[値] 領域内でフィールドの位置を上下に移動できます。 値列ラベルを [列ラベル] 領域または [行ラベル] 領域に移動することもできます。 ただし、値列ラベルを [レポート フィルター] 領域に移動することはできません。
    • フィールドは、データ型が数値型であるかどうかに関係なく、[レポート フィルター] 領域、[行ラベル] 領域、[列ラベル] 領域のいずれかに 1 回のみ追加できます。 同じフィールドを 2 回以上追加しようとすると (たとえば、レイアウト セクションの [行ラベル] 領域と [列ラベル] 領域に追加しようとした場合)、フィールドは元の領域から自動的に削除されて、新しい領域に配置されます。
    • 同じフィールドを [値] 領域に追加するもう 1 つの方法は、数式内の同じフィールドを使用する数式 (集計列とも呼ばれます) を使用することです。
    • OLAP データ ソースに基づくピボット テーブルでは、同じフィールドを複数回追加することはできません。

ピボットテーブルのフィールドを並べ替える

レイアウト セクションの下部にある 4 つの領域のいずれかを使用して、既存のフィールドを並べ替えるか、またはそれらのフィールドの位置を変更することができます。

ピボットテーブル レポート 説明 ピボットグラフ 説明
値 集計した数値データを表示するために使用します。 値 集計した数値データを表示するために使用します。
行ラベル フィールドをレポートの横側の行として表示するために使用します。 下の位置にある行は、そのすぐ上の別の行にネストされます。 軸フィールド​​ (カテゴリ) フィールドをグラフの軸として表示するために使用します。
列ラベル フィールドをレポートの上部の列として表示するために使用します。 下の位置にある列は、そのすぐ上の別の列にネストされます。 凡例​​フィールド​​ (系列) ラベル フィールドをグラフの凡例に表示するために使用します。
レポート フィルター レポート フィルターで選択したアイテムに基づいてレポート全体をフィルター処理するために使用します。 レポート フィルター レポート フィルターで選択したアイテムに基づいてレポート全体をフィルター処理するために使用します。

フィールドを並べ替えるには、1 つの領域でフィールド名を選び、次のコマンドのいずれかを選びます。

選択するコマンド 結果
上へ移動 フィールドを領域内の 1 つ上の位置に移動します。
下へ移動 フィールドを領域内の下の位置に移動します。
先頭へ移動 フィールドを領域の先頭に移動します。
末尾へ移動 フィールドを領域の末尾に移動します。
レポート​​ フィルター​​に移動 フィールドを [レポート フィルター] 領域に移動します。
行ラベルに移動 フィールドを [行ラベル] 領域に移動します。
列ラベルに移動 フィールドを [列ラベル] 領域に移動します。
値​​に移動 フィールドを [値] 領域に移動します。
値フィールドの設定、フィールドの設定 [フィールドの設定] ダイアログ ボックスまたは [値フィールドの設定] ダイアログ ボックスを表示します。 各設定の詳細については、ダイアログ ボックスの上部にある [ヘルプ] ボタンの画像 を参照してください。

フィールド名をクリックして押したままにし、フィールド セクションとレイアウト セクション間、および異なる領域間でフィールドをドラッグすることもできます。

ピボットテーブルからフィールドを削除する

  1. ピボットテーブルをクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. 必要に応じてピボットテーブルのフィールド リストを表示するには、[ ピボットテーブルの分析 ] タブの [ 表示 ] グループで [ フィールド リスト] を選択します。 ピボットテーブルを右クリックし、[フィールド リストの表示] を選択することもできます。

  3. フィールドを削除するには、ピボットテーブルのフィールド リストで、次のいずれかの操作を行います。

    • ピボット テーブルのフィールド リストでフィールド名の横にあるチェック ボックスをオフにします。

      注

      フィールド リストのチェック ボックスをオフにすると、フィールドのすべてのインスタンスがレポートから削除されます。

    • レイアウト領域で、フィールド名を選択し、[ フィールドの削除] を選択します。

    • レイアウト セクションでフィールド名をクリックして押したままにし、ピボットテーブルのフィールド リストの外部にドラッグします。

列、行、小計のレイアウトを変更する

ピボットテーブルのレイアウトをさらに細かく設定するために、列、行、および小計のレイアウトに影響を与える変更を行うことができます。たとえば、行の上に小計を表示したり、列見出しを非表示にしたりできます。 また、行または列内の個々のアイテムを再配置することもできます。

列フィールドおよび行フィールドの見出しの表示と非表示を切り替える

  1. ピボットテーブルを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。
  2. フィールドの見出しの表示と非表示を切り替えるには、[ ピボットテーブルの [分析 ] タブの [ 表示 ] グループで [ フィールドの見出し] を選択します。

行の上または下に小計を表示する

  1. ピボットテーブルで、小計を表示する行フィールドを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

    ヒント

    アウトライン形式または表形式で行フィールドをダブルクリックして、手順 3 に進むこともできます。

  2. [ ピボットテーブルの分析 ] タブの [アクティブなフィールド ] グループで、[ フィールドの設定] を選択します。
    小計を構成するためのフィールド設定コマンド

  3. [ フィールド設定] ダイアログ ボックスの [ 小計 & フィルター ] タブの [ 小計] で、[ 自動] または [カスタム] を選択します。

    注

    [なし] を選択すると、小計は表示されません。

  4. [レイアウト] & [印刷 ] タブの [レイアウト] で、[ アイテムのラベルをアウトライン形式で表示する] を選び、次のいずれかの操作を行います。

    • 集計した行の上に小計を表示するには、[小計を各グループの先頭に表示する] チェック ボックスをオンにします。 このオプションは、既定でオンになっています。
    • 集計した行の下に小計を表示するには、[小計を各グループの先頭に表示する] チェック ボックスをオフにします。

行または列のアイテムの順序を変更する

次のいずれかの操作を実行します。

  • ピボットテーブルで、ラベル内の行や列のラベルまたはアイテムを右クリックし、[移動] をポイントして、[移動] メニューのいずれかのコマンドを使用してアイテムを別の場所に移動します。
  • 移動する行または列のラベル アイテムを選択して、セルの下側の境界をポイントします。 ポインターが四方向矢印のポインターに変わったら、アイテムを新しい位置にドラッグします。 次の図では、行アイテムをドラッグして移動する方法を示します。
    ピボットテーブル レポートでアイテムを移動する例

更新時に列の幅を調整する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ ピボットテーブルの分析 ] タブの [ ピボットテーブル ] グループで、[ オプション] を選択します。
    アイテム ラベルを結合するためのピボットテーブル オプション コマンド

  3. [ ピボットテーブル オプション] ダイアログ ボックスの [ レイアウト] タブ & [書式 ] タブの [書式] で、次のいずれかの操作を行います。

    • 最も幅が広いテキストまたは数値のサイズに合わせてピボットテーブルの列を自動的に調整するには、[更新時に列幅を自動調整する] チェック ボックスをオンにします。
    • 現在のピボットテーブルの列幅を維持するには、[更新時に列幅を自動調整する] チェック ボックスをオフにします。

列を行ラベル領域に、または行を列ラベル領域に移動する

列フィールドを行ラベル領域に、または行フィールドを列ラベル領域に移動して、ピボットテーブルのレイアウトや読みやすさを最適化することが必要な場合があります。 列を行に、または行を列に移動すると、フィールドの縦方向または横方向を入れ替えることになります。 この操作は、行または列の「ピボット」とも呼ばれます。

右クリック コマンドを使用する

次のいずれかの操作を実行します。

  • 行フィールドを右クリックし、[移動] <フィールド名>] をポイントして、[<フィールド名>列に移動] を選択します。
  • 列フィールドを右クリックし、[<フィールド名> を行に移動] をクリックします。

ドラッグ アンド ドロップを使う

  1. ピボットテーブルにポインターを置き、[ピボットテーブルの分析]>オプションを選択し、[表示] タブを選択してから、[クラシック ピボットテーブル レイアウト] を選択して、クラシック モードに切り替えます。

  2. 行フィールドまたは列フィールドを別の領域にドラッグします。 次の図は、列フィールドを行ラベル領域に移動する方法を示します。

    a. 列フィールドを選択する b. 列を行領域にドラッグします。 c. "地域" と同様、"スポーツ" も行フィールドになります。
    手順 1. 列フィールドを選択する 手順 2. 行領域にドラッグする 手順 3.

外側の行アイテムおよび列アイテムのセルを結合または結合解除する

行や列のアイテムのセルを結合してアイテムを横方向および縦方向に中央揃えにしたり、セルの結合を解除して外側の行や列のフィールドのアイテムをアイテム グループの上部で左揃えにしたりすることができます。

  1. ピボットテーブル内の任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。
  2. [ ピボットテーブルの分析 ] タブの [ ピボットテーブル ] グループで、[ オプション] を選択します。
    エラーと空白セルの表示のピボットテーブル オプション コマンド
  3. [ピボットテーブル オプション] ダイアログ ボックスで、[レイアウト] & [書式] タブを選択し、[レイアウト] で [セルをラベルで結合して中央揃えにする] チェック ボックスをオンまたはオフにします。

注

ピボットテーブルでは、[配置] タブの [セルの結合] チェック ボックスを使用できません。

空白セル、空白行、およびエラーの表示方法を変更する

ピボットテーブルのデータに空白セル、空白行、またはエラーが含まれている場合に、その表示方法を変更することができます。

エラー セルおよび空白セルの表示方法を変更する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ ピボットテーブルの分析 ] タブの [ ピボットテーブル ] グループで、[ オプション] を選択します。
    データのないアイテムのためのピボットテーブル オプション コマンド

  3. [ ピボットテーブル オプション] ダイアログ ボックスで、[ レイアウト] タブ & [書式 ] タブを選択し、[ 書式] で次の 1 つ以上を実行します。

    • エラーの表示を変更するには、[エラー値に表示する値] チェック ボックスをオンにします。 ボックスにエラー値の代わりに表示する値を入力します。 エラー値が入力されたセルを空白セルとして表示するには、ボックス内の文字を削除します。

    • 空白セルの表示を変更するには、[空白セルに表示する値] チェック ボックスをオンにして、空白セルに表示する値をテキスト ボックスに入力します。

      ヒント

      空白セルとして表示するには、ボックス内のすべての文字を削除します。 ゼロを表示するには、このチェック ボックスをオフにします。

行またはアイテムの後の空白行の表示と非表示を切り替える

行の場合は、次の操作を行います。

  • ピボットテーブルで、行フィールドを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

    ヒント

    アウトライン形式または表形式で行フィールドをダブルクリックして、手順 3 に進むこともできます。

  • [ ピボットテーブルの分析 ] タブの [アクティブなフィールド ] グループで、[ フィールドの設定] を選択します。
    空白行を挿入するためのフィールド設定コマンド

  • [フィールドの​​設定] ダイアログ ボックスの [レイアウトと書式] タブにある [レイアウト] で、[アイテムのラベルの後ろに空行を入れる] チェック ボックスをオンまたはオフにします。

アイテムの場合は、次の操作を行います。

  • ピボットテーブルで、対象のアイテムを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  • [デザイン] タブの [レイアウト] グループで [空白行] を選択し、[各アイテムのラベルの後に空行を挿入する] または [各アイテムのラベルの後に空行を削除する] チェック ボックスをオンにします。
    [ピボットテーブルのデザイン] タブの [空白行] メニュー

    注

    空白行に文字とセルの書式を適用することはできますが、データを入力することはできません。

データが含まれていないアイテムとラベルの表示方法を変更する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ ピボットテーブルの分析 ] タブの [ ピボットテーブル ] グループで、[ オプション] を選択します。
    表示設定用のピボットテーブル オプション コマンド

  3. [表示] タブの [表示] で、次のいずれか 1 つまたは複数の操作を行います。

    • データのないアイテムを行に表示するには、[データのないアイテムを行に表示する] チェック ボックスをオンにします。このチェック ボックスをオフにすると、値のない行アイテムが非表示になります。

      注

      この設定は、オンライン分析処理 (OLAP) データ ソースにのみ使用できます。

    • データのないアイテムを列に表示するには、[データのないアイテムを列に表示する] チェック ボックスをオンにします。このチェック ボックスをオフにすると、値のない列アイテムが非表示になります。

      注

      この設定は OLAP データ ソースにのみ使用できます。

    • 値の領域にフィールドがない場合にアイテムのラベルを表示するには、[値の領域にフィールドがない場合にアイテムのラベルを表示する] チェックボックスをオンにします。このチェック ボックスをオフにすると、値の領域にフィールドがない場合にアイテムのラベルが非表示になります。

書式設定を変更または削除する

ギャラリーでさまざまなピボットテーブルのスタイルを選択できます。 さらに、レポートの縞模様の設定も制御できます。 フィールドの表示形式を変更することにより、レポート全体で一貫した書式を簡単に適用できます。 また、行や列に縞模様 (暗い部分と明るい部分が交互になっている背景) を追加または削除することもできます。 縞模様を追加すると、データを読んだりスキャンしたりすることも簡単になります。

スタイルを適用してピボットテーブルの書式を設定する

ピボットテーブルの多数の定義済みスタイル (または、クイック スタイル) のいずれかを使用すると、ピボットテーブルの外観や書式をすばやく変更できます。

  1. ピボットテーブル内の任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ デザイン ] タブの [ ピボットテーブル スタイル ] グループで、次のいずれかの操作を行います。

    • 表示されているピボットテーブル スタイルを選択するか、ギャラリーをスクロールしてその他のスタイルを表示します。
    • 使用可能なスタイルをすべて表示するには、スクロール バーの下部にある [ クイック スタイル] ボタンを選択します。
      [ピボットテーブル スタイル] ギャラリーの [その他]
      独自のカスタム ピボットテーブル スタイルを作成する場合は、ギャラリーの下部にある [ 新しいピボットテーブル スタイル ] を選択して、[ 新しいピボットテーブル スタイル] ダイアログ ボックスを表示します。

縞模様を適用してピボットテーブルの書式を変更する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ デザイン ] タブの [ ピボットテーブル スタイルのオプション ] グループで、次のいずれかの操作を行います。

    • 各行を明るい色形式と暗い色形式で交互に表示するには、[ 縞模様の行] を選択します。
    • 各列を明るい色形式と暗い色形式で交互に表示するには、[ 縞模様の列] を選択します。
    • 行見出しに縞模様を設定するには、[ 行見出し] を選びます。
    • 列見出しに縞模様を設定するには、[ 列見出し] を選びます。
      行と列のバンディングのピボットテーブル スタイル オプション

ピボットテーブルからスタイルまたは縞模様の書式を削除する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。
  2. [ デザイン ] タブの [ピボットテーブル スタイル ] グループで、スクロール バーの下部にある [ クイック スタイル ] ボタンを選択して使用可能なスタイルをすべて表示し、ギャラリーの下部にある [クリア ] を選択します。
    ピボットテーブル スタイルをクリアするための [その他] ボタン

ピボット テーブルの条件付き書式データ

条件付き書式を使用すると、データを視覚的に検索して分析し、重要な問題を検出し、パターンと傾向を特定できます。 条件付き書式はデータに関する特定の疑問の解決に役立ちます。 ピボットテーブルで条件付き書式を使用する場合は、理解しておくべき重要な相違点があります。

  • フィルター処理、レベルの非表示、レベルの折りたたみと展開、またはフィールドの移動によってピボットテーブルのレイアウトを変更しても、基になるデータのフィールドが削除されない限り、条件付き書式は維持されます。

  • [値] 領域内のフィールドの条件付き書式の範囲は、データ階層に基づくことが可能で、1 つ以上の列に対する行、または 1 つ以上の行に対する列にある親 (階層内で次に高いレベル) の表示中のすべての子 (階層内で次に低いレベル) によって決まります。

    注

    データ階層では、親から子に条件付き書式は継承されず、子から親へも条件付き書式は継承されません。

  • [値] 領域内のフィールドの条件付き書式の範囲を指定する方法には、選択による方法、対応するフィールドによる方法、および値フィールドによる方法の 3 つがあります。

詳細については、「条件付き書式を適用する」を参照してください。

フィールドの表示形式を変更する

  1. ピボットテーブルで、対象のフィールドを選択します。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。
  2. [アクティブなフィールド] グループの [ピボットテーブルの分析] タブで、[フィールドの設定] を選択します。
    数値の書式設定のためのフィールド設定コマンド
    ラベルおよびレポート フィルターの場合は [フィールドの設定] ダイアログ ボックスが表示され、値の場合は [値フィールドの設定] ダイアログ ボックスが表示されます。
  3. ダイアログ ボックスの下部にある [ 表示形式 ] を選択します。
  4. [ セルの書式設定 ] ダイアログ ボックスの [分類] ボックスの一覧で、使用する表示形式を選びます。
  5. 目的のオプションを選択して、[ OK ] を 2 回選択します。
    値フィールドを右クリックして、[ 表示形式] を選択することもできます。

OLAP サーバーの書式を使用する

Microsoft SQL Server Analysis Services のオンライン分析処理 (OLAP) データベースに接続している場合、どの OLAP サーバーの書式を取得してデータ表示で使用するかを指定できます。

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ ピボットテーブルの分析 ] タブの [データ ] グループで、[ データ ソースの変更] を選択し、[ 接続プロパティ] を選択します。
    [データ] グループの [データ ソースの変更] コマンド

  3. [ 接続のプロパティ] ダイアログ ボックスの [使用法 ] タブの [ OLAP サーバーの書式] セクションで、次のいずれかの操作を行います。

    • 通貨、日付、時刻などの数値の書式を有効または無効にするには、[表示形式] チェック ボックスをオンまたはオフにします。
    • 太字、斜体、下線、取り消し線などのフォントのスタイルを有効または無効にするには、[スタイル] チェック ボックスをオンまたはオフにします。
    • 塗りつぶしの色を有効または無効にするには、[塗りつぶしの色] チェック ボックスをオンまたはオフにします。
    • テキストの色を有効または無効にするには、[テキストの色] チェック ボックスをオンまたはオフにします。

書式設定を保持または破棄する

  1. ピボットテーブルの任意の場所をクリックします。
    これにより、リボンに [ピボットテーブル ] タブ、[分析] タブと [デザイン ] タブが表示されます。

  2. [ ピボットテーブルの分析 ] タブの [ ピボットテーブル ] グループで、[ オプション] を選択します。
    書式設定を保持するためのピボットテーブル オプション コマンド

  3. [レイアウトと書式] タブの [書式] で、次のいずれかの操作を行います。

    • ピボットテーブルのレイアウトと書式を保存して、ピボットテーブルで操作を行うたびに使用されるようにするには、[更新時にセル書式を保持する] チェック ボックスをオンにします。
    • ピボットテーブルのレイアウトと書式を破棄して、ピボットテーブルで操作を行うたびに既定のレイアウトと書式が使用されるようにするには、[更新時にセル書式を保持する] チェック ボックスをオフにします。

    注

    このオプションはピボットグラフの書式設定にも影響しますが、近似曲線、データ ラベル、エラー バー、特定のデータ系列に対するその他の変更は保持されません。

補足説明

Excel 技術コミュニティの専門家にいつでも質問するか、コミュニティでサポートを受けることができます。