ワークシートのデータのアウトライン (グループ) を作成する

適用先
Excel for Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

グループ化して要約するデータのリストがある場合は、最大 8 つのレベルのアウトラインを作成できます。 アウトライン記号で大きい数値で表される各内部レベルには、アウトライン記号で小さい番号で表される前の外部レベルの詳細データが表示されます。 アウトラインを使うと、集計行や集計列の表示や各グループの詳細データの参照をすばやく行うことができます。 作成できるアウトラインは、行のアウトライン (下の例を参照)、列のアウトライン、行と列の両方のアウトラインです。

3 レベル アウトラインを持つデータ
1. レベルの行を表示するには、適切な 1 つの 2 つの 3 つのアウトライン記号を選択します。

  • レベル 1 には、すべての詳細行の合計売上が含まれます。
  • レベル 2 には、各地域の各月の合計売上高が含まれます。
  • レベル 3 には詳細行 (この場合、行 17 から 20) が含まれます。
2. アウトライン内のデータを展開または折りたたむには、アウトラインの プラス 記号と マイナス 記号をクリックするか、 Alt キー + SHIFT + = キーを押して展開し、 Alt キー + Shift + - キー を押して折りたたみます。

行のアウトラインを作成する

  1. アウトラインを作成するデータの各列の 1 行目にラベル (地域など) があり、各列に同様の事実が含まれ、アウトラインを作成する範囲に空白の行や列がないことを確認します。

  2. 必要に応じて、グループ化された詳細行に対応する集計行 (小計) を作成できます。 これらを作成するには、次のいずれかの操作を行います。

    • [小計] コマンドを使用して集計行を挿入する 
      [小計] を使うと、詳細行の各グループのすぐ上またはすぐ下に SUBTOTAL 関数が挿入され、アウトラインが自動的に作成されます。 SUBTOTAL 関数の使用方法の詳細については、「SUBTOTAL 関数」をご覧ください。
    • 独自の集計行を挿入する 
      詳細行の各グループのすぐ上またはすぐ下に数式を設定して、独自の集計行を挿入します。 たとえば、3 月と 4 月の売上データの行の下 (または上) で、SUM 関数を使ってこれらの月の売上の小計を出します。 後の表では、この例を示します。
  3. 既定では、集計する詳細の下に集計行が検索されますが、詳細行の上に作成することができます。 詳細の下にサマリー行を作成した場合は、次の手順 (手順 4) に進みます。 詳細行の上に集計行を作成した場合は、[ データ>アウトライン] に移動し、ダイアログ ボックス起動ツールを選択します。
    アウトライン グループでダイアログ ボックス起動ツールをクリックする
    [設定] ダイアログ ボックスが開きます。
    アウトライン用の [設定] ダイアログ ボックス
    [設定] ダイアログ ボックスで、[ 詳細の下のサマリー行] チェック ボックスをオフにし、[ OK] を選択します。

  4. データのアウトラインを作成します。 次のいずれかの操作を行います。
    アウトラインを自動作成する

    1. アウトラインを描くセル範囲内のセルを選択します。
    2. [データ>アウトライン]>グループ>グループの順に移動し、[アウトラインの自動] を選択します。
      [グループ] の下にある矢印をクリックして、[アウトラインの自動作成] をクリックする

    アウトラインを手動で作成する

    重要

    アウトライン レベルを手動でグループ化する場合は、行が正しくグループ化されないように、 すべてのデータを表示する ことをお勧めします。

    1. 外側のグループ (レベル 1) のアウトラインを作成するには、外側のグループに含まれるすべての行 (つまり、詳細行と、追加した場合はその集計行) を選択します。

      外部グループを作成する準備が整ったデータ選択
      1. 最初の行にはラベルが含まれており、選択されていません。
      2. これは外側のグループであるため、小計と詳細を含むすべての行を選択します。
      3. 総計を選択しない。
    2. データ>アウトライン>グループ>グループの順に移動します。 [グループ] ダイアログ ボックスで、[ 行]、[ OK] の順に選択します。

      ヒント

      セルのみではなく行全体を選択すると、Excel は自動的に行別にグループ化され、[グループ化] ダイアログ ボックスも開きません。

      [行] をクリックして、[OK] をクリックする
      画面のグループの上または左に、アウトライン記号が表示されます。

    3. 必要に応じて、入れ子になった下位グループ (指定したデータ セクションの詳細行) のアウトラインを作成します。

      内部グループを作成する必要がない場合は、以下の手順 f に進みます。

      入れ子になった下位グループそれぞれについて、集計行に隣接する各詳細行を選択します。

      階層のレベル 2 でグループ化するために選択されたデータ。
      1. 各内部レベルで複数のグループを作成できます。 ここでは、2 つのセクションが既にレベル 2 にグループ化されています。
      2. このセクションが選択され、グループ化する準備ができました。
      3. グループ化するデータの集計行を選択しないでください。
    4. データ>アウトライン>グループ>グループの順に移動します。
      [データ] タブの [グループ] をクリックする
      [グループ] ダイアログ ボックスで、[ 行]、[ OK] の順に選択します。 画面のグループの上または左に、アウトライン記号が表示されます。

      ヒント

      セルのみではなく行全体を選択すると、Excel は自動的に行別にグループ化され、[グループ化] ダイアログ ボックスも開きません。

    5. 下位の行の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

    6. 行のグループ化を解除する場合は、その行を選択して、[データ]>アウトライン>グループ化解除>グループ化解除の順に移動します。
      レベル全体を削除せずに、アウトラインのセクションのグループ化を解除することもできます。 Shift キーを押しながらグループのプラス ボックスまたはマイナス ボックスを選択し、[データ]>アウトライン>グループ化解除>グループ解除の順に移動します。

      重要

      詳細データが非表示の状態でアウトラインのグループ化を解除すると、詳細行が非表示のままになることがあります。 データを表示するには、まず、非表示の行に隣接して表示されている行番号をドラッグして選択します。 次に、[ ホーム>セル>書式] に移動し、[ 非表示] & [非表示] をポイントして、[ 非表示の行] を選択します。

列のアウトラインを作成する

  1. アウトラインを作成するデータの各行の最初の列に行見出しがあること、同じ行には同じ種類のデータが入力されていること、範囲内に空白行または空白列が含まれていないことを確認します。

  2. 詳細列の各グループのすぐ右または左に、数式を含む独自の集計列を挿入します。 次の手順 4 の一覧の表に例を示します。

    列単位でデータのアウトラインを作成するには、グループの各詳細列のセル範囲を参照する数式を集計列に設定します。

  3. 集計列が詳細列の左側にある場合は、[ データ>アウトライン] に移動し、ダイアログ ボックス起動ツールを選択します。
    アウトライン グループでダイアログ ボックス起動ツールをクリックする
    [設定] ダイアログ ボックスが開きます。
    アウトライン用の [設定] ダイアログ ボックス
    [設定] ダイアログ ボックスで、[詳細の右側にある概要列] チェック ボックスをオフにし、[OK] を選択します。

  4. データのアウトラインを作成するには、次のいずれかの操作を行います。
    アウトラインを自動作成する

    1. 範囲内のセルを選択します。
    2. [データ>アウトライン]>グループ>グループの順に移動し、[アウトラインの自動] を選択します。

    アウトラインを手動で作成する

    重要

    アウトライン レベルを手動でグループ化する場合、列のグループ化でのミスを防ぐために、すべてのデータを表示することをお勧めします。

    1. 外側のグループ (レベル 1) のアウトラインを作成するには、下位の集計列をすべて選択し、関連する詳細データを選択します。

      グループ化する列に配置されたデータ
      1. 列 A にはラベルが含まれます。
      2. 詳細列と小計列をすべて選択します。 列全体を選択しない場合は、[ グループ 化 (データ>アウトライン>グループ化] を選択すると、[グループ化] ダイアログ ボックスが開き、[ 行] または [列] を選択するように求められます。
      3. 総計列は選択しないでください。
    2. データ > アウトライン>グループ>グループの順に移動します。
      [データ] タブの [グループ] をクリックする
      アウトライン記号がグループの上に表示されます。

    3. 入れ子になった詳細列 (レベル 2 以上) の内側のグループのアウトラインを描くには、集計列を含む列に隣接する詳細列を選択します。

      列でグループ化されたデータ
      1. 各内部レベルで複数のグループを作成できます。 ここでは、2 つのセクションが既にレベル 2 にグループ化されています。
      2. これらの列が選択され、グループ化する準備ができました。 列全体を選択しない場合は、[ グループ 化 (データ>アウトライン>グループ化] を選択すると、[グループ化] ダイアログ ボックスが開き、[ 行] または [列] を選択するように求められます。
      3. グループ化するデータの集計列は選択しないでください。
    4. データ>アウトライン>グループの順に移動します。
      [データ] タブの [グループ] をクリックする
      画面のグループの上または左に、アウトライン記号が表示されます。

  5. 下位の列の選択とグループ化を続け、アウトラインに含めるすべてのレベルを作成します。

  6. 列のグループ化を解除する場合は、列を選択して、[データ]>アウトライン>グループ解除 に移動します。

[データ] タブで、[グループ解除] をクリックする

レベル全体を削除せずに、アウトラインのセクションのグループ化を解除することもできます。 Shift キーを押しながらグループの プラス ボックス または マイナス ボックス を選択し、[ データ>アウトライン>グループ解除] に移動します。

詳細データが非表示の状態でアウトラインのグループ化を解除すると、詳細列を非表示のままにすることができます。 データを表示するには、まず、非表示の列に隣接して表示されている列見出しをドラッグして選択します。 [ホーム>セル>書式] に移動し、[非表示] & [非表示] をポイントして、[非表示の列] を選択します。

アウトラインの詳細データの表示と非表示を切り替える

  1. アウトライン記号 1、2、3プラスマイナスが表示されない場合は、[ファイル>オプション]>[詳細設定] に移動し、[次のワークシートの表示オプション] セクションで、[アウトラインが適用されている場合にアウトライン記号を表示する] チェック ボックスチェック、[OK] の順に選択します。

  2. 次の操作のいずれか、または複数の操作を行います。

    • グループの詳細データを表示または非表示にする 
      グループ内の詳細データを表示するには、グループの プラス ボタンを選択するか、 Alt + Shift + = キーを押します。
    • グループの詳細データを非表示にするには、グループの マイナス ボタンを選択するか、 Alt + Shift + - キーを押します。
    • アウトライン全体の特定のレベルを表示または非表示にする 
      1 つ 2 つの 3 つのアウトライン記号で、目的のレベル番号を選択します。 クリックした記号よりも下位レベルの詳細データは非表示になります。
      たとえば、アウトラインに 4 つのレベルがある場合、 3 つ を選択することで、4 番目のレベルを非表示にし、残りのレベルを表示できます。
    • アウトラインの詳細データをすべて表示または非表示にする 
      すべての詳細データを表示するには、 1、2、3 のアウトライン記号の最も低いレベルを選択します。 たとえば、3 つのレベルがある場合は、 3 つ を選択します。
    • すべての詳細データを非表示にするには、 を選択します

アウトラインのスタイルを変更する

アウトラインが作成された行には、RowLevel_1 や RowLevel_2 などのスタイルが使われます。 アウトラインが作成された列には、ColLevel_1 や ColLevel_2 などのスタイルが使われます。 スタイルには、太字、斜体などの文字書式が使われ、他のデータから集計行と集計列が区別されます。 これらの各スタイルの定義を変更し、別のテキストの書式やセルの書式を使ってアウトラインの表示を独自に設定できます。 アウトラインへのスタイルの適用は、アウトラインの作成時または作成後に行うことができます。

次の操作のいずれか、または複数の操作を行います。

新しい集計行または集計列にスタイルを自動的に適用する 

  1. [データ>アウトライン] に移動し、ダイアログ ボックス起動ツールを選択します。
    アウトライン グループでダイアログ ボックス起動ツールをクリックする
    [設定] ダイアログ ボックスが開きます。
    アウトライン用の [設定] ダイアログ ボックス
  2. [既定のスタイルを使用する] チェック ボックスをオンにします。

既存の集計行または集計列にスタイルを適用する 

  1. スタイルを適用するセルを選択します。
  2. [データ>アウトライン] に移動し、ダイアログ ボックス起動ツールを選択します。
    アウトライン グループでダイアログ ボックス起動ツールをクリックする
    [設定] ダイアログ ボックスが開きます。
    アウトライン用の [設定] ダイアログ ボックス
  3. [自動スタイル] チェック ボックスをオンにして、[スタイルの適用] を選択します。
    [自動スタイル] が選択された [設定] ダイアログ ボックス

オートフォーマットを使って、アウトラインを作成したデータの書式を設定することもできます。

アウトラインの詳細データをコピーする

  1. 外形記号 1、2、3プラスマイナスが表示されない場合は、[ファイル>オプション]>[詳細設定] に移動し、[次のワークシートの表示オプション] セクションの下にある [アウトラインが適用されている場合にアウトライン記号を表示する] チェック ボックスチェックオンにします。
  2. アウトライン記号 1、2、3負符号、プラスを使用して、コピーしたくない詳細データを非表示にします。
    詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。
  3. 集計行の範囲を選択します。
  4. [ホーム]>編集>[& 検索] [選択] に移動し、[選択] を選択してから、[選択] を選択します。
    [検索] & [選択] をクリックし、[移動] をクリックします。
  5. [ 可視セルのみ] を選択します。
  6. [ OK] を選択し、データをコピーします。

アウトラインを非表示または削除する

アウトラインを非表示または削除しても、データは削除されません。

アウトラインを非表示にする

  • [詳細設定] > [ファイル>オプション] に移動し、[このワークシートの表示オプション] セクションの下にある [アウトラインが適用されている場合はアウトライン記号を表示する] チェックチェックオフにします。

アウトラインを削除する

  1. シートをクリックします。

  2. [データ>アウトライン]>グループ解除の順に移動し、[アウトラインのクリア] を選択します。
    [グループ解除] ボタンの [アウトラインのクリア] をクリックする

    重要

    詳細データが非表示の状態でアウトラインを削除すると、詳細行または詳細列は非表示のままになります。 データを表示するには、まず、非表示の行または列に隣接して表示されている行番号または列見出しをドラッグして選択します。 [ホーム>セル>書式] に移動し、[非表示] & [非表示] をポイントして、[行を再表示] または [非表示の列] を選択します。

グラフを使ったサマリー レポートを作成する

合計やその合計のグラフのみを表示する、データの集計レポートを作成するとします。 この場合、一般に次の操作を行います。

  1. サマリー レポートを作成する

    1. データのアウトラインを作成します。
      詳細については、「行のアウトラインを作成する」または「列のアウトラインを作成する」をご覧ください。
    2. 次の行アウトラインの例に示すように、アウトライン記号 1、2、3プラスマイナス を選択して合計のみを表示することで、詳細を非表示にします。
      合計行だけが表示されたアウトライン表示のリスト
    3. 詳細については、「アウトラインの詳細データの表示と非表示を切り替える」を参照してください。
  2. サマリー レポートをグラフ化する

    1. グラフ化する集計データを選択します。
      たとえば、総計ではなく吉田と西脇の合計のみをグラフ化するには、上の例のようにセル A1 から C19 を選択します。
    2. [挿入]>[グラフ]>[おすすめグラフ] を選択し、[すべてのグラフ] タブを選択してグラフの種類を選択します。
      [グラフの挿入] ダイアログ
      たとえば、[集合縦棒] オプションを選択した場合、グラフは次のようになります。
      小計データから作成したグラフ
      アウトライン表示されたデータ リストの詳細データの表示と非表示を切り替えると、対応するグラフに表示されるデータも切り替わります。

補足説明

Excel 技術コミュニティの専門家にいつでも質問するか、コミュニティでサポートを受けることができます。

関連項目

ピボットテーブルでデータをグループ化またはグループ化解除する