ODC ファイルを使用して外部データを共有する (Power Query)

適用先
Excel for Microsoft 365 Excel 2024 Excel 2021

Office データ接続 (ODC) ファイルを使用すると、Excel ユーザー間で外部データ接続を共有できます。 ODC ファイルは移植可能で簡単に更新できるように設計されています。 Power Query によって整形されたデータと外部データ ソースを共有するには、次のアプローチを使用します。

注

ODC ファイルは引き続きサポートされていますが、多くの組織では SharePoint、OneDrive、Power BI データフロー、またはその他の一元化されたデータ ソースを使用して Power Query ソリューションを共有しています。

この例では、データ ブックからインポートされたデータを含むブックを共有します。 ただし、このプロセスは、Excel がインポートして接続できるほとんどすべての外部データ ソースに適用されます。 唯一の例外は、インポート元の Excel テーブルまたは名前付き範囲の接続情報を ODC ファイルに保存できないことです ( Data>From Table/Range を使用)。

重要

認証またはプライバシーに関する問題が発生した場合は、「データ ソースの設定とアクセス許可を管理する (Power Query)」および「プライバシー レベルを設定する (Power Query)」を参照してください。

手順 1: データをインポートし、接続とクエリの情報を ODC ファイルに保存する

データを簡単に共有できるようにするには、1 人のユーザーが次の手順を実行します。

  1. [データ]>データの取得>ファイルから>Excel ブックから] を選択します。
  2. [ データのインポート ] ダイアログ ボックスで、データを含むブックを見つけて選択し、[ インポート] を選択します。
  3. [ ナビゲーター ] ダイアログ ボックスで、テーブルを選択してから、[ データ変換] を選択します。
  4. Power Query エディターで、目的のデータを整形し、[ホーム] >[閉じる] & [読み込み] を選択します。
  5. クエリ データを含む Excel ワークシートで、テーブル内のセルを選択し、[ データ]、[ すべて更新] の横にある矢印、[ 接続プロパティ]、[ 定義 ] タブの順に選択してから、ダイアログ ボックスの下部にある [接続ファイルのエクスポート] を選択します。
  6. [ ファイルの保存] ダイアログ ボックスで、ファイル名を入力し、[ 保存]、[ OK] の順に選択します。
  7. ネットワーク フォルダー、SharePoint ライブラリ、OneDrive フォルダーなど、他のユーザーがアクセスできる信頼できる場所にファイルを保存してください。 信頼できるデータ ソースの詳細については、「信頼済みドキュメント」、「Microsoft Office セキュリティ センターのプライバシー オプションを表示する」および「信頼できる場所を追加、削除、または変更する」を参照してください。
  8. ブックを保存します。

結果

ODC ファイルには、外部データ ソースに関するすべての接続情報と、Power Query 操作の手順と数式が含まれています。 必要に応じて、メモ帳で ODC ファイルを開いて、使用されている XML 形式を確認します。

手順 2: 保存した ODC ファイルを開いて使用する

共有データにアクセスするには、別のユーザーが次の手順を実行します:

  1. ODC ファイルを見つけて開きます。

    Excel は ODC ファイルを新しい Excel ブックに開きます。

  2. データ ソースを信頼することに関するメッセージが表示された場合は、[ 有効にする] を選択します。

  3. [ データのインポート ] ダイアログ ボックスで、データのインポート方法を決定し、[ OK] を選択します。 このダイアログ ボックスの使用方法の詳細については、疑問符 (?) を選択してください。

  4. すべてが正しく機能していることを確認するには、ブックのデータ ソースを更新してから、Ctrl + Alt + F5 キーを押してこのブックのすべてのデータを更新します。

  5. ブックを保存します。

結果

もう 1 人は、Power Query によって整形されたデータを持つ外部データ ソースを共有できるようになりました。

関連項目

Power Query for Excel のヘルプ

Excel で外部データ接続を更新する

Excel のデータについて