現象
ソフトウェア パッケージのインストール時に発生する問題のトラブルシューティングを支援するため、Windows インストーラーではログが使用されます。ログを有効にすると、失敗したインストールを再試行できます。Windows インストーラーは、進捗状況を追跡し、データをログ ファイルに記録します。サポート担当者は、これらのログを参照して、問題を特定するために役立てることができます。
原因
Microsoft インストーラーの問題の原因としては、データの破損、インストールした製品の破損、その他多くの問題が考えられます。
解決方法
これらの問題のトラブルシューティングを行うには、2 つの手順のログ記録を有効にして、更新プログラムのインストールを再試行する必要があります。ログ記録を有効にすると、Windows インストーラーによって生成される実際のエラー コードが取得されます。エラー コードが取得されるとすぐに、実際の問題とその問題の解決策を特定することができます。これらのエラーでは、マイクロソフト サポートに連絡を取って問題を解決する必要があります。ただし、マイクロソフト サポートに連絡を取る前に、いくつかの操作を実行する必要があります。
Windows インストーラーのログを有効にして収集するには、お使いのオペレーティング システムの手順に従います。
手順 1:Microsoft インストーラーのログ記録および Windows Update の詳細ログ記録を有効にする
ログ記録を有効にするには、「Fix it で解決する」セクションに進んでください。自分でログ記録を有効にする場合は、「自分で解決する」セクションに進んでください。
Fix it で解決する
ログ記録を有効にするには、[この問題を解決する] リンクをクリックし、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、ウィザードの手順に従います。
注: このウィザードは英語版のみである場合がありますが、自動的な解決は英語版以外の Windows でも機能します。
注: 操作しているコンピューターに問題がない場合、自動的な解決をフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行できます。
自分で解決する
Windows 2000、Windows XP、または Windows Server 2003 を搭載しているコンピューターの場合
-
[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「Notepad」と入力し、[OK] をクリックします。
-
メモ帳に次のコマンドを入力します。
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"Logging"="voicewarmupx"
"Debug"=dword:00000007
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
"Flags"=dword:00000016
"Level"=dword:00000004 -
[ファイル] メニューの [名前を付けて保存] をクリックします。
-
[保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
-
[ファイル名] ボックスに「LoggingOn.reg」と入力し、[ファイルの種類] ボックスの一覧の [すべてのファイル] をクリックし、[保存] をクリックします。
-
デスクトップ上で LoggingOn.reg ファイルをダブルクリックし、レジストリ キーを Windows レジストリに追加します。
-
メッセージ ボックスの [OK] をクリックします。
-
更新プログラムのインストールを再試行して、Windows インストーラーの .log ファイル内にある追加のエラー情報を取得します。
Windows Vista および Windows Server 2008 を搭載しているコンピューターの場合
-
[スタート] ボタン をクリックし、[検索の開始] ボックスに「Notepad」と入力します。
-
プログラム一覧で、[Notepad] をクリックします。
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メモ帳に次のコマンドを入力します。
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"Logging"="voicewarmupx"
"Debug"=dword:00000007
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
"Flags"=dword:00000016
"Level"=dword:00000004 -
[ファイル] メニューの [名前を付けて保存] をクリックします。
-
[保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
-
[ファイル名] ボックスに「LoggingOn.reg」と入力し、[ファイルの種類] ボックスの一覧の [すべてのファイル] をクリックし、[保存] をクリックします。
-
デスクトップ上で LoggingOn.reg ファイルをダブルクリックし、レジストリ値を Windows レジストリに追加します。
管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。 -
[はい] をクリックし、[OK] をクリックします。
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更新プログラムのインストールを再試行して、Windows インストーラーの .log ファイル内にある追加のエラー情報を取得します。
手順 2: 更新プログラムのインストールを再試行してログ ファイルを作成する
更新プログラムのインストールを再試行するには、次の Microsoft Update Web サイトを参照してください。
http://www.update.microsoft.com/注: これらのログを収集するのに数分かかることがあるため、更新手順が正常に動作していないように思えることがあります。手順が完了するのに必要な時間を考慮してください。
手順 3: Microsoft インストーラーのログ記録および Windows Update の詳細ログ記録を無効にする
重要 Windows Update または Microsoft Update が完了したらすぐに Windows インストーラーのログ記録を無効にします。ログ記録を有効にすると、更新プログラムをインストールするたびに長い時間がかかったり、コンピューターの速度が低下したり、多量のディスク領域を必要とするサイズの大きいログ ファイルを作成したりすることがあります。
自動でログ記録を無効にするには、「Fix it で解決する」セクションに進んでください。自分でログ記録を無効にする場合は、「自分で解決する」セクションに進んでください。
Fix it で解決する
ログ記録を無効にするには、[この問題を解決する] リンクをクリックし、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、ウィザードの手順に従います。
注: このウィザードは英語版のみである場合がありますが、自動的な解決は英語版以外の Windows でも機能します。
注: 操作しているコンピューターに問題がない場合、自動的な解決をフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行できます。
自分で解決する
Windows インストーラーのログ記録を無効にするには、お使いのオペレーティング システムの手順に従います。
Windows 2000、Windows XP、または Windows Server 2003 を搭載しているコンピューターの場合
-
[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「Notepad」と入力し、[OK] をクリックします。
-
メモ帳に次のコマンドを入力します。
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"Logging"=-
"Debug"=-
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace] -
[ファイル] メニューの [名前を付けて保存] をクリックします。
-
[保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
-
[ファイル名] ボックスに「LoggingOff.reg」と入力し、[ファイルの種類] ボックスの一覧の [すべてのファイル] をクリックし、[保存] をクリックします。
-
デスクトップ上で LoggingOff.reg ファイルをダブルクリックし、レジストリ値を Windows レジストリから削除します。
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メッセージ ボックスの [OK] をクリックします。
-
LoggingOn.reg および LoggingOff.reg ファイルをデスクトップから削除する
マイクロソフト サポートに連絡し、サポート エージェントに話す際にはこのマイクロソフト サポート技術情報を参照します。お問い合わせ方法については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ln=ja&ws=support#tab0
Windows Vista および Windows Server 2008 を搭載しているコンピューターの場合
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[スタート] ボタン をクリックし、[検索の開始] ボックスに「Notepad」と入力します。
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プログラム一覧で、[Notepad] をクリックします。
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メモ帳に次のコマンドを入力します。
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"Logging"=-
"Debug"=-
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace] -
メモ帳で、[ファイル] メニューの [名前を付けて保存] をクリックします。
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[保存する場所] ボックスの一覧の [デスクトップ] をクリックします。
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[ファイル名] ボックスに「LoggingOff.reg」と入力し、[ファイルの種類] ボックスの一覧の [すべてのファイル] をクリックし、[保存] をクリックします。
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デスクトップ上で LoggingOff.reg ファイルをダブルクリックし、レジストリ値を Windows レジストリから削除します。
管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。 -
[はい] をクリックし、[OK] をクリックします。
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LoggingOn.reg および LoggingOff.reg ファイルをデスクトップから削除します。
マイクロソフト サポートに連絡し、サポート エージェントに話す際にはこのマイクロソフト サポート技術情報を参照します。お問い合わせ方法については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ln=ja&ws=support#tab0
詳細
多くの場合、Windows インストーラーのログには、msi で始まり、.log の拡張子で終わる文字のグループが含まれています。たとえば、Windows インストーラーのログには以下と同様のファイル名があります。
msib3a6g.log Windows 2000、Windows XP、または Windows Server 2003 を搭載しているコンピューターでは、インストーラーのログは次のディレクトリにあります。
C:\Documents and Settings\ {UserName} \Local Settings\Temp\ このディレクトリを開くには、[実行] をクリックし、「%temp%」と入力して、[OK] をクリックします。
注: この情報は、Windows が既定のドライブ C にインストールされていることを前提としています。そうでない場合は、インストール ドライブに合わせてフォルダー パスのドライブ文字を変更します。
Windows Vista または Windows Server 2008 を搭載しているコンピューターでは、インストーラーのログは以下のディレクトリにあります。
C:\Users\{UserName\AppData\Local\Tempこのディレクトリを開くには、[スタート] ボタン をクリックし、[検索の開始] ボックスに「%temp%」と入力し、Enter キーを押します。
注: この情報は、Windows が既定のドライブ C にインストールされていることを前提としています。そうでない場合は、インストール ドライブに合わせてフォルダー パスのドライブ文字を変更します。
関連情報
Windows インストーラーのログの記録を有効にする方法の詳細については、以下のサポート技術情報番号をクリックしてください。
314852Windows XP で Windows インストーラーのログを有効にする方法