[HOWTO] Microsoft Word 2000 文書のメタデータを最小限にする方法

この記事は、以前は次の ID で公開されていました: JP237361
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
概要
この資料は、Word 文書内のメタデータの量を最小限に抑えるためのさまざまな方法について説明します。

Word 2000 での文書の作成、表示、または保存を行う場合、その文書を電子的に配布したときに第三者に見られては困る内容が文書に含まれる可能性があります。この情報は "メタデータ" と呼ばれます。メタデータは、Office 文書の編集、表示、ファイリング、および検索を強化するためのさまざまな目的で使用されます。

ある種のメタデータは、Microsoft Word のユーザー インターフェイスを経由して簡単にアクセスできます。その他のメタデータは、低レベルのバイナリ ファイル エディタで文書を開くなど、特殊な方法を使用することによってのみアクセスできます。以下に、文書に格納されるメタデータの例をいくつか示します。
  • 名前
  • 頭文字
  • 会社名と組織名
  • コンピュータ名
  • 文書を保存したネットワーク サーバーまたはハード ディスクの名前
  • その他のプロパティと概要情報
  • 埋め込み OLE オブジェクトの非表示部分
  • 以前の文書作成者の名前
  • 文書の変更履歴
  • 文書のバージョン
  • テンプレートの情報
  • 隠し文字
  • コメント
詳細
Word 文書内でメタデータが作成される方法は、それぞれ異なります。そのため、これらのメタデータを一括して文書から取り除く方法はありません。ここでは、メタデータが Word 文書内に保存される領域について説明します。

以下にご紹介しますサンプル コードは、弊社にてその動作を保証するものではございません。弊社は、この情報をプログラミング言語の使用方法の一例として提供するだけであり、市場性および特定目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。この資料は、例示されているプログラミング言語やプロシージャの作成およびデバッグに使用するツールについて理解されている方を対象としています。Microsoft Support Professional は、特定のプロシージャの機能についての問い合わせにはお答えできますが、お客様固有の目的に合わせた機能の追加、プロシージャの作成などの内容変更は行っておりません。プログラミングに習熟されていない場合、マイクロソフト認定パートナー、あるいはマイクロソフトの有償サポート窓口までお問い合わせください。マイクロソフト認定パートナーの詳細については、次のマイクロソフト Web サイトを参照してください。使用可能なサポート オプションおよびマイクロソフトの問い合わせ先の詳細については、次のマイクロソフト Web サイトを参照してください。
この資料中のサンプル コードの使用方法を参照するには、以下の「サポート技術情報」をクリックしてください。
212536 OFF2000: How to Run Sample Code from Knowledge Base Articles
先頭に戻る

文書からユーザー名を手動で削除する方法

現在のユーザー名を参照または変更するには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[ユーザー情報] タブをクリックします。

    次のボックスが表示されます。
    名前
    頭文字
    住所
  2. これらの情報が文書に表示されないようにするには、自分を特定されない文字列かスペースを該当するボックスに入力し、[OK] をクリックして変更内容を確定します。
注意 : 新規作成する文書にはすべてこの情報が含まれます。Office をインストールしたときに入力したデフォルト値ではありません。ただし、既存の文書には既にこの情報が含まれている可能性があります。

先頭に戻る

個人の概要情報を手動で削除する方法

Word で文書を作成または保存すると、概要情報が文書内に保存される可能性があります。この情報にアクセスするために使用できる方法は複数あります。

  • 文書を開き、[ファイル] メニューの [プロパティ] をクリックします。[ファイルの概要]、[詳細情報]、[ファイルの構成]、および [ユーザー設定] タブにはすべて、名前、管理者の名前、および会社名など、さまざまなプロパティが含まれている可能性があります。
  • Windows エクスプローラで文書を右クリックし、ショートカット メニューの [プロパティ] をクリックします。上述と同様に、[プロパティ] ダイアログ ボックス内のタブに情報が含まれている可能性があります。
  • Visual Basic for Applications (VBA) マクロやその他のプログラム コードを使用して、[プロパティ] ダイアログ ボックスに表示されるプロパティを読み取ることが可能です。
既存の文書またはテンプレートから概要情報を削除するには、以下の手順を実行します。
  1. 文書またはテンプレートを開きます。
  2. [ファイル] メニューの [プロパティ] をクリックします。
  3. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のフィールドの内容をすべて削除します。
  4. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  5. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [保存] をクリックします。最後に [ファイル] メニューの [閉じる] をクリックします。
上の手順が完了した文書には、概要プロパティは含まれません。

先頭に戻る

ネットワークに接続したときの個人の概要情報を手動で削除する方法

ネットワークにログオンしている場合、文書を保存すると、[ファイルの概要] タブの [作成者] ボックス、および [詳細情報] タブの [更新者] フィールドに、ネットワーク ユーザー名が表示されることがあります。その他の個人情報をコンピュータからすべて削除しても、この処理は行われる可能性があります。

ネットワークを利用しているときに、文書から概要情報を削除するには、次の手順を実行します。
  1. 文書がネットワーク サーバーに保管されている場合は、その文書をローカルのハード ディスクにコピーします。
  2. コンピュータを再起動します。ただし、ネットワークにはログオンしないようにします。ネットワークのログオン ダイアログ ボックスが表示されたら、[キャンセル] をクリックするか Esc キーを押します。

    : Esc キーを押すと Windows を起動できない場合 (たとえば、Windows NT を実行している場合) は、この手順を継続することはできません。
  3. 文書を開きます。
  4. [ファイル] メニューの [プロパティ] をクリックします。
  5. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のフィールドの内容をすべて削除します。
  6. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  7. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [保存] をクリックします。最後に [ファイル] メニューの [閉じる] をクリックします。
ネットワークにログオンしている状態でファイルを開かないでください。ファイルを開くと、ネットワーク ユーザー名がファイルに書き込まれる可能性があります。ただし、エクスプローラを使用して、ファイルをネットワークまたはフロッピー ディスクにコピーすることはできます。

先頭に戻る

文書のコメントを削除する方法

Microsoft Word には、文書にコメントを付加する機能が用意されています。通常、コメントには作成者の名前が入力され、書き込んだユーザー名がわかるようになっています。

コメントは通常、強調表示されたテキスト部分として表示されます。コメント内を右クリックして、ショートカット メニューの [コメントの削除] をクリックすることにより、コメントを削除できます。

この後、上述の別項で示す方法で、[オプション] の [ユーザー設定] からユーザー情報を削除します。以後、新しく作成したコメントには名前が入りません。

先頭に戻る

文書からヘッダーとフッターを手動で削除する方法

文書のヘッダーとフッターには、ユーザー名などの識別情報が含まれていることがあります。ヘッダーやフッターから情報を削除するには、次の手順を実行します。
  1. [表示] メニューの [ヘッダーとフッター] をクリックします。
  2. 文書の各ページの上部と下部にヘッダーとフッターが表示されます。必要に応じて内容を変更します。
  3. 以上の手順が完了した後、[ヘッダーとフッター] ツール バーの [閉じる] をクリックします。
先頭に戻る

変更履歴を手動で削除する方法

文書には変更履歴を含めることができます。これを使用して、特定の変更を加えたユーザーを判別することができます。変更履歴を反映するか元に戻すと、変更済みのテキストが文書に保存され、変更履歴は削除されます。

変更履歴を反映したり元に戻したりするには、次の手順を実行します。
  1. [ツール] メニューの [変更履歴の作成] をポイントして、[変更個所の確認] をクリックします。
  2. [変更箇所の確認] ダイアログ ボックスで、2 つの [検索] ボタンを使って特定の変更個所を探し、個別に [反映する] または [元に戻す] をクリックするか、[すべて反映する] または [すべて元に戻す] をクリックします。
  3. 完了後、[閉じる] をクリックします。
先頭に戻る

高速保存をオフにする方法

高速保存機能は、文書に加えられた変更部分のみを保存することにより、文書の保存処理を高速化します。

高速保存機能の仕様上、文書を保存した後でも、削除したテキストが文書内に残る可能性があります。削除したテキストが文書内に残ることを問題視する場合は、次の手順を実行してください。

  1. [ツール] メニューの [オプション] をクリックします。
  2. [保存] タブを選択します。
  3. [高速保存] チェック ボックスをオフにし、[OK] をクリックします。
高速保存機能の関連情報については、「サポート技術情報」にある次の資料を参照してください。
211209 WD2000: Opening Word Document in Text Editor Displays Deleted Text
197978 [WD2000] 高速保存に関する Q&A
先頭に戻る

隠し文字として書式設定されたテキストを検索および削除する方法

Word 文書は、テキストを隠し文字として書式設定することが可能です。配布したくない情報が隠し文字に含まれている可能性があるため、必要に応じて隠し文字を表示し、削除してください。隠し文字として書式設定されているテキストをすべて文書から削除するには、次の手順を実行します。

  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [隠し文字] チェック ボックスをオンにして、[OK] をクリックします。
  3. [編集] メニューの [置換] をクリックします。
  4. [オプション] をクリックして、ダイアログ ボックスを展開します。
  5. [検索する文字列] の横にあるボックスをクリックします。
  6. [書式] をクリックして、[フォント] をクリックします。[隠し文字] チェック ボックスを オン にして、[OK] をクリックします。
  7. [すべて置換] をクリックします。
すべての隠し文字が文書から削除されます。隠し文字の表示と非表示を切り替えるには、次の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [隠し文字] チェック ボックスを オフ にして、[OK] をクリックします。
先頭に戻る

文書からハイパーリンクを削除する方法

文書には、他の文書またはイントラネットやインターネットの Web ページへのハイパーリンクが含まれていることがあります。ハイパーリンクは通常、青い下線付きのテキスト文字列として表示されます。

ハイパーリンクを右クリックし、ショートカット メニューの [ハイパーリンク] をポイントして、[ハイパーリンクの削除] をクリックすることにより、文書から単一のハイパーリンクを手動で削除することができます。

VBA マクロを使用することにより、すべてのハイパーリンクを文書から削除することができます。次のサンプル VBA マクロを使用すると、文書内のすべてのハイパーリンクを削除することができます。

注意 : 以下のサンプル マクロでは、リンクのみが削除されます。ハイパーリンクのテキストは文書に残ります。

Sub RemoveHyperlinks()     Dim oDoc As Document     Dim oStory As Range     Dim oHlink As Hyperlink     For Each oStory In ActiveDocument.StoryRanges         For Each oHlink In oStory.Hyperlinks             oHlink.Delete         Next     NextEnd Sub
ハイパーリンクとハイパーリンクのテキストの両方を文書からすべて削除するには、上で示したコードの代わりに、以下のサンプル マクロを使用することができます。
Sub RemoveAllHyperlinks()Dim oDoc As DocumentDim oStory As RangeDim oHlink As Hyperlink     For Each oStory In ActiveDocument.StoryRanges         For Each oHlink In oStory.Hyperlinks             oHlink.Range.Delete         Next     NextEnd Sub
この資料中のサンプル コードの使用方法を参照するには、以下の「サポート技術情報」をクリックしてください。
212536 OFF2000: How to Run Sample Code from Knowledge Base Articles
先頭に戻る

文書からスタイルを削除する方法

文書には、メタデータの入ったスタイルが含まれることがあります。以下の手順を実行することにより、これらのスタイルの削除、または名前の変更を行えます。
  1. スタイルを含む文書を開きます。
  2. [書式] メニューの [スタイル] をクリックします。
  3. 削除または名前変更を行うスタイルをクリックします。[削除] をクリックしてそのスタイルを削除するか、[変更] をクリックして名前を変更します。
先頭に戻る

文書から旧版のファイルを削除する方法

Word には、1 つのファイル内に同じ文書の複数の版を保存できるようにするための、ファイル バージョン管理機能が含まれています。文書を他のユーザーと共有する前に、その文書の旧版を削除しておくことをお勧めします。

文書内の 1 つ以上の版を削除するには、次の手順を実行します。
  1. [ファイル] メニューの [版の管理] をクリックします。
  2. 削除する文書の版をクリックします。Ctrl キーを押しながら版をクリックすることにより、複数の版を選択することができます。
  3. [削除] をクリックします。
  4. 旧版文書の削除が完了した後、[ファイル] メニューの [保存] をクリックします。
先頭に戻る

フィールド コードからリンクを削除する方法

Word 文書からリンクされている画像やその他のオブジェクトには、リンク先の画像やオブジェクトのパスなどのリンク情報が含まれている可能性があります。フィールド コードを編集することにより、文書からリンク情報を削除することができます。

フィールド コードを表示するには、次の手順を実行します。

  1. [ツール] メニューの [オプション] をクリックし、[表示] タブをクリックします。
  2. [フィールド コード] チェック ボックスを オン にし、[OK] をクリックします。
フィールド コードを表示できるようにした後、識別情報が含まれているかどうかを確認することができます。

リンクされている画像やその他のオブジェクトからリンク情報を削除するには、次の手順を実行します。
  1. リンクされている画像またはオブジェクトをクリックします。または、フィールド コードが表示されている場合は、画像やオブジェクトのフィールド コードをクリックします。
  2. Ctrl + Shift + F9 キーを押します。
これにより、画像またはオブジェクトのリンクは解除されます。画像やオブジェクトのリンクを解除すると、編集できなくなる場合があることに注意してください。

先頭に戻る

テンプレートの名前と場所を削除する方法

Word で作成される文書は、すべてテンプレートに基づいています。デフォルトでは、Templates フォルダにある Normal.dot テンプレート ファイルが使用されます。しかし、他の場所にある別のテンプレートに基づく文書を作成することもできます。このテンプレートのパスと名前は、文書のプロパティ内に保管されます。

テンプレートの名前と場所を表示するには、[ファイル] メニューの [プロパティ] をクリックし、[ファイルの概要] タブをクリックします。

テンプレートを文書と一緒に送信しない場合であっても、文書にはテンプレートの名前と場所が保持されます。テンプレートの名前と場所を、相手に特定されない値に変更するには、次の手順を実行します。
  1. [ツール] メニューの [テンプレートとアドイン] をクリックします。
  2. [添付] をクリックします。
  3. テンプレートの名前や場所が、公開可能なもの、または固有ではないものを選択します。たとえば、Microsoft Word がインストールされているすべてのコンピュータには Normal.dot が入っているため、Normal.dot を選択するのも 1 つの方法です。
  4. [開く] をクリックします。次に [OK] をクリックします。
注意: テンプレートには、マクロ、定型句のエントリ、ユーザー定義スタイル、およびユーザー定義ツール バーが含まれていることがあります。テンプレートを変更すると、これらの項目を文書から利用できなくなることがあります。

先頭に戻る

回覧先情報を削除する方法

回覧先を使用して、文書を電子メールを通じて送信すると、ルーティング情報が文書に添付される可能性があります。この情報を文書から削除するには、回覧先情報が保持されない形式で文書を保存する必要があります。

Microsoft Word 文書をリッチ テキスト形式 (RTF) または HTML 形式で保存します。文書を閉じてから、保存した新しいファイルを再度開きます。これによって回覧先情報が削除されるため、ここで文書を Microsoft Word 形式に保存することができます。

次の手順を使用することもできます。
  1. この資料の上述の手順に従って、[高速保存] を オフ にします。
  2. [ファイル] メニューの [送信] をポイントして、[ほかの回覧先] をクリックします。
  3. [クリア] をクリックして回覧先を削除し、[OK] をクリックします。
  4. [ファイル] メニューの [上書き保存] をクリックします。
これにより、回覧先情報が何も含まれない状態で文書が保存されます。

先頭に戻る

以前の作成者の名前を削除する方法

Word では、ある文書で作業を行ったユーザーのうち、最新の 10 人までの名前が保管されています。これは自動で処理される機能であり、オフ にできません。

その代わり、この情報を保持できない形式で文書を保存することにより、最新の 10 人までの作成者の名前を文書から削除することができます。たとえば、文書をリッチ テキスト形式 (RTF) か HTML 形式で保存すると、作成者の情報は失われます。その後、保存した RTF か HTML の文書を再度開き、それを Microsoft Word 形式で保存し直すことができます。

先頭に戻る

Visual Basic のコードから自分の名前を削除する方法

Word で Visual Basic のマクロを記録する場合、記録されたマクロは、次のようなヘッダーで始まります。

   ' <マクロ名> Macro   ' 記録日 1999/3/11 記録者 <ユーザー名>
記録したすべてのマクロから自分の名前を削除するには、次の手順を実行します。
  1. マクロが含まれている文書を開きます。
  2. [ツール] メニューの [マクロ] をポイントし、[Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. プロジェクト ウィンドウで、対象となるマクロが含まれているモジュールをダブルクリックします。
  4. 記録されているマクロ コードから自分の名前を削除します。
名前の削除が完了した後、Alt + Q キーを押して、アプリケーションに戻ります。その後、[ファイル] メニューの [保存] をクリックします。

先頭に戻る

他のファイルに対する Visual Basic の参照設定を削除する方法

Visual Basic Editor では、別のファイルへの参照を作成することが可能です。他のファイルへの参照が含まれている文書を開くと、参照先ファイルの名前が表示されます。

これらの参照を削除するには、以下の手順を実行します。
  1. 参照が含まれる文書を開きます。
  2. [ツール] メニューの [マクロ] をポイントして [Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. [ツール] メニューの [参照設定] をクリックします。
  4. 参照されているファイルの横にあるチェック ボックスを オフ にします。作業の完了後、[OK] をクリックします。
  5. Alt + Q キーを押します。
  6. [ファイル] メニューの [上書き保存] をクリックします。
注意 : 他のファイルへの参照を削除すると、文書内のマクロが正常に動作するための機能が損なわれる可能性があります。

先頭に戻る

文書内の埋め込みオブジェクトにメタデータが含まれることがある

文書内にオブジェクトを埋め込んだ場合、文書にどのような操作を行っても、そのオブジェクト内の独自のプロパティが保持されます。たとえば、Microsoft Excel ブックを Word 文書内に埋め込んだ場合、文書とブックはそれぞれ独自のプロパティを持ちます。

オブジェクトをアクティブにし、上述の方法に従ってメタデータを削除して、コンテナの文書 (上述の例では Word 文書) を再度アクティブにした後で文書を保存することにより、埋め込みオブジェクトからメタデータを削除することができます。

注意 : 文書の埋め込みオブジェクトをアクティブにする場合、埋め込みオブジェクトの一部のみが文書内に表示され、その他の情報は表示されないままオブジェクトに含まれている可能性があります。埋め込みオブジェクトの実際の内容ではなく、表示されている部分のみが文書に含まれるようにするには、オブジェクトを切り取った後、[編集] メニューの [形式を選択して貼り付け] コマンドを使用して、オブジェクトを図 (拡張メタファイル) 形式で文書に貼り付けます。これを行った後、埋め込みオブジェクトの編集はできなくなりますが、メタデータは完全に含まれなくなります。

先頭に戻る

文書変数にメタデータが含まれることがある

Word 文書に含まれる文書変数を削除するには、次のマクロ例を使用します。
Sub DeleteDocVars()Dim ResponseDim myVar As Variable   For Each myVar In ActiveDocument.Variables      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _         "Value: " & myVar.Value & vbCr & vbCr & _         "Do you want to delete the variable from this document?", vbYesNo)                  If Response = "6" Then         ' 変数を削除         myVar.Delete      Else         End      End If   Next myVar               MsgBox "There are no variables in the document."   End Sub
Variables プロパティの詳細については、Visual Basic Editor で [ヘルプ] メニューの [Microsoft Visual Basic ヘルプ] をクリックします。次に、Office アシスタントまたはアンサー ウィザードで「Variables プロパティ」と入力して [検索] をクリックし、表示されるトピックを参照してください。

先頭に戻る

セキュリティに関する一般的な注意点

ここでは、使用しているコンピュータ環境でセキュリティのレベルを向上するための一般的な注意点について記載します。
  • コンピュータのそばから離れるときは、パスワードで保護されたスクリーン セーバー、システム起動時のパスワード、または Windows NT のロック機能を必ず使用してコンピュータを保護してください。
  • 使用しているコンピュータに共有フォルダがある場合は、必ずパスワードを適用して、権限のあるユーザーのみが共有にアクセスできるようにします。より高いセキュリティを実現するためには、ユーザー レベルの管理を使用して、コンピュータの共有にアクセスできるユーザーを正しく制御してください。
  • ファイルを削除した後、すぐにごみ箱を空にします。ファイルを削除するときに、自動的に完全消去または上書きを行うユーティリティの使用を検討する方法もあります。
  • バックアップしたデータは、金庫または鍵付きのキャビネットなどの安全な場所に保管します。
  • 重要な文書はパスワードで保護し、権限のあるユーザー以外は開くことができないようにします。パスワードは、安全な場所に保管する必要があります。パスワードを忘れた場合、パスワード保護された文書の内容を取り出す方法がないため、注意が必要です。
  • 電子的な形態で文書を配布することは避け、代わりに印刷するようにします。(プレゼンテーションなど) 電子的な形態で使用する必要がある場合を除いて、独自のフォント、透かし、ロゴ、または特殊な用紙など、相手から自分が特定されるような要素を使用しないでください。
  • 電子メールは匿名では処理されません。何らかの方法で文書に自分の識別情報が添付されるのを懸念するユーザーは、文書を電子メールで送信しないでください。
  • HTTP または FTP プロトコルを使用して、インターネット上で文書を送信しないでください。これらのプロトコルを使って送信される情報は、"クリア テキスト" で送信されます。これは、その内容を盗み見ることが (考えにくいことですが) 技術的に不可能ではないことを意味します。
先頭に戻る
関連情報

参考資料

この資料に記載した内容の関連情報については、次の「サポート技術情報」の資料を参照してください。
195007 WD2000: Some Document Properties Populated Automatically
194606 WD2000: Summary Information Under Properties Is Not Encrypted
209638 WD2000: No Password Prompt for &apos;Modify&apos; in Mail Client
先頭に戻る
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 237361 (最終更新日 2002-08-30) をもとに作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

privacy confidentiality identity anonymity meta-data
プロパティ

文書番号:237361 - 最終更新日: 12/05/2015 15:14:42 - リビジョン: 1.0

Microsoft Word 2000 Standard Edition

  • kbnosurvey kbarchive kbhowto kbhowtomaster wd2000 kbdta 文書 作成者 回覧先 隠し文字 個人 概要情報 word 情報 削除 セキュリティ フィールド メタデータ ハイパーリンク 履歴 KB237361
フィードバック