ヒストグラムは、頻度のデータを表示する縦棒グラフです。

注: このトピックでは、ヒストグラムの作成についてのみ説明します。 パレート図 (並べ替えられたヒストグラム) の詳細については、「パレート図を作成する」を参照してください。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[統計グラフの挿入]、[ヒストグラム] の順にクリックします。

    [統計グラフの挿入] ボタンからアクセスしたヒストグラム コマンド

    [おすすめグラフ] の [すべてのグラフ] タブを使用して、ヒストグラムを作成することもできます。

ヒント: 

  • グラフの外観をカスタマイズするには、[デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。 ビンの幅は、スコットの正規化基準ルールを使用して計算されます。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。 また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

[自動] オプション (スコットの正規化基準ルール)   

自動化の数式オプション

スコットの正規化基準ルール (Scott’s normal reference rule) では、データ セットと比較した場合のヒストグラムの分散の偏りを最小化します。通常は分散データを想定しています。

[ビンのオーバーフロー] オプション   

オーバーフロー ビンの数式オプション

[ビンのアンダーフロー] オプション   

ビンのアンダーフローの数式オプション
  1. 分析ツールが読み込まれていることを確認します。 詳細については、「Excel で分析ツールを読み込む」参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。

    項目の合計値、テストの点数など、必ず定量的な数値データを使用します。 ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。

    独自の境界値を使用すると、分析に役立つ可能性があります。 境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

  4. [データ] > [データ分析] をクリックします。

    [データ分析] と [ソルバー]

  5. [ヒストグラム]、[OK] の順にクリックします。

    [データ分析] ダイアログ ボックス

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックスに、入力番号が設定されているデータ範囲のセル参照を入力します。

    2. [データ区間] ボックスに、境界値が設定されている範囲のセル参照を入力します。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: 参照を手動で入力する代わりに、[ [折りたたみ] ] をクリックしてダイアログ ボックスを一時的に折りたたみ、ワークシートの範囲を選択できます。 このボタンを再びクリックすると、ダイアログ ボックスが表示されます。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] で、出力先を選びます。

    ヒストグラムは、同じワークシート上、現在のブックの新しいワークシート上、または新しいブックに出力することができます。

  9. 次のボックスを 1 つ以上オンにします。

    パレート (並べ替えヒストグラム) これは、データを頻度の降順で表示します。

    累積パーセンテージ     これは、累積パーセンテージを示し、ヒストグラム グラフに累積パーセンテージの線を追加します。

    グラフの出力     これは、埋め込まれたヒストグラム グラフを示しています。

  10. [OK] をクリックします。

    ヒストグラムをカスタマイズする場合は、テキスト ラベルを変更し、ヒストグラム グラフ内の任意の場所をクリックして、グラフの右側にある [グラフ要素]、[グラフ スタイル]、および [グラフ フィルター] ボタンを使用できます。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[グラフ] の順にクリックします。

    Word の [挿入] タブの [図] グループの [グラフ]
  3. [グラフの挿入] ダイアログ ボックスの [すべてのグラフ] で、[ヒストグラム] をクリックして、[OK] をクリックします。

ヒント: 

  • グラフの外観をカスタマイズするには、リボンにある [デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これはヒストグラムの既定の設定です。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

次の手順に従って、次の手順でヒストグラムを作成Excel for Mac。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. リボンの [挿入] タブをクリックし、[グラフ] ( 統計グラフ アイコン ) をクリックし、[ヒストグラム] で [ヒストグラム] を選択します

ヒント: 

  • グラフの外観をカスタマイズするには、[グラフのデザイン] タブと [書式] タブを使用します。

  • [グラフのデザイン] タブおよび [書式] タブが表示されない場合は、ヒストグラムの任意の場所をクリックして、それらをリボンに追加します。

Excel 2011 for Mac でヒストグラムを作成するには、サードパーティ製のアドインをダウンロードする必要があります。 詳細については、「2011 for Mac の 2011 Excel Analysis Toolpak が見当たらない」を参照してください。

Excel Onlineでは、ヒストグラム (頻度データを示す列グラフ) を表示できますが、 Web 用 Excelでサポートされていない Excel アドインである Analysis ToolPak が必要なので、作成できない場合があります。

デスクトップ アプリケーションが Excel 場合は、[Excel で編集] ボタンを使用して、デスクトップで Excel を開き、ヒストグラムを作成できます

[Excel で編集] ボタン

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 電話を使っている場合は、編集アイコンをタップ [編集] アイコン リボンを表示します。 をタップし、[ホーム] をタップします

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

    必要に応じて、グラフの要素をカスタマイズできます。

    注: この機能は、Microsoft 365 サブスクリプションをお持ちのユーザーに限り使用できます。 Microsoft 365 サブスクリプションをお持ちの場合は、最新バージョンの Office があることを確認してください

    Microsoft 365 を試用または購入するためのリンク

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 電話を使っている場合は、[編集] アイコンをタップ [編集] アイコン リボンを表示し、[ホーム] を タップします

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

Excelでヒストグラムを作成するには、分析するデータと、頻度を測定する間隔を表すビン番号の 2 種類のデータを指定します。 ワークシートの 2 つの列にデータを整理する必要があります。 これらの列には、次のようなデータが含まれている必要があります。

  • 入力データ    これは、ヒストグラム ツールを使用して分析するデータです。

  • 区間番号    これらの番号は、データ分析で入力データを測定するためにヒストグラム ツールで使用する間隔を示します。

[ヒストグラム] ツールを使用すると、 Excel ビン内のデータ ポイントの数がカウントされます。 データ ポイントは、その数値がデータ区間の最小の境界値よりも大きく、最大の境界値以下である場合、特定の区間に含まれます。 ビン範囲を省略すると、 Excel データの最小値と最大値の間に均等に分散されたビンのセットが作成されます。

ヒストグラム分析の出力は、新規ワークシート (または新規ブック) に表示され、ヒストグラム テーブルおよびヒストグラム テーブル内のデータを反映する縦棒グラフが表示されます。

補足説明

Excel 技術コミュニテでは、いつでも専門家に質問できます。また、Answers コミュニティでは、サポートを受けられます。

関連項目

ウォーターフォール図の作成

パレート図を作成する

グラフにサンバースト グラフを作成Office

箱ひげ図を作成する

ツリーマップ グラフを作成Office

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Office Insider に参加

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×