すべてのデータを分析できると、ビジネス上の意思決定を向上させるのに役立ちます。 ただし、Microsoft Access や Microsoft SQL Server データベース、オンライン分析処理 (OLAP) キューブ ファイルなど、Excel の外部に保存されているデータが多い場合は特に、どこから始めるべきかわかりません。 その場合は、外部データ ソースに接続し、ピボットテーブルを作成して、そのデータを集計、分析、探索、表示します。

既存の外部データ接続を使用してピボットテーブルを作成する方法を次に示します。

  1. ワークシートで、セルをクリックします。

  2. [挿入]、[ピボットテーブル] の順にクリックします。

    [挿入] タブの [ピボットテーブル] ボタン

  3. [ピボットテーブルの作成 ] ダイアログ ボックスで、[分析するデータを選んでください。] の下にある [外部データ ソースを使用] をクリックします。

    [外部データ ソースを使用] が選択された [ピボットテーブルの作成] ダイアログ ボックス

  4. [接続の選択] をクリックします。

  5. [接続] タブの[表示]ボックスで、[すべての接続] を選択した状態にするか、接続するデータ ソースを含む接続カテゴリを選択します。

既存の接続を再利用または共有するには、このブックの 接続から接続を使用します

  1. 接続の一覧で目的の接続を選択し、[開く] をクリック します

  2. [ ピボットテーブル レポートを配置する場所を選択する] で、場所を選択します。

    • セル A1 から始まる新しいワークシートにピボットテーブルを配置するには、[新しいワークシート] を選択します

    • アクティブなワークシートにピボットテーブルを配置するには、[既存のワークシート] を選択し、[場所] ボックスにピボットテーブルを開始するセルを入力します。

  3. [OK] をクリックします。

    Excel空のピボットテーブルが追加され、[フィールド リスト] が表示され、 必要なフィールドを表示したり、並べ替えたりして独自のレイアウトを作成できます

    外部データ フィールドが表示されたフィールド リスト

  4. [フィールド リスト] セクションで、フィールド名の横にあるチェック ボックスをオンにして、[フィールド リスト] の領域セクションの既定の領域にフィールド を配置します

    通常、数値以外のフィールドは [行] 領域に追加され、数値フィールドは [値] 領域に追加され、日付と時刻のフィールドは [列] 領域に追加されます。 必要に応じて、フィールドを別の領域に移動できます。

    ヒント: フィールド名を右クリックし、[レポート フィルターに追加]、列ラベルに追加、行ラベルに追加、または [値に追加] を選択して、フィールドを領域セクションのその領域に配置するか、フィールド セクションから領域セクションの領域にフィールドをドラッグすることもできます。

    [フィールドリスト] を使用して、ピボットテーブルのレイアウトと書式をさらにデザインするには、[領域] セクションのフィールドを右クリックし、目的の領域を選択するか、領域セクション内の領域間でフィールドをドラッグします。

Connect外部データ ソースへの接続

新しい外部データ接続を作成してテーブルSQL ServerテーブルまたはピボットテーブルExcelにデータをインポートするには、次の操作を行います。

  1. [Data >From Other Sources ]をクリックします

[データ] タブの [その他のデータ ソース] ボタン

  1. 必要な接続をクリックします。

    • [SQL Server]をクリックして、テーブルへの接続SQL Serverします。

    • [Analysis Services から] をクリックして、分析キューブSQL Server作成します。

  2. データ接続 ウィザード で、接続を確立する手順を完了します。

    • 1 ページで、データベース サーバーを入力し、サーバーにログオンする方法を指定します。

    • 2 ページ目で、必要なデータを含むデータベース、テーブル、またはクエリを入力します。

    • 3 ページで、作成する接続ファイルを入力します。

Access データベースへの新しい接続を作成し、テーブルまたはピボットテーブルExcelにデータをインポートするには、次の操作を行います。

  1. [Data >From Access] をクリックします

[データ] タブの [Access データベース] ボタン

  1. [データ ソースの選択] ダイアログ ボックスで、接続するデータベースを見つけ、[開く] を クリックします

  2. [テーブル の選択] ダイアログ ボックスで、目的のテーブルを選択し 、[OK] をクリックします

複数のテーブルがある場合は、[複数のテーブルの選択を有効にする] チェック ボックスをオンにして、必要なテーブルのボックスをオンにし、[OK]をクリックします。

  1. [データ のインポート ] ダイアログ ボックスで、ブック内のデータの表示方法とデータを保存する場所を選択し 、[OK]をクリックします。

テーブルがデータ モデルに自動的に追加され、Access データベースがブックの接続に追加されます。

ピボットテーブルの詳細

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×