Microsoft Access 2010の使い方を学ぶのに役立つ基本的なデータベース タスクを次に示#x0。

 

この記事の内容

Access とは

Access 2010 は、重要な情報を追跡するために使用できるデータベース アプリケーションの設計および展開ツールです。 他のユーザーが Web ブラウザーでデータベースを使用できるよう、自分のデータをコンピューターに保持したり、Web に公開したりすることができます。

多くのユーザーが、タスクに対して徐々に何かを追跡するために使用しているプログラムが適しくなり、Access の使用を開始します。 たとえば、自分がイベント プランナーであり、イベントを成功するために管理する必要があるすべての詳細を追跡したいとします。 ワード プロセッサまたはスプレッドシート プログラムを使用してこれを行う場合、重複するデータや矛盾したデータで問題が発生する可能性があります。 カレンダー ソフトウェアは使用できますが、予定表で財務情報を追跡することは適した機能ではないと考え、データの管理に適しています。

Access のリレーショナル データベース

このような情報を追跡するには、リレーショナル データベースが必要な場合があります。重複をなくし、一般的な情報 (フィールドと呼ばれる) に基づいて関連付け合わせて、より小さなデータのコレクション (テーブルと呼ばれる) に分割されたデータの保存場所です。 たとえば、イベント計画リレーショナル データベースには、顧客情報を含むテーブル、ベンダー情報を含むテーブル、およびイベント情報を含むテーブルが含まれる場合があります。 イベント情報を含むテーブルには、得意先テーブルに関連付けるフィールドと、それを仕入先テーブルに関連付けるフィールドがあります。 この方法では、たとえば、ベンダーの電話番号が変更された場合、ベンダーが関与するあらゆるイベントではなく、ベンダー テーブルで情報が 1 回変更される可能性があります。

Access は、情報の管理に役立つリレーショナル データベース アプリケーションをすばやく簡単に開発するために使用できるツールです。 データベースを作成すると、在庫、専門の連絡先、ビジネス プロセスなど、あらゆる種類の情報を追跡できます。 実際には、Access にはテンプレートが付属しています。テンプレートを使ってさまざまな情報を追跡し、初心者でも簡単に管理できます。

Access を開いた場合

Access 2010を起動すると、Microsoft Office Backstage ビューが表示されます。このビューでは、現在のデータベースに関する情報の取得、新しいデータベースの作成、既存のデータベースの開き、 Office.comからのおすすめコンテンツの表示を行えます。

Access 2010 の Backstage ビュー

Backstage ビューには、データベースの調整、保守、または共有に使用できる他の多くのコマンドも含まれています。 Backstage ビューのコマンドは通常、データベース内のオブジェクトではなく、データベース全体に適用されます。

注: [ファイル] タブをクリックすると、いつでも Backstage ビュー にアクセス できます。

ページの先頭へ

テンプレートを検索して適用する

Access には、データベース作成プロセスの高速化に使用できるさまざまなテンプレートが提供されています。 テンプレートは、特定のタスクを実行するために必要なすべてのテーブル、クエリ、フォーム、レポートを含む、すぐに使用できるデータベースです。 たとえば、問題の追跡、連絡先の管理、経費の記録に使用できるテンプレートがあります。 一部のテンプレートには、使用例を示すサンプル レコードがいくつか含まれます。 テンプレート データベースは、この方法で使用するか、ニーズに合わせてカスタマイズできます。

テンプレートを検索してデータベースに適用するには、次の操作を行います。

  1. [ファイル] タブの [新規] をクリックします。

  2. [ 使用可能なテンプレート] で、次のいずれかの操作を行います。

    • 最近使用したテンプレートを再利用するには、[最近使ったテンプレート] をクリックし、目的のテンプレートを選択します。

    • 既にインストールされているテンプレートを使用するには、[マイテンプレート] をクリックし、目的のテンプレートを選択します。

    • Office.comでテンプレートを見つけるには、[Office.comテンプレート] でテンプレート カテゴリをクリックし、目的のテンプレートを選択し、[ダウンロード] をクリックして Office .com からコンピューターにテンプレートをダウンロードします。

      Access 内からテンプレートをOffice.com検索することもできます。 [テンプレート の検索Office.com ボックスに、1 つ以上の検索用語を入力し、矢印ボタンをクリックして検索します。

  3. 必要に応じて、[ファイル名] ボックスの横にあるフォルダー アイコンをクリックして、データベースを作成する場所を参照します。 特定の場所を指定しない場合は、[ファイル名] ボックスの下に表示される既定の場所にデータベース が作成 されます。

  4. [作成] をクリックします。

Access によってデータベースが作成され、使用するために開きます。

ページの先頭へ

データベースを一から作成する

Access を使用してデータベースを作成する背後にある概念について、より詳しい説明が必要な場合は、「データベース設計の基本」の 記事を参照してください

どのテンプレートもニーズに合わない場合、または Access で使用する別のプログラムのデータがある場合は、データベースを最初から作成した方が良い場合があります。 Access 2010 では、標準デスクトップ データベースまたは Web データベースから選択できます。

Web データベースの詳細については、「Web で共有するデータベースを作成 する」を参照してください

新しいデータベースを作成するには、次の操作を行います。

  1. Access を起動します。

  2. Backstage ビュー の [ 新規] タブで、[空のデータベース] または [ Web データベース] をクリックします

    重要: ここで選択すると、データベースで使用できる機能が決されます。 デスクトップ データベースは Web に発行できません。また、Web データベースは、合計クエリなどの一部のデスクトップ機能をサポートしていない。

  3. 右側の [ファイル名] ボックスにデータベースの名前 を入力 します。

    ファイルを作成する場所を変更するには、[ファイル名]ボックスの横にある [代替テキストを参照] をクリックし、新しい場所を参照して選択し、[OK]をクリックします。

  4. [作成] をクリックします。

    Access によってデータベースが作成され、テーブル内に空のテーブル (Table1 という名前) が データシート ビュー。

  5. Access では、新しいテーブルの [クリックして追加] 列の最初の 空のセル にカーソルが置かされます。

    データを追加するには、入力を開始するか、別のソースのデータを貼り付ける (この記事で後述する「別のソースのデータを Accessテーブルに貼り付ける」セクションで説明したように) 貼り付けます。

    注: 

    • データシート ビューでのデータの入力は、Excel ワークシートでのデータ入力と非常に似たデザインです。 主な制限は、データシートの左上隅から連続する行と列にデータを入力する必要があるという制限です。 Excel ワークシートのように空白の行または列を含めてデータの書式を設定すると、テーブルのスペースが無駄になるので、書式設定を試みる必要があります。 テーブルには単にデータが格納されます。 そのデータのすべての視覚的なプレゼンテーションは、後でデザインしたフォームとレポートで行われます。

    • データを入力すると、テーブル構造が作成されます。 データシートに新しい列を追加すると、テーブルに新しいフィールドが定義されます。 入力したデータ データ型 に基づいて、フィールドのフィールドの種類が設定されます。 たとえば、日付値のみを入力した列がある場合、Access ではそのフィールドのデータ型が日付/時刻型に設定されます。 後で日付以外の値 (名前や電話番号など) をそのフィールドに入力しようとすると、値が列のデータ型と一致しないというメッセージが表示されます。 可能な場合は、各列にテキスト、日付、数値など、同じ種類のデータが含まれるテーブルを計画する必要があります。 これにより、必要なデータを選択するクエリ、フォーム、レポートを簡単に作成できます。

データをまだ入力しない場合は、[閉じる]をクリック ボタンの画像

注: 保存せずに閉じると、Access によって Table1 が削除されます。

ページの先頭へ

既存の Access データベースを開く

ヒント: 最後に開いたデータベースの 1 つをすばやく開く場合は、[ファイル]タブで [最近使ったファイル] をクリックし、ファイル名をクリックします。

  1. [ファイル] タブの [開く] をクリックします。

  2. [開く]ダイアログボックスでショートカットをクリックするか、[検索場所] ボックスで、必要なデータベースを含むドライブまたはフォルダーをクリックします。

  3. フォルダー一覧で、データベースを含むフォルダーを開くまでフォルダーをダブルクリックします。

  4. データベースが見つけたら、次のいずれかの操作を行います。

    • データベースを既定の開きモードで開くには、データベースをダブルクリックします。

    • 自分と他のユーザーの両方がデータベースの読み取りと書き込みを同時に行える、マルチユーザー環境で共有アクセス用のデータベースを開く場合は、[開く] をクリック します

    • 読み取り専用アクセス用にデータベースを開き、表示はできるが編集できない場合は、[開く] ボタンの横にある矢印をクリックし、[読み取り専用で開く] をクリックします

    • データベースを排他アクセス用に開き、開いている間は他のユーザーがデータベースを開くことができない場合は、[開く]ボタンの横にある矢印をクリックし、[排他で開く] をクリックします。

    • 読み取り専用アクセス用にデータベースを開く場合は、[開く] ボタンの横にある矢印をクリックし、[読み取り専用で開く] をクリックすると、他のユーザーは引き続きデータベースを開くことができますが、読み取り専用アクセス権のみを持ちます。

開くデータベースが見当たらない場合    

  1. [開く]ダイアログ ボックスで、[マイ コンピューター] ショートカットをクリックするか、[探すファイル] ボックスで [マイ コンピューター]をクリックします

  2. ドライブの一覧で、データベースが含まれていると思うドライブを右クリックし、[検索] をクリック します

  3. 検索条件を入力し、Enter キーを押してデータベースを検索します。

  4. データベースが見つかった場合は、[検索結果] ダイアログ ボックスでダブルクリックして きます。

    検索は [開く] ダイアログボックスから開始されたため、データベースを開く前に、そのダイアログ ボックスで [キャンセル] をクリックする必要があります。

外部ファイル形式 (dBASE、Paradox、Microsoft Exchange、Excel など) でデータ ファイルを直接開くことができる。 また、Microsoft FoxPro などの ODBC データ ソースを直接Microsoft SQL Server開く方法があります。 Access では、データ ファイルと同じフォルダーに新しい Access データベースが自動的に作成され、外部データベースの各テーブルへのリンクが追加されます。

ページの先頭へ

新しいデータベースの使用を開始する

使用したテンプレートによっては、新しいデータベースの使用を開始するために、次の操作が必要になる場合があります。

  • 空のユーザーリストが 表示された [ログイン] ダイアログ ボックスが表示される場合は、次の手順に従って開始します。

    1. [新 しいユーザー] をクリックします

    2. [ユーザーの詳細 ] フォームに入力 します。

    3. [保存して閉じる] をクリックします。

    4. 入力したユーザー名を選び、[ログイン] を クリックします

  • 空のデータシートが表示される場合は、そのデータシートに直接データを入力するか、他のボタンやタブをクリックしてデータベースを参照できます。

  • Access に[操作の開始] ページが表示されている場合は、そのページのリンクをクリックしてデータベースの詳細を確認するか、他のボタンやタブをクリックしてデータベースを参照できます。

  • メッセージ バーにセキュリティ警告 メッセージ が表示され、テンプレートのソースが信頼できる場合は、[コンテンツの有効化] を クリックします。 データベースにログインが必要な場合は、もう一度ログインする必要があります。

デスクトップ データベースと Web データベースの場合は、次のいずれかの手順から始める必要があります。

ページの先頭へ

表を追加する

[作成] タブの [テーブル] グループのツールを使用して、既存のデータベース に新しい テーブルを 追加 できます。

[作成] タブの [テーブル]

注: Web データベースでは、[テーブル] グループ 使用できるのは [ テーブル] コマンドのみです。

開始するビューに関係なく、Access ウィンドウのステータス バーにある [表示] ボタンを使用して、いつでも他のビューに切り替えます。

データシート ビューで空白のテーブルを作成する    データシート ビューでは、データをすぐに入力して、Access でテーブル構造を構築できます。 フィールド名には数値 (Field1、Field2 など) が割り当て、入力したデータの種類に基づいてフィールド データ型が設定されます。

  1. [作成]タブの[テーブル] グループ、[テーブル] タブボタンの画像

  2. テーブルが作成され、[クリックして追加] 列の最初の空の セルにカーソルが置 かされます。

  3. データを追加するには、最初の空のセルに入力を開始するか、この記事で後述するように別のソースのデータを貼り付けます。

    • 列 (フィールド) の名前を変更するには、列見出しをダブルクリックし、新しい名前を入力します。

      ヒント: 各フィールドにわかりやすい名前を付け、データを確認することなく、フィールドに含まれているデータを確認できます。

    • 列を移動するには、列見出しをクリックして列を選択し、目的の場所にドラッグします。 連続する複数の列を選択し、それらをまとめて新しい場所にドラッグすることもできます。

      テーブルにフィールドを追加するには、データシート ビューの [クリックして追加] 列に入力を開始するか、[フィールド] タブの [& 削除の追加] グループのコマンドを使用して新しいフィールドを追加します。

デザイン ビューからテーブルを作成する    デザイン ビューでは、まず新しいテーブルの構造を作成します。 次に、データシート ビューに切り替えてデータを入力するか、フォームなどの他の方法でデータを入力します。

デザイン ビューは、Web データベース内のテーブルでは使用できません。

  1. [作成] タブで、[テーブル] グループの [テーブル デザイン] をクリックします。 ボタンの画像

  2. テーブルのフィールドごとに、[フィールド名] 列に名前を入力し、[データ型] リストからデータ型を選択します。

  3. [説明] 列には、フィールドごとに追加情報を 入力 できます。 入力した説明は、挿入ポイントがフィールド内にあるときにステータス バーに表示され、[フィールド リスト] ウィンドウからフォームまたはレポートにフィールドをドラッグして作成したコントロールのステータス バーテキストとして使用され、フォーム ウィザードまたはレポート ウィザードによってそのフィールドに対して作成されたコントロールに使用されます。

  4. すべてのフィールドを追加した後、テーブルを保存します。

    • [ファイル] タブで [保存] をクリックします。

  5. データシート ビューに切り替え、最初の空のセルをクリックして入力すると、いつでもテーブルにデータを入力できます。 次のセクションで説明するように、別のソースのデータを貼り付けもできます。

SharePoint リストに基づいてテーブルを作成する    SharePoint リストを使用すると、Access を使用していないユーザーがデータを使用できます。 さらに、リスト データはサーバーに保存され、一般的に、デスクトップ コンピューターに保存されているファイルよりもデータ損失に対する保護が向上します。 新しいリストから始めるか、既存のリストにリンクすることができます。 リストを作成する SharePoint サイトに対して十分な権限が必要です。これはサイトによって異なる場合があります。オプションの詳細については、SharePoint 管理者にお問い合わせください。

この機能は Web データベースでは使用できません。

  1. [作成] タブの [テーブル] で、[SharePoint リスト] をクリックします。

  2. リスト テンプレートの 1 つを使用して、連絡先やイベントなどの標準の SharePoint リストを作成できます。

    ユーザー設定リストを作成したり、既存のリストにリンクしたり、既存のリストをインポートしたりもできます。 必要なオプションをクリックします。

  3. リスト テンプレートを選ぶか、ユーザー設定のリストを作成する場合は、[新しいリストの作成] ダイアログ ボックスが開き、プロセスを案内します。 既存のリストを使用する場合は、[外部データの取り込み] ダイアログ ボックスが表示されます。

テーブルの詳細については、「テーブルの概要」を参照してください。

ページの先頭へ

別のソースのデータを Access テーブルに貼り付ける

データが現在 Excel などの別のプログラムに保存されている場合は、データをコピーして Access テーブルに貼り付けます。 一般に、これは、データが Excel ワークシートと同じ列に既に分割されている場合に最適です。 データがワード プロセス プログラム内にある場合は、まずタブを使用してデータの列を分離するか、またはワード プロセス プログラムでデータをテーブルに変換してから、データをコピーする必要があります。 データの編集や操作が必要な場合 (たとえば、フル ネームを名と名に分割する場合)、特に Access に慣れている場合は、データをコピーする前に、この操作を行います。

空のテーブルにデータを貼り付ける場合、Access では、見つけたデータの種類に応じて各フィールドのデータ型が設定されます。 たとえば、貼り付けフィールドに日付値以外の値が含まれている場合、Access はそのフィールドに日付/時刻データ型を適用します。 貼り付けフィールドに "yes" と "no" の単語だけが含まれている場合、フィールドには Yes/No データ型が適用されます。

貼り付けデータの最初の行で見つけた内容に応じて、フィールドに名前が付けされます。 貼り付け先のデータの最初の行が次の行と型が似ている場合、Access は最初の行がデータの一部と判断し、フィールドの汎用名 (Field1、Field2 など) を割り当てました。 貼り付けデータの最初の行が次の行と類似していない場合、Access は最初の行をフィールド名として使用し、実際のデータの最初の行を除外します。

Access で汎用フィールド名が割り当てらされている場合は、混乱を避けるために、できるだけ早くフィールドの名前を変更する必要があります。 次の手順で行います。

  1. [ファイル] タブの [保存 ] をクリックして テーブルを保存します。

  2. データシート ビューで、各列見出しをダブルクリックし、列の名前を入力します。

  3. もう一度テーブルを保存します。

ページの先頭へ

次のステップ

残りのデザイン プロセスは目標によって異なりますが、クエリ、フォーム、レポート、マクロの作成を検討する必要がある場合があります。 この記事では、追加のデータベース オブジェクトの作成に関する情報は提供しません。

詳細については、次の記事を参照してください。

ページの先頭へ

スプレッドシートまたは他のプログラムからデータをインポートする

他のデータベースやスプレッドシート プログラムを使い慣れた方は、これらのアプリケーションの動作やデータベースの用途の基礎を理解している方が多いはず。 Access では、リレーショナル データベースを作成できる他の多くのデータベース アプリケーションとは異なります。また、高度なクエリ、フォーム、レポートを開発するためのツールを提供することで、ほとんどのスプレッドシート プログラムとはさらに異なります。 Access には、データベース などの他のデータベース プログラムを操作するための多くのオプションSQL Server。

Excel ワークシートを Access にインポートする

多くのユーザーが、Excel で最初にリストを作成した後に Access の探索を開始します。 Excel はリストの作成に最適な場所ですが、リストが増えるにつれて、整理や更新が難しくなります。 通常、リストを Access に移動する手順は次の論理的手順です。

データベース テーブルは、データが行と列に格納されるという点で、ワークシートと構造が似ています。 そのため、通常、ワークシートをデータベース テーブルにインポートするのは簡単です。 ワークシートにデータを保存する場合とデータベースに保存する主な違いは、データの整理方法です。 ワークシート全体をデータベースの新しいテーブルとしてインポートするだけでは、特にワークシートに冗長なデータが含まれている場合、データの整理と更新に関連する問題は解決しません。 これらの問題を解決するには、関連データを含むスプレッドシート データを別々のテーブルに分割する必要があります。 テーブル内のデータを配置する方法の詳細については、「データベース設計の基本」 を参照してください

Access にはテーブルアナライザー ウィザードが含まれるので、このプロセスを完了するのに役立ちます。 データをテーブルにインポートした後、ウィザードを使用すると、テーブルを別々のテーブルに分割し、それぞれに他のテーブルで複製されていないデータが含まれます。 ウィザードでは、テーブル間に必要なリレーションシップも作成されます。

ページの先頭へ

Excel ワークシートを新しいデータベースのテーブルとしてインポートする

  1. [ファイル] タブの [新規] を クリックし、[空のデータベース ] をクリックします

  2. [ファイル名] ボックスに新しいデータベースの名前を入力し、[作成] をクリックします

    新しいデータベースが開き、新しい空のテーブル Table1 が作成されます。

  3. Table1 を閉じます。

    Table1 のデザインに変更を保存する場合は、[いいえ] をクリックします。

  4. [外部 データ] タブの [リンクのインポート& Excel]クリックしますボタンの画像

  5. [外部データ の取り込み] ダイアログ ボックスで、[参照] を クリックします

  6. [ファイルを 開く] ダイアログ ボックスを使用して、ファイルを探します。

  7. ファイルを選び、[開く] をクリックします。

  8. [外部 データの取り 込み] ダイアログ ボックスで、[現在のデータベースの新しいテーブルにソース データをインポートする] オプションが選択 されています。

  9. [OK] をクリックします。

    スプレッドシート インポート ウィザードが起動し、データに関する質問が表示されます。

  10. 指示に従って、[次へ] または [ 戻る ] を クリックしてページ 間を移動します。 ウィザードの最後のページで、[完了] をクリックします。

    注: 完了したインポート操作の詳細を保存するかどうかを確認するメッセージが表示されます。 同じインポート操作を再度実行すると思う場合は、[はい]をクリックし、詳細を入力します。 その後、[外部データ] タブの [インポート]グループで [保存済みインポート] をクリックすると、今後の操作を簡単に再現できます。 操作の詳細を保存しない場合は、[閉じる] をクリック します

新しいテーブルにデータがインポートされ、ナビゲーション ウィンドウの [すべてのテーブル] の下に表示されます。

ページの先頭へ

テーブル分析ツール ウィザードを使用してデータを整理する

データを Access テーブルにインポートしたら、テーブルアナライザー ウィザードを使用して冗長なデータをすばやく特定できます。 ウィザードでは、データを個別のテーブルに整理して、最も効率的な方法で保存する簡単な方法が提供されます。 Access では、元のテーブルがバックアップとして保持され、データベース アプリケーションの基礎として使用できる新しいテーブルが作成されます。

  1. 分析するテーブルが含まれている Access データベースを開きます。

  2. [データベース ツール ] タブの [分析] グループ 、[テーブルの分析] をクリックします

    テーブル分析ツール ウィザードが起動します。

    ウィザードの最初の 2 ページには、クリックして例を表示できるボタンが含まれる短いチュートリアルが含まれています。 導入ページが表示されるのではなく、[導入ページを表示する] チェック ボックスが表示される場合は、チェック ボックスをオンにし、[戻る] を 2 回クリックして概要を表示します。 概要を読んだ後に導入ページを再び表示したくない場合は、[導入ページを表示しますか ? ] チェック ボックスをオフにできます。

  3. [複数 のレコードで繰 り返される値を含むフィールドを含むテーブル] ページで、分析するテーブルを選択し、[次へ] をクリック します

  4. ウィザードで、どのテーブルにどのフィールドを入れるかを決定させるか、または自分で決定することができます。 ウィザードの指示に従った場合でも、ウィザードの次のページで表のレイアウトを変更できます。

    注: ウィザードで、どのテーブルにどのフィールドを入力するか決定する場合、特に作業するデータがあまりない場合は、その選択が常にデータに適しているとは限りしません。 ウィザードの結果は慎重に確認する必要があります。 一方、ウィザードでは、考えている組織よりも効率的な組織を提案する場合があります。そのため、少なくともウィザードの決定を 1 回は実行してみてください。 提案が気に入らない場合でも、フィールドを手動で並べ替え、いつでも [戻る] をクリックして、すべてのフィールドを自分で配置することができます。

  5. [次へ] をクリックします。 このページでは、フィールドを含むテーブルを指定します。 ウィザードで決定することを選択した場合は、リレーションシップ ラインで接続された複数のテーブルが表示されます。 それ以外の場合は、すべてのフィールドを含むテーブルが 1 つ作成されます。 いずれの場合も、このページで変更を行えます。

    • テーブルからページの空白領域にフィールドをドラッグして、それらのフィールドを含む新しいテーブルを作成できます。 テーブル名の入力を求めるメッセージが表示されます。

    • フィールドを別のテーブルにドラッグすると、フィールドの方が効率的に保存されます。

    • ほとんどのテーブルには 、ID または生成された一意 の ID フィールドが割り当 てされます。 [ID] フィールドの詳細については、ウィザードの右上隅にある [ヒント] をクリックします。

    • 変更を元に戻すには、[元に戻す] ボタン をクリック します。

    • テーブルの名前を変更するには、タイトル バーをダブルクリックし、新しい名前を入力し 、[OK]をクリックします。

  6. フィールドを必要な方法で配置した後、[次へ] を クリックします

  7. ウィザードで、非常に類似した値を持つレコードが検出された場合、入力ミスの可能性がある値が特定され、その処理を確認できる画面が表示されます。 リストをスクロールして [修正] 列の値を検索し、ドロップダウン リストで適切な項目をクリックします。 ウィザード が値に変更 を加え続けない場合は、[そのまま残す] を選択します。 完了したら、[次へ] を クリックします

  8. ウィザードでは、元のテーブルに似たクエリを作成するかどうかを確認するメッセージが表示されます。 元のテーブルに基づくフォームとレポートを既に作成している場合は、そのようなクエリを作成するとよい方法です。 [はい] を選択した場合は、クエリを作成すると、ウィザードによってテーブル名に "_OLD" が追加され、元のテーブルの名前を使用して新しいクエリの名前が変更されます。 テーブルに基づくフォームとレポートでは、データに対するクエリが使用され、以前と同様に動作し続ける。

  9. [完了] をクリックします。

    ウィザードでは、指定した方法で新しいテーブルが作成され、開きます。 結果の検査が終了したら閉じます。

ページの先頭へ

他のプログラムのデータを使用する

Access 2010 には、他のプログラムに保存されているデータを操作する機能があります。

別のファイル形式のデータにリンクする新しい Access データベースを作成する    Access を使用して、テキスト、dBASE、スプレッドシートなどの別のファイル形式でファイルを開きます。 Access によって Access データベースが自動的に作成され、ファイルが自動的にリンクされます。

  1. Access を起動します。

  2. [ファイル] タブの [開く] をクリックします。

  3. [開 ] ダイアログ ボックスで、一覧で開くファイルの種類をクリックします。 ファイルの種類が不明な場合は、[すべてのファイル ] (*.*) をクリックします

  4. 必要に応じて、開くファイルを含むフォルダーを参照します。 ファイルが見つけたら、ダブルクリックして開きます。

  5. ウィザードに表示される手順に沿って操作します。 ウィザードの最後のページで、[完了] をクリックします。

既存の Access データベースにデータをインポートまたはリンクする    他のソースやプログラムから Access テーブルにデータをインポートしてデータが Access ファイルに含まれるか、データが元のファイル (Access ファイルの外部) に残るデータにリンクすることもできます。

  1. [外部 データ] タブ の [インポート& リンク ] グループで、データが保存されている形式をクリックします。

    次のソースからデータをインポートまたはリンクできます。

    • Excel    Excel ブック内のワークシートまたは名前付き範囲からデータを取り込む。 各ワークシートまたは名前付き範囲は、個別にインポートまたはリンクする必要があります。

    • Access    これは、プロセスをデータから分離し、分割データベースを作成する場合に非常に便利です。 つまり、1 つのデータベースを使用して、すべてのフォーム、レポート、マクロを含め、データを別のデータベースに保持できます。 その後、すべてのユーザーの作業を中断することなく、改善を開発できます。 また、多くの異なる Access データベースのデータを 1 つで結合して、部門間またはビジネス パートナー間でデータを簡単に集計することもできます。

    • ODBC データベース    多くのプログラムでは、多くのデータベース サーバー製品を含め、この形式をサポートしています。 これにより、さまざまなシステムのデータを組み合わせる "ランディング パッド" データベースを作成できます。

    • テキスト ファイル    単純なテキスト ファイルに接続し、Access を使用してそのファイルの内容を変更できます。 これにより、さまざまなプログラムで Access データを簡単に使用できます。

    • XML ファイル    この形式は、一部の Web サーバーを含む他のさまざまなプログラムとの互換性も提供します。

    • SharePoint リスト    これにより、SharePoint リストを使用する標準的な方法である Web ブラウザーでデータを使用できます。

    • データ サービス    企業内の Web データ サービスに接続できます。

    • HTML ドキュメント    

    • Outlook フォルダー    Outlook フォルダーに接続すると、連絡先情報を他のデータと簡単に統合できます。

    • dBase ファイル    dBase は、Access でサポートされている一般的な代替データベース システムです。

      [ 外部データの取り込み ] ダイアログ ボックスが表示されます。

  2. ダイアログ ボックスの指示に従います。

    Access によってデータがデータベースにインポートまたはリンクされます。 ほとんどの形式では、データの場所を指定し、データをデータベースに格納する方法を選択する必要があります。

ページの先頭へ

以前のバージョンのデータベースを複数のバージョンの Access で使用する

Access データベースまたは Access プロジェクトが Access 2000 以降で作成された場合は、ファイルのセキュリティが有効な場合でも、データベースまたはプロジェクトを作成したバージョンまたはそれ以降のバージョンの Access で使用できます。 たとえば、Access 2000 ファイルは、Access 2000、Access 2002、Access 2003、Access 2007、Access 2010 で使用できます。

以前のバージョンの Access でデータを保持したいが、新しいバージョンの Access を持つユーザーが、そのデータにリンクしたいが、新しいバージョンの機能の一部を利用したい場合があります。 解決策は、新しいバージョン (フォーム、レポート、クエリ、マクロを含むがテーブルなし) で新しい "フロントエンド" データベースを作成し、以前のバージョンのファイルのテーブルにリンクすることです。 データベースが 1 つのファイルに含まれているか、既に 1 つのファイルに分割されているのかによって、次のいずれかの手順を フロントエンド/バックエンド アプリケーション。

Access データベース ファイルを複数のバージョンの Access で使用する

以前のバージョンの Access データベースのすべてのテーブル、フォーム、その他のオブジェクトが 1 つのファイルに含まれている場合、いくつかのバージョンの Access でデータベースを使用する場合は、新しいフロントエンド データベースを新しいバージョンで作成し、それを元のファイルにリンクすることができます。 以前のバージョンの Access を使用しているユーザーは、引き続き元のデータベースを使用できます。 新しいバージョンを使用しているユーザーは、新しいフロントエンド データベースを使用して同じデータにリンクできます。 Access の複数のバージョンに対応する必要がある場合は、複数のフロントエンド バージョンを作成できます。

ページの先頭へ

手順 1: 既存のデータベースのコピーを作成し、新しい形式で保存する

Access 2000、Access 2002-2003、または Access 2007 の 3 つの最新の形式にデータベースを変換するには、次の手順を使用します。 このコマンドは、元のデータベースを元の形式で保持し、指定した形式でコピーを作成します。

  1. Access ファイルを閉じます。 ファイルがサーバーまたは共有フォルダーにあるマルチユーザー Access データベースの場合は、他のユーザーが開いていないか確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. 変換するファイルの場所を参照し、ダブルクリックして開きます。

    [データベースの 拡張] ダイアログ ボックスが表示され、データベースを拡張するかどうかを確認するメッセージが表示されたら、[いいえ] を クリックします

  5. データベースの起動時にフォームが開いたら、フォームを閉じます。

  6. [ファイル] タブの [データベースに名前を 付けて保存] をクリックします

  7. [名前 を付けて保存 ] ダイアログ ボックスで、新しいデータベースの名前を入力します。

    注: 新しいデータベースを別の場所に保存しない限り、その名前は元のデータベースとは異なる名前である必要があります。 どちらの場合も、フロントエンド データベースとバック エンド データベースを簡単に区別できるよう、通常は別の名前を使用する方が最適です。 ただし、Access 2007 形式に変換する場合、ファイル名の拡張子は .mdb から .accdb に変わり、同じファイル名を使用できます。

  8. [保存] をクリックします。

ページの先頭へ

手順 2: コピー データベースを分割し、元のファイルをバック エンド データベースとして使用する

次の手順に従って、変換されたデータベースを分割します。

  • [データベース ツール ] タブの [データの移動] グループ で、[Access データベース] をクリックしますボタンの画像

  • [データベース分割 ] ダイアログ ボックスで、[データベースの分割] をクリックします。

    必要に合ったバックアップを作成できますが、元のデータベースを使用してコピーを再作成する方法があります。

  • バック エンド データベースの名前を入力し、[分割] を クリックします

ページの先頭へ

手順 3: 新しいフロントエンドを元のデータベースに接続する

  1. データベース分割ツールが作成したバック エンド データベースを削除します。元のデータベースは削除しないように注意してください。

  2. 新しいフロントエンド データベースを元のデータベースのテーブルにリンクする:[外部データ] タブの[リンク] グループの [& テーブル マネージャー] をクリックしますボタンの画像

  3. [ すべて選択] をクリックし、[常に新しい場所を確認する ] チェック ボックスをオンにします。

  4. [OK]をクリックし、以前のバージョンのデータベースを参照してダブルクリックします。

    すべてが問題ない場合は、選択したリンク テーブルすべてが正常に更新されたことを示すメッセージが表示されます。

新しいバージョンの Access を使用するユーザー向け新機能をサポートするように、新しいフロントエンド データベースを拡張できます。 以前のバージョンを使用しているユーザーは、引き続き以前のバージョンのデータベースを使用できます。

ページの先頭へ

複数のバージョンの Access でフロントエンド/バック エンド アプリケーションを使用する

Access データベースが既に新しいファイル フロントエンド/バックエンド アプリケーション、フロント エンドを新しいファイル形式に変換できます。 バック エンド データベースに変更を加える必要はありません。

次の手順では、[データベースに名前を付けて保存] コマンドを使用して、フロントエンド データベースを Access 2000、Access 2002-2003、または Access 2007 のいずれかの最新の形式に変換する方法を示します。 このコマンドは、元のデータベースを元の形式で保持し、指定した形式でコピーを作成します。

  1. フロントエンド データベースを閉じます。 ファイルがサーバーまたは共有フォルダーにあるマルチユーザー Access データベースの場合は、他のユーザーが開いていないか確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. フロントエンド データベースの場所を参照し、ダブルクリックして開きます。

    [データベースの 拡張] ダイアログ ボックスが表示され、データベースを拡張するかどうかを確認するメッセージが表示されたら、[いいえ] を クリックします

  5. データベースを開いた際にフォームが表示される場合は、フォームを閉じます。

  6. [ファイル] タブの [データベースに名前を 付けて保存] をクリックします

  7. [名前 を付けて保存 ] ダイアログ ボックスで、新しいデータベースの名前を入力します。

  8. [保存] をクリックします。

新機能をサポートするために、新しいフロントエンド データベースを拡張できます。

ページの先頭へ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×