Microsoft アカウントでサインイン
サインインするか、アカウントを作成します。
こんにちは、
Select a different account.
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

オートコンプリート リストは、名前とメール アドレスの入力を開始するときに候補を表示する機能です。 これらの候補は、送信したメール メッセージの名前とメール アドレスの一覧から一致する可能性があります。 

オートコンプリート リスト

AutoComplete リストをあるコンピューターから別のコンピューターにコピーする方法は、Outlook に追加したメール アカウントの種類によって異なります。 Microsoft 365 アカウント、Exchange Server アカウント、または IMAP アカウントがある場合 (これは他のメール アカウントの最も一般的な種類です)、オートコンプリート リストは Outlook データ ファイルに非表示ファイルとして格納されます。 手順については 、「オートコンプリートの一覧をコピーする」を参照してください。

POP3 アカウントを使用している場合 (あまり一般的ではありませんが、Comcast、Earthlink、Verizon などのサード パーティのメール プロバイダーでよく使用されます)、オートコンプリート リストはコンピューターに保存されているファイルに格納されます。 「.nk2 ファイルをコピーしてインポートする」を参照してください。

持っているアカウントの種類がわからない場合は、[ アカウント 設定]> [ アカウント設定 ] > [ アカウント設定] を選択します。 アカウントの種類については、こちらを参照してください。

オートコンプリートの一覧をコピーする

手順 1: オートコンプリート メールボックス メッセージをエクスポートする

  1. Outlook を終了し、メールボックスに接続されているすべてのワークステーションでOutlook on the webを閉じます。

  2. http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。

  3. mfcmapi.exeを実行します。

  4. [ セッション ] メニューの [ログオン] を選択します。

  5. プロファイルの入力を求められたら、目的のプロファイル名を選択し、[OK] をクリック します

  6. 上部のウィンドウで、メールボックスに対応する行を見つけてダブルクリックします。

  7. 左側のナビゲーション ウィンドウで、[ ルート コンテナー] を展開し、[ 情報ストアの上部 ] または [IPM_SUBTREE] を展開します。

  8. [受信トレイ] フォルダーを右クリックし、[関連付けられたコンテンツ テーブルを開く] を選択します。 このアクションにより、さまざまなプロパティを含む新しい MFCMAPI ウィンドウが開きます。

  9. [ 件名 ] 列で、件名 IPM を含む項目を右クリックします。Configuration.Autocomplete を選択し、[メッセージのエクスポート] を選択します。 このアクションにより、[ メッセージをファイルに保存] ウィンドウが 開きます。

  10. ドロップダウン リストで 、[ MSG ファイル (UNICODE)] を選択し、[OK] を選択します

  11. メッセージを保存するフォルダーの場所を選択し、[保存] を選択します。 この場所に注意してください。

手順 2: AutoComplete メールボックス メッセージをインポートする

  1. Outlook を終了し、メールボックスに接続されているすべてのワークステーションでOutlook on the webを閉じます。

  2. http://mfcmapi.codeplex.com から MFCMAPI をダウンロードしてインストールします。

  3. mfcmapi.exeを実行します。

  4. [ セッション ] メニューの [ログオン] を選択します。

  5. プロファイルの入力を求められたら、目的のプロファイル名を選択し、[OK] をクリック します

  6. 上部のウィンドウで、メールボックスに対応する行を見つけてダブルクリックします。

  7. 左側のナビゲーション ウィンドウで、[ ルート コンテナー] を展開し、[ 情報ストアの上部 ] または [IPM_SUBTREE] を展開します。

  8. [受信トレイ] フォルダーを右クリックし、[関連付けられたコンテンツ テーブルを開く] を選択します。 このアクションにより、さまざまなプロパティを含む新しい MFCMAPI ウィンドウが開きます。

  9. エントリが重複しないようにするには、既存の AutoComplete メッセージを削除する必要があります。

    注: IPM を削除する前 に。Configuration.Autocomplete メッセージは、「自動完了キャッシュをエクスポートする方法」セクションの手順を使用してメッセージをエクスポートする必要があります。

    既存のオートコンプリート メッセージを削除するには、次の手順に従います。

    1. [ 件名 ] 列で、件名 IPM を持つ項目を見つけます。Configuration.Autocomplete

    2. アイテムを右クリックし、[メッセージの削除] を選択します。 [アイテムの 削除 ] ウィンドウが開きます。

    3. ドロップダウン リストで、[ 完全削除] (サポートされている場合は削除済みアイテムの保持に削除) を選択し、[OK] を選択します

  10. [フォルダー] メニューの [ インポート] を選択し、[ メッセージから] を選択します。

  11. 上記の「AutoComplete メールボックス メッセージをエクスポートする」の手順 11 で作成した .msg ファイルを見つけて、[OK] を選択します

  12. 表示された [ メッセージの読み込み ] ウィンドウで、[ 読み込み スタイル] の一覧で [現在のフォルダーにメッセージを 読み込む ] を選択し、[OK] を選択します

オートコンプリート情報は IPM からインポートされます。Configuration.Autocomplete_<16 進コード>.msg。プレースホルダー<16 進コード>は、数字と文字の長い文字列を表します。

.nk2 ファイルをコピーしてインポートする

手順 1: 古いコンピューターからオートコンプリート ファイルをコピーする

  1. 既定のフォルダーは非表示フォルダーであるため、フォルダーを開く最も簡単な方法は、Windows 検索ボックスでコマンド %APPDATA%\Microsoft\Outlook を使用することです (または、C:\Users\username\AppData\Roaming\Microsoft\Outlook を参照します)。

  2. Outlook フォルダーで、オートコンプリート リスト (.nk2) ファイルを見つけます。

    注: 既定で、ファイル拡張子は Windows で表示されません。 ファイルの拡張子を表示するかどうかを変更するには、エクスプローラーの [ツール] メニュー (Windows 7 または Windows Vista の場合は、ALT キーを押して、[ツール] メニューを表示します) で、[フォルダー オプション] をクリックします。 [表示] タブで、[登録されている拡張子は表示しない] チェック ボックスをオンまたはオフにします。

  3. ファイルを新しいコンピューターにコピーします。 ファイルは小さく、USBメモリスティックなどのリムーバブルメディアに配置できます。

手順 2: オートコンプリート ファイルを新しいコンピューターにコピーする

  1. 新しいコンピューターのコントロール パネルで、[メール] を選択またはダブルクリックします。

    メールは、Microsoft Windows オペレーティング システムのバージョン、選択したコントロール パネル ビュー、32 ビットまたは 64 ビットオペレーティング システム、または Outlook 2010 のバージョンに応じて、異なるコントロール パネルの場所に表示されます。

    [メール] を見つけるには、Windows のコントロール パネルを開き、ウィンドウ上部の [検索] ボックスに「メール」と入力する方法が最も簡単です。 Windows XP のコントロール パネルでは、[アドレス] ボックスに「メール」と入力します。

    注: [メール] アイコンは、Outlook を初めて起動した後に表示されます。

  2. [プロファイルの表示] を選択します

  3. プロファイルの名前を書き留めます。 後でこの名前に一致するように .nk2 ファイルの名前を変更する必要があります。

  4. .nk2 ファイルを、Outlook 構成が保存されているフォルダー内の新しいコンピューターにコピーします。 既定のフォルダーは非表示フォルダーであるため、フォルダーを開く最も簡単な方法は、Windows 検索ボックスでコマンド %APPDATA%\Microsoft\Outlook を使用することです (または、C:\Users\username\AppData\Roaming\Microsoft\Outlook を参照します)。

  5. ファイルがフォルダーにコピーされたら、ファイルを右クリックし、[ 名前の変更] をクリックし、手順 3 で示したプロファイル名と一致するように名前を変更します。

手順 3: オートコンプリート リストをインポートする

これで、Outlook を起動してファイルをインポートする準備が整いましたが、特別な 1 回限りのコマンドで Outlook を起動する必要があります。

  • Windows 検索ボックスに「outlook /importnk2」と入力し、Enter キーを押します。

メッセージを作成し、[宛先]、[Cc]、または [Bcc] ボックスに入力を開始すると、オートコンプリート リストに他のコンピューターのエントリが表示されるようになります。

ページの先頭へ

Outlook 2007 では、オートコンプリート リストの名前とメール アドレスをコンピューター間でコピーできます。 たとえば、新しいコンピューターにアップグレードしていて、オートコンプリート リストに格納されているすべての情報を失いたくない場合は、古いコンピューターから新しいコンピューターに名前とメール アドレスをコピーできます。

重要: 次の手順を開始する前に、 Microsoft Outlook を終了する必要があります。 Outlook を再起動すると、オートコンプリート リストに名前が含まれます。

古いコンピューターからオートコンプリート ファイルをコピーする

  1. 古いコンピューターで、drive:\user\AppData\Local\Microsoft\Outlook に移動します。

    注: ファイルの設定によっては、このフォルダーが非表示になっている可能性があります。

  2. プロファイル名.nk2 を右クリックし、[ コピー] をクリックします。

    ヒント: USB メディア スティックなどのリムーバブル メディアにファイルをコピーし、新しいコンピューター上の正しい場所にファイルをコピーできます。 または、ファイルを電子メール メッセージに添付し、自分にメッセージを送信することもできます。 新しいコンピューターで、Outlook で添付ファイルを開き、正しい場所に保存します。

  3. オートコンプリート リストを設定するコンピューターで、ドライブ内の任意の場所:\user\AppData\Local\Microsoft\Outlook を右クリックし、[貼り付け] をクリックしてプロファイル名.nk2 を保存します。

  4. .nk2 ファイルを移動するコンピューターで Outlook ユーザー プロファイル名が異なる場合は、ファイルを正しいフォルダーにコピーした後、新しいコンピューターで使用されている Outlook ユーザー プロファイル名でファイルの名前を変更する必要があります。 たとえば、元のコンピューターから Kim Akers.nk2 を Outlook ユーザー プロファイル名の Kim Akers から移動し、Kim Akers.nk2 ファイルを新しいコンピューターにコピーする場合は、新しいコンピューターで使用されている Outlook プロファイル名でファイルの名前を変更する必要があります。

  5. 既存のファイルの置き換えについてメッセージが表示されたら、[ はい] をクリックします。

  6. Outlook を開き、オートコンプリート リストへの変更を表示します。

ページの先頭へ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Office Insider に参加

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

ご意見をいただきありがとうございます。

×