ダッシュボードは、主要なメトリックを視覚的に表現したグラフで、データをすばやく 1 か所で表示および分析できます。 ダッシュボードは、統合されたデータ ビューを提供するだけでなく、セルフサービスのビジネス インテリジェンスの機会を提供します。この機会に、ユーザーはデータをフィルター処理して重要な情報だけを表示できます。 多くの場合、Excelレポートでは、ニーズに応じて異なるユーザーまたは部門に対して複数のレポートを生成する必要がありました。

Excel ダッシュボードのスライサーとタイムラインの例

概要

このトピックでは、複数のピボットテーブル、ピボットグラフ、ピボットテーブル ツールを使用して動的ダッシュボードを作成する方法について説明します。 次に、スライサーとタイムラインを使用してデータを簡単にフィルター処理する機能をユーザーに提供します。この機能を使用すると、ピボットテーブルとグラフを自動的に拡張および契約して、ユーザーが表示したい情報のみを表示できます。 さらに、データを追加または更新するときに、ダッシュボードをすばやく更新できます。 これにより、ダッシュボード レポートを作成する必要があるのが 1 回だけなので、非常に便利です。

例として、1 つのデータ ソースから 4 つのピボットテーブルとピボットグラフを作成します。

ダッシュボードを作成したら、Microsoft グループを作成して、ダッシュボードを他のユーザーと共有する方法を説明します。 また、対話型のExcelブックをダウンロードして、独自の手順に従って操作することもできます。

Excel ダッシュボードのチュートリアル ブックをダウンロードする。

データを取得する

  1. データをコピーして直接コピーして Excelするか、データ ソースからクエリを設定できます。 このトピックでは、Microsoft AccessのNorthwind Tradersテンプレートから Sales Analysis クエリを使用しました。 使用する場合は、Access を開き、[ファイル] > [新規>検索] で "Northwind" を検索し、テンプレート データベースを作成します。 完了すると、テンプレートに含まれるクエリにアクセスできます。 このデータは既に Excel ブックに挿入済みなので、Access を使用していない場合でも心配する必要はありません。

  2. データの構造が正しいこと、行や列に不足がないことを確認してください。 各行が個別のレコードまたは項目を表しているはずです。 クエリの設定方法またはデータの操作方法については、「Excel 2016 で取得と変換を実行する」を参照してください。

    ピボットテーブルのデータ ソースとして使用する、Excel の表のサンプル データ
  3. データが Excel の表として書式設定されていない場合は、書式設定します。 Access からインポートすると、データは表に自動的にインポートされます。

ピボットテーブルを作成する

  1. データ範囲内のセルを選択し、[挿入]、[ピボットテーブル]、[ワークシート] の順に進みます。 詳細については、「ピボットテーブルを作成してワークシート データを分析する」を参照してください。

  2. 必要なピボットテーブル フィールドを追加し、必要に応じて書式設定します。 このピボットテーブルは他のピボットテーブルの基礎になります。そのため、スタイル、レポートのレイアウト、一般的な書式設定に必要な調整を行うのに少し時間を費やす必要があります。そのため、複数回行う必要はありません。 詳細については、「ピボットテーブルの レイアウトと形式を設計する」を参照してください

    今回のサンプルでは、売上を製品カテゴリ別にまとめています。売上フィールドを降順に並べています。

    カテゴリ、売上、合計 (%) からなるピボットテーブルのサンプル

    詳細については、「ピボット テーブルまたはピボット グラフのデータを並べ替える」を参照してください。

  3. マスター ピボットテーブルを作成したら、それを選択し、ワークシート内の空白領域に必要な回数だけコピーして貼り付けます。 この例では、これらのピボットテーブルは行を変更できますが、列は変更できないので、各ピボットテーブルの間に空白の列がある同じ行に配置します。 ただし、列を展開できる場合は、ピボットテーブルを互いに下に配置する必要がある場合があります。

    重要: ピボットテーブルを部分的に重ねることはできません。そのため、値のフィルター処理、追加、削除に合わせて拡大/縮小できるようにデザインに十分な余白を与えてください。

    この時点で、その機能がわかるようにピボットテーブルに意味のある名前を与えておくと便利です。 名前を付けない場合、PivotTable1、PivotTable2 のような名前が自動的に付けられます。 ピボットテーブルを選択し、[ピボットテーブル ツール]、[分析] の順に進み、[ピボットテーブル名] ボックスで新しい名前を入力できます。 分かりやすい名前があることは、ピボットテーブルをスライサー コントロールやタイムライン コントロールに接続するときに重要になります。

    [ピボットテーブル ツール]、[分析]、[ピボットテーブル名] ボックスでピボットテーブルの名前を変更する

ピボットグラフを作成する

  1. 最初のピボットテーブル内の任意の場所をクリックし、[ピボットテーブル ツール] >分析] >ピボットグラフ>グラフの種類を選択します。 [売上] が [クラスター化縦棒グラフ] の [複合グラフ] と [合計率] が [第 2 軸] にプロットされた線グラフとして選択されました。

    グラフの選択ダイアログで集合縦棒と折れ線の複合グラフを選択する
  2. [ピボットグラフ ツール] タブからグラフを選択し、任意でサイズや書式設定を選択します。 詳細については、グラフの書式設定に関する動画シリーズをご覧ください。

  3. 残りのピボットテーブルにも同じ作業を繰り返します。

  4. ここで、ピボットグラフの名前を変更しておくこともお勧めします。 [ピボットグラフ ツール]、[分析] の順に進み、[グラフ名] ボックスに新しい名前を入力します。

スライサーとタイムラインを追加する

スライサーとタイムラインを利用すると、ピボットテーブルやピボットグラフを簡単にフィルター処理できます。自分にとって意味のある情報だけを表示できます。

ダッシュボードのスライサー/タイムライン コントロールの展開ビュー
  1. ピボットテーブルを選択し、[ピボットテーブル ツール] >分析>フィルター > スライサーの挿入] に移動し、スライサーに使用する各項目を確認します。 このダッシュボードでは、[カテゴリ]、[製品名]、[従業員]、および [顧客名] を選択しました。 [OK] をクリックすると、スライサーが画面の中央に追加され、互いに重なって表示されます。そのため、必要に応じて、スライサーの配置とサイズ変更を行う必要があります。

    [ピボットテーブル ツール]、[分析]、[フィルター] の [スライサーの挿入] オプション
  2. スライサー オプション– スライサーをクリックすると、[スライサーツール] >オプション] に移動し、[スタイル] や表示される列数など、さまざまなオプションを選択できます。 複数のスライサーを配置するには、Ctrlキーを押しながら左クリックして選択し、[スライサー ツール] タブの [配置] ツールを使用します。

  3. ライサー接続 - スライサーは作成に使用したピボットテーブルにのみ接続されます。そのため、各スライサーを選択してから、[スライサーツール] > オプション>レポート接続] に移動し、それぞれに接続するピボットテーブルを確認する必要があります。 スライサーとタイムラインは、ワークシートが非表示の場合でも、任意のワークシートのピボットテーブルを制御できます。

    [スライサー ツール]、[オプション] のスライサー レポート接続
  4. タイムラインの追加 - ピボットテーブルを選択し、[ピボットテーブル ツール]、[分析]、[フィルター]、[タイムラインの挿入] の順に進み、使用する項目にチェックを入れます。 今回のダッシュボードでは、注文日を選択しました。

  5. タイムラインのオプション - タイムラインをクリックし、[タイムライン ツール]、[オプション] の順に選択し、[スタイル]、[ヘッダー]、[キャプション] などのオプションを選択します。 [レポートの接続] オプションを選択すると、選択したピボットテーブルにタイムラインがリンクされます。

スライサー コントロールの詳細はこちらで、タイムライン コントロールの詳細はこちらで確認できます。

次の手順

ダッシュボードは機能的に完了しましたが、必要に応じて調整し、最終的な調整を行う必要がある可能性があります。 たとえば、レポートのタイトルや背景を追加できます。 ダッシュボードでは、ピボットテーブルの周りに図形を追加し、[表示] タブの [見出し] と [枠線] をオフにしました。

各スライサーとタイムラインをテストして、ピボットテーブルとピボットグラフが適切に動作することを確認してください。 ピボットテーブルが別のピボットテーブルを調整して重なり合う必要がある場合、特定の選択で問題が発生する場合があります。この場合、エラー メッセージが表示されます。 これらの問題は、ダッシュボードを配布する前に修正する必要があります。

ダッシュボードの設定が完了したら、このトピックの一番上にある “ダッシュボードの共有” タブをクリックすると、配布方法を確認できます。

ダッシュボードを作成して、おめでとうございます。 この手順では、ダッシュボードを共有する Microsoft グループを設定する方法について説明します。 ユーザーがいつでも簡単にアクセスできるよう、ダッシュボードを SharePoint のグループのドキュメント ライブラリの上部にピン留めします。

注: グループをまだ用意していない場合、「Outlook でグループを作成する」を参照してください。

グループにダッシュボードを保存する

ダッシュボード ブックをグループにまだ保存していない場合、そこに移動します。 グループのファイル ライブラリに既に入っている場合、この手順は省略できます。

  1. Outlook 2016 または Outlook on the web のグループに移動します。

  2. リボンの [ファイル] をクリックし、グループのドキュメント ライブラリにアクセスします。

  3. リボンの [アップロード] ボタンをクリックし、ダッシュボード ブックをドキュメント ライブラリにアップロードします。

グループの SharePoint Online チーム サイトに追加する

  1. Outlook 2016 からドキュメント ライブラリにアクセスした場合、左のナビゲーション ウィンドウの [ホーム] をクリックします。 Outlook on the web からドキュメント ライブラリにアクセスした場合、リボンの右端から [その他]、[サイト] の順にクリックします。

  2. 左のナビゲーション ウィンドウの [ドキュメント] をクリックします。

  3. ダッシュボード ブックを見つけ、その名前の左にある円形の選択ボックスをクリックします。

  4. ダッシュボード ブックが選択されたら、リボンの [先頭にピン留め] を選択します。

ファイルを選択して [ピン留めする] をクリックし、ドキュメント ライブラリで簡単にアクセスできるようにする

これで、SharePoint Online チーム サイトのドキュメント ページにユーザーがアクセスするたびに、ドキュメント ワークシートが一番上に表示されます。 ユーザーはそれをクリックし、現行バージョンのダッシュボードに簡単にアクセスできます。

ヒント: ユーザーは Outlook Groups モバイル アプリ経由で、ダッシュボード ブックを含む、グループ ドキュメント ライブラリにアクセスすることもできます。

関連項目

このページで回答されていない質問はありますか?

Microsoft Answers コミュニティにアクセスしてください。

ご意見をお待ちしています。

この記事は 、2017 年 3 月 16 日に Ben と Chris によってフィードバックの結果として最後にレビューされました。 役に立った場合、特に役に立たなかった場合は、以下のフィードバック コントロールを使用し、建設的なフィードバックをお寄せください。引き続き改善に取りかかることができます。 よろしくお願いいたします。

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Office Insider に参加

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

ご意見をいただきありがとうございます。

×