Microsoft Project Online デスクトップクライアントでタスクボードを使用する

Project Online のサブスクライバーである場合は、Project Online デスクトップクライアントで、より機敏な方法でプロジェクトを操作できます。 プロジェクトを管理するために、プロジェクトを管理するためにかんばんを使用してスクラム方法を使用している場合は、Project Online デスクトップクライアントを使用すると、プロジェクトのタスクボードビューを使用し、スプリントベースのプロジェクトを作成する機能を通じて、プロジェクトの作成と管理を使い慣れた方法で行うことができます。

重要: 

  • この記事で説明する機能は、Project Online サブスクリプションで利用できる Project のバージョンでのみ使用できます。 使用している Project のバージョンを確認するには、Project を開き、[ファイル]、[アカウント] の順に選択します。 [製品情報] の下に、次のようなサブスクリプションバージョンが表示されます。 サブスクリプション製品名のスクリーンショットProject の [ファイル] の [アカウント​​] セクションに表示されている、Microsoft Project Online デスクトップ クライアント。

  • さらに、一部の機能は、 Microsoft 365 の対象指定リリースオプションを設定した組織に段階的に導入されています。 つまり、このような機能は、まだ表示されなかったり、ヘルプ記事に記載されている内容と異なったりする場合があります。

この記事では、次の方法について説明します。

タスクボードでプロジェクトを表示する

ボードなどのかんばん機能を使用してプロジェクトを操作する場合、Project では、既存の従来の "ウォーターフォール" プロジェクトをタスクボードビューで表示および管理できます。

タスクボードでプロジェクトを表示するには、次の操作を行います。   

  • プロジェクトを開き、[表示] タブの [タスクビュー ] セクションで、[タスクボード] を選択します。

    [表示] リボンのタスクボード

    プロジェクトタスクは、[タスクボード] ビューではボードとして表示されます。

    タスクボードビュー

注: タスクボードビューでプロジェクトタスクを表示するには、[タスクの[ボードに表示] の設定を[はい] (既定の設定) に設定する必要があります。

タスクの [ボード上に表示] の設定を変更するには、次の操作を行います。   

  1. [ガントチャート] ビューでプロジェクトを開きます。

  2. プロジェクトのガントチャートで、[新しい列の追加] を選択します。

  3. リストから、[掲示板に表示] を選びます。

    タスクの掲示板の設定を表示する
  4. [ボード上に表示] 列には、各タスクの値 ([はい]または [いいえ]) が表示されます。

  5. 設定を変更するには、タスクの値をクリックして、変更後の値を選択します。

  6. 変更内容を保存します。

タスクボードカードに詳細情報を追加する

タスクが [タスクボード] ビューに表示されている場合、タスク "カード" は既定で、タスク名 (リソースが割り当てられているリソース) と共にいくつかの基本フィールドを表示し、タスクが完了した場合はチェックマークを付けます。 [タスクボードカードのカスタマイズ] 機能を使用して、プロジェクトのタスクカード (ユーザー設定フィールド情報など) に詳細情報を提供できます。 これにより、各タスクカードに最大5つのユーザー設定フィールドの情報を表示したり、表示される [基準フィールド] を選択したりすることができます。

プロジェクトのタスクカードをカスタマイズするには、次の操作を行います。   

  1. [書式] タブを選択し、[カードのカスタマイズ] を選択します。

    カードをカスタマイズする
  2. [タスクボードカードのカスタマイズ] ページの [基準フィールド] セクションで、表示する [基準フィールド] を選択します。

  3. [追加フィールド] セクションで、ドロップダウンメニューをクリックし、表示するユーザー設定フィールドを選択します。 最大5つのカスタムフィールドを選ぶことができます。

    カード構成の設定をカスタマイズする
  4. [OK] をクリックします。

    これで、選択したフィールドを含むプロジェクト表示のすべてのタスクカードが表示されます。

    カスタマイズされたタスクカード。

注: カードのカスタマイズ設定は、それらが設定されたプロジェクトに固有です。 他のプロジェクトで同じカスタマイズを表示する必要がある場合は、それらのプロジェクトにもそれらを設定する必要があります。

既存のプロジェクトにスプリントを追加する

タスクボードを通じてプロジェクトを表示および管理できるようになったため、Project でもスプリントを追加できます。 プロジェクトにさらにスプリントを追加した後、[スプリント] タブに追加のスプリント機能が表示されます。

プロジェクトにスプリントを追加するには、次の操作を行います。

  1. [プロジェクト] タブで、[スプリントの管理] を選択します。

    [スプリントの管理] ボタン
  2. [スプリントの管理] ページで、最初のスプリントが既定で追加されます。 スプリント1に用意されている長さ開始情報を編集できます。

    • [長さ]: スプリントの期間。

    • [開始日: スプリントが開始された日付。

  3. [スプリントの追加] セクションで、追加する追加のスプリントの情報を指定します。

    • スプリントの開始: 追加するスプリントの開始日です。

    • Duration: スプリント (1 週間など) の時間の長さ。

  4. [スプリントの追加] を選びます。 これにより、プロジェクトに追加のスプリントが追加されます。

    スプリントの管理
  5. すべてのスプリントを追加したら、[ OK]を選択します。

追加のスプリントをプロジェクトに追加すると、リボンに [スプリント] タブが表示され、プロジェクトのスプリント機能を管理することができます。 これらの機能を使用する方法については、「スプリントを使用してプロジェクトを計画する」セクションを参照してください。

[スプリント] タブ

新しいスプリントプロジェクトを作成する

既存のプロジェクトにスプリントを追加するだけでなく、スプリントプロジェクトテンプレートから新しいスプリントベースのプロジェクトを作成することもできます。

新しいスプリントプロジェクトを作成するには、次の操作を行います。

  1. [ファイル] メニューの [新規] を選択し、[お勧めのテンプレート] で [スプリントプロジェクト] を選択します。

    スプリントプロジェクトテンプレート
  2. スプリント計画の掲示板が表示され、プロジェクトタスクを追加して、別のスプリントサイクルに移動することができます。

    スプリント計画掲示板

スプリントを使用してプロジェクトを計画する

プロジェクトでスプリントを使用してプロジェクトを実行するには、最初にタスクをプロジェクトに追加してから、タスクをスプリントに割り当てる必要があります。タスクをオンにして完了したら、ボード全体でタスクを移動します。 さらに、スプリントビューを使用して、特定のスプリントに割り当てられているタスクを表示することができます。

[ガントチャート] ビューでは、すべてのアジャイルタスクを表示して、従来のウォーターフォール方式とスプリントを使ってそれらを管理することができます。 また、スプリントを使って、従来のプロジェクトのサブセットのみを実行することもできます。 「ガントチャートでタスクをスプリントで管理する」を参照してください。

プロジェクトにタスクを追加する

新しいタスクをスプリントプロジェクトに追加する最も簡単な方法は、次のとおりです。

  • タスクボードビュー: タスクボードビューで [新しいタスク] を選択すると、新しいタスクが作成されます。

  • ガントチャートビュー: [ガントチャート] ビューで追加したタスクは、タスクボードにも追加されます。

  • タスクボードシートビュー: 同様に、タスクボードシートビューを使って新しいタスクを追加できます。

上記の各方法により、タスクボードの [開始] 列に新しいタスクが追加されます。

未開始タスク

タスクをスプリントに割り当てる

プロジェクトのタスクリストを作成したら、タスクを完了するタイミングに応じて、これらのタスクをスプリントに並べ替えます。 最初に、スプリントの長さと日付を定義する必要があります。その後、タスクを特定のスプリントに移動することができます。

スプリントの長さと日付を定義するには   

  1. [スプリントの管理] ページにアクセスするには、次のいずれかの操作を行います。

    • [スプリント] タブで [管理] を選びます。

    • [プロジェクト] タブの [プロパティ] グループで、[スプリントの管理] を選択します。

  2. [スプリントの管理] ページで、最初のスプリントが既定で追加されます。 スプリント1に用意されている長さ開始情報を編集できます。

    • [長さ]: スプリントの期間。

    • [開始日: スプリントが開始された日付。

  3. [スプリントの追加] セクションで、追加する追加のスプリントの情報を指定します。

    • スプリントの開始: 追加するスプリントの開始日です。

    • Duration: スプリント (1 週間など) の時間の長さ。

  4. [スプリントの追加] を選びます。 これにより、プロジェクトに追加のスプリントが追加されます。

    スプリントの管理

タスクを特定のスプリントに移動するには   

  1. [スプリント] タブの [表示] グループで、[計画]、[スプリント計画掲示板] の順に選択します。

  2. [スプリント計画の掲示板] で、[スプリントがありません] 列から、タスクを達成したいスプリントにそのタスクをドラッグします。

    タスクをスプリントに移動する。

ヒント: シート ビューでは、[スプリント] 列の内容を変更することで、スプリントにタスクを割り当てることもできます。 シート ビューに移動するには

  1. ボードビューの場合は、[書式] タブを選択します。

  2. [表示] グループで、[シート] を選択します。

ボード間でタスクを移動する

チームは、特定のスプリント内のタスクに対して作業を行うため、タスクボード間でタスクを移動して、完了までの進捗状況を追跡することができます。

  1. 現在のスプリントボードのビューに移動するには、次のいずれかの操作を行います。

    • [スプリント] タブの [ビュー ] グループで、[スプリント]、[現在のスプリントボード] の順に選択します。

    • [表示] タブの [タスクビュー ] グループで、[タスクボード]、[その他のビュー ] の順に選択し、[現在のスプリントボード] を選択します。

  2. Project には、3 つの列 ([次のタスク]、[進行中]、[完了]) が用意されており、これらを使用して作業を開始します。

    現在のスプリントボード

    • 列の名前を変更するには、列名を右クリックして [名前の変更] を選択し、新しい名前を入力して、Enter キーを押します。

    • 最後の列の右側に列を追加するには、[新しい列の追加] を選択し、名前を入力して、Enter キーを押します。

  3. タスクをその状態と一致する列にドラッグ アンド ドロップします。

    現在のスプリントボードのタスクを移動する。

ヒント: シート ビューでは、[ボードの状態] 列の内容を変更することで、タスクの状態を変更することもできます。 シート ビューに移動するには

  • [スプリント] タブの [表示] グループで、[スプリント]、[現在のスプリントのシート] の順に選択します。

  • [表示] タブの [タスクビュー ] グループで [タスクボード] を選択し、[タスクボードシート] を選択します。

特定のスプリントに割り当てられているタスクを表示する

[スプリント] タブで使用可能なタスクボードビューを使用して、特定のスプリントに割り当てられているすべてのタスクを表示できます。

スプリントビュー
  1. [スプリント] タブを選択して、[スプリント] リボンを表示します。

  2. リボンの [スプリント] を選択し、ドロップダウンから、表示する特定のスプリントを選択します。

    たとえば、[スプリント 2] を選択すると、その特定のスプリントのタスクがスプリントボードに表示されます。

    特定のスプリントのスプリントボードビュー

[スプリントなし] を選択して、スプリントに割り当てられていないタスクを表示することもできます。

ガント チャートでアジャイル タスクを管理する

一方のビューに影響を与えずに、従来のウォーターフォールビューとタスクボードでプロジェクトタスクを同時に管理できます。 [タスクボード] ビューでは、タスクに情報が追加されますが、ガントチャートタスクの詳細は表示されません。 タスクボードビューにはすべてのタスクの詳細は表示されませんが、他のプロジェクトビューには残ります。

タスクボードのビューに表示されるタスクを制限することができます。たとえば、大規模なプロジェクトを使用していて、スプリントを使って小さな部分だけを追跡する場合などです。

タスクボードのビューに表示されるタスクを管理するには、次の操作を行います。   

  1. [タスク] リボンで、[ガント チャート] を選択します。

  2. チャートで最後の列を選択します ([新しい列の追加])。

  3. [列] リストで、[ボードに表示] を選びます。

  4. この列では、自動的にすべてのタスクが [はい] に設定されます。 アジャイルビューからタスクを削除するには、[ボードの列]の値を [いいえ] に変更します。 このタスクは [タスクボード] ビューに表示されなくなります。

    [ボードに表示] の設定

タスクボードレポートを取得する

Project には、タスク、作業、スプリントの状態に関する組み込みのタスクボードレポートが用意されています。

タスクボードレポートを見つけるには、次の操作を行います。    

  1. [レポート] リボンの [レポートの表示] セクションで、[タスクボード] を選択します。

  2. レポートを選択します。

    これらのレポートの 1 つの例を以下に示します。

    Project の [現在のスプリント - 作業の状態] レポートのスクリーンショット

注:  このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 情報が役に立ったかどうか、ご意見をお寄せください。 参考までに、こちらから英語の記事をお読みいただけます。

お時間を最大限に活用するためのサブスクリプション

ヘルプを表示

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×