Set-SendConnector は、Edge Server がインストールされているハイブリッド シナリオのExchange Serverでは機能しません

適用先
Exchange Server 2019 Exchange Server 2016

現象

Microsoft Exchange Server 2019 用の累積的な更新プログラム 3 または Exchange Server 2019 用の累積的な更新プログラム 2 を、エッジ サーバーがインストールされているハイブリッド環境にインストールすることを想定しています。 それぞれの送信コネクタ用に証明書が構成されている場合、 Set-SendConnector コマンドレットが機能せず、次のエラー メッセージが表示されます。
"PowerShell failed to invoke 'Set-SendConnector': Error 0x5 (Access is denied) from cli_GetCertificate"

または

"cli_GetCertificateからのエラー 0x6ba (RPC サーバーを利用できません)"

この問題は、Exchange Server 2016 用の累積的な更新プログラム 14 または Exchange Server 2016用の累積的な更新プログラム 13 をインストールした後にも発生します。

原因

この問題は、RPC 通信がエッジ サーバーに対してブロックされるため、TLS 証明書チェック (TlsCertificateName 属性が送信コネクタで設定されている場合) がエッジ サーバーに対して機能しないために発生します。

解決策

この問題を解決するには、次のいずれかの更新プログラムをインストールします。

Exchange Server 2019 の場合は、Exchange Server 2019 用の累積的な更新プログラム 4 またはそれ以降の Exchange Server 2019 の累積的な更新プログラムをインストールします。

Exchange Server 2016 の場合は、Exchange Server 2016 用の累積的な更新プログラム 15 またはそれ以降の Exchange Server 2016 の累積的な更新プログラムをインストールします。

回避策

ハイブリッド構成ウィザード (HCW) は、「Office 365 への送信」送信コネクタが存在しない場合でも正常に作成できます。 これは、 New-SendConnector コマンドレットが問題なく使用できるためです。

作成後に (Set-SendConnector コマンドレットを使用して) "Office 365 への送信" 送信コネクタをそれ以上変更することはできません。 ただし、「Office 365 への送信」送信コネクタは、必要な構成を使用して削除して再作成できます。

参考資料

マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。

詳細情報

Microsoft はこの問題を認識しており、詳細については、利用可能になり次第、この記事に掲載する予定です。