マイクロソフトでは、Microsoft SQL Server 2008 の修正を 1 つのダウンロード可能なファイルとして配布しています。 修正は累積的であるため、新しいリリースの修正には、以前のリリースの SQL Server 2008 の修正に含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれます。
現象
Microsoft SQL Server 2008 クラスター環境では、サーバーの負荷が高いと、SQL Server サービスが停止するまでに長い時間がかかります。 さらに、サービスの状態が "保留中の停止" に変更され、SQL Server サービスを再起動できなくなります。 また、次のようなエラー メッセージが Windows クラスター ログに記録されます。
注
[RES]SQL Server <SQL Server (SQL1)>: [sqsrvres] SvcStop: 最初の停止信号をサービスに送信しています。
[RHS]RhsCall::D eadlockMonitor: リソース 'SQL Server (SQL1)' に対する TERMINATERESOURCE の呼び出しがタイムアウトしました。
[RHS]リソース SQL Server (SQL1) のデッドロックの処理。 電流動作のクリーニングとRHSプロセスの終了
00001858.00003154::Date Time 警告 [RHS] リソース SQL Server IsAlive は障害を示しました。
00001bfc.000041a4::Date Time INFO [RCM] HandleMonitorReply: FAILURENOTIFICATION for 'SQL Server', gen(0) result 1.
00001bfc.000041a4::Date Time INFO [RCM] TransitionToState(SQL Server) Online-->ProcessingFailure.
00001bfc.000069d8::Date Time ERR [RCM] rcm::RcmResource::HandleFailure: (SQL Server)
00001bfc.000069d8::Date Time INFO [RCM] resource SQL Server: 失敗数: 1、restartAction: 2.
00001bfc.000069d8::Date Time INFO [RCM] 500 ミリ秒でリソースを再起動します。
00001bfc.000069d8::Date Time INFO [RCM] TransitionToState(SQL Server) ProcessingFailure-->[Terminating to DelayRestartingResource].
00001bfc.000069d8::Date Time INFO [RCM] rcm::RcmGroup::P rocessStateChange: (SQL Server (MSSQLSERVER), Online --> Pending)
00001bfc.000069d8::Date Time INFO [RCM] TransitionToState(SQL Server エージェント) Online-->[Terminating to OnlineCallIssued].
00001bfc.000087fc::Date Time INFO [RCM] リソース 'SQL Server エージェント' を再起動しています。
00001858.00008f58::Date Time ERR [RES] SQL Server <SQL Server>: [sqsrvres] CheckQueryProcessorAlive: sqlexecdirect failed
00001858.00008f58::Date Time ERR [RES] SQL Server <SQL Server>: [sqsrvres] printODBCError: sqlstate = HYT00; native error = 0; message = .....
00001858.00008f58::Date Time INFO [RES] SQL Server <SQL Server>: [sqsrvres] OnlineThread: QP の待機中に終了するように要求されました。
00001858.00001924::Date Time ERR [RHS] RhsCall::D eadlockMonitor: リソース 'SQL Server' の TERMINATERESOURCE がタイムアウトしました。
00001858.00001924::Date Time ERR [RHS] リソース SQL Server がデッドロックを処理しています。 電流運転のクリーニングとRHSプロセスの終了
00001bfc.0000e7dc::Date Time INFO [RCM] HandleMonitorReply: FAILURENOTIFICATION for 'SQL Server', gen(1) result 4.
00001bfc.0000e7dc::Date Time INFO [RCM] rcm::RcmResource::HandleMonitorReply: リソース 'SQL Server' の連続エラー回数 1。
00001bfc.0000e7dc::Date Time ERR [RCM] rcm::RcmMonitor::RecoverProcess: モニター プロセス 0x1858の回復中。
00001bfc.0000e7dc::Date Time INFO [RCM] Created monitor process 28164 / 0x6e04
00006e04.0000e8a4::Date Time INFO [RHS] Initializing.
00001bfc.0000e7dc::Date Time INFO [RCM] rcm::RcmResource::ReattachToMonitorProcess: (SQL Server, [DelayRestartingResource への終了])
00001bfc.0000e7dc::Date Time INFO [RCM] TransitionToState(SQL Server) initializing-->OpenCallIssued.
00001bfc.00004878::Date Time INFO [RCM] TransitionToState(SQL Server) [Terminating to DelayRestartingResource]-->DelayRestartingResource.
00001bfc.00004878::Date Time INFO [RCM] SQL Server と待機中の依存関係の遅延再起動。
00001bfc.00004878::Date Time INFO [RCM] TransitionToState(SQL Server) DelayRestartingResource-->OnlineCallIssued.
00001bfc.0000e7dc::Date Time INFO [RCM] HandleMonitorReply: ONLINERESOURCE for 'SQL Server', gen(1) result 997.
00001bfc.0000e7dc::Date Time INFO [RCM] TransitionToState(SQL Server) OnlineCallIssued-->OnlinePending.
00006e04.00003478::Date Time INFO [RHS] リソース SQL Server がオンラインになりました。 RHS は RCM にステータス変更を報告しようとしています
原因
クラスタ サービスが SQL Server サービスの状態を確認すると、クラスタ サービスは IsAlive クエリを実行します。 IsAlive クエリがタイムアウトすると、クラスター サービスは、SQL Server リソースの .dll ファイルをホストする Rhs.exe プロセスをリサイクルします。 SQL Server リソースの .dll ファイルは、SQL Server シャットダウン プロセスを開始します。 SQL Server シャットダウン プロセスが DeadlockTimeout プロパティで指定された時間を超えると、サービスは停止できず、状態は「保留中の停止」になります。このサービスの状態により、SQL Server サービスは再起動できません。
解決策
SQL Server 2008 のリリース バージョン
重要: リリース版の SQL Server 2008 を実行している場合は、この修正プログラムをインストールする必要があります。
この問題の修正プログラムは、累積的な更新プログラム 7 で最初にリリースされました。 SQL Server 2008用のこの累積的な更新プログラムパッケージを入手する方法の詳細についてはをクリックして以下「サポート技術情報」(Microsoft サポート技術情報)資料を参照。
973601 SQL Server 2008 の累積的な更新プログラム パッケージ 7 注: ビルドは累積的であるため、新しくリリースされた修正プログラムには、以前の SQL Server 2008 更新プログラム リリースに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています。 この修正プログラムが含まれている最新リリースの修正の適用を検討することを推奨します。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
956909 SQL Server 2008 のリリース以降にリリースされた SQL Server 2008 のビルド
SQL Server 2008 Service Pack 1
重要: SQL Server 2008 Service Pack 1 を実行している場合は、この修正プログラムをインストールする必要があります。
この問題の修正プログラムは、SQL Server 2008 Service Pack 1 の累積的な更新プログラム 5 で最初にリリースされました。 この累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
975977 SQL Server 2008 Service Pack 1 の累積的な更新プログラム パッケージ 5 注: ビルドは累積的であるため、新しい修正プログラムの各リリースには、以前の SQL Server 2008 更新プログラムのリリースに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています。 マイクロソフトでは、この修正プログラムを含む最新の修正プログラム リリースを適用することを検討することをお勧めします。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
970365 SQL Server 2008 Service Pack 1 以降にリリースされた SQL Server 2008 ビルド
Microsoft SQL Server 2008 の修正プログラムは、特定の SQL Server Service Pack 用に作成されます。 SQL Server 2008 Service Pack 1 のインストールには、SQL Server 2008 Service Pack 1 修正プログラムを適用する必要があります。 既定では、1 つの SQL Server Service Pack で提供されているすべての修正プログラムは、次の SQL Server Service Pack に含まれています。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
PendingTimeout プロパティの詳細については、次の MSDN (Microsoft Developer Network) Web サイトを参照してください。
https://msdn.microsoft.com/library/aa372194(vs.85).aspx
DeadlockTimeout プロパティの詳細については、次の MSDN (Microsoft Developer Network) Web サイトを参照してください。
https://msdn.microsoft.com/library/bb309217(vs.85).aspx
SQL Server の増分サービス モデルの関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
935897 報告された問題に対する修正プログラムを提供する SQL Server チームの増分サービス モデル (ISM) について
SQL Server の更新プログラムの命名方式の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
822499 Microsoft SQL Server ソフトウェア更新プログラム パッケージの新しい名前付けスキーマ
ソフトウェア更新プログラムに関する用語の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
824684 Microsoft のソフトウェア更新プログラムの説明で使用される一般的な用語の解説