現象
スナップショット バックアップのためにサーバーを中断するために ALTER SERVER CONFIGURATION を実行すると、エラーの発生後にデータベースが正しくない中断状態になっていることがあります。 スナップショット バックアップのためにサーバーを一時停止するときに発生するエラーは、次のエラーに類似しています。
メッセージ 9018、レベル 16、状態 1、行 <行番号>
データベース <DatabaseName> のログでは、ユーザーの書き込みは許可されません。メッセージ 5901、レベル 16、状態 1、行 <行番号>
データベース <DatabaseName> に属する 1 つ以上の復旧ユニットがチェックポイントを生成できませんでした。 これは通常、ディスクやメモリなどのシステム リソースの不足、または場合によってはデータベースの破損が原因で発生します。 このエラーの詳細については、エラー ログ内の以前のエントリを調べてください。
このエラーが発生すると、サーバー上の中断されたデータベース数に 0 が表示されますが、すべてのデータベースが正しく中断が解除されるわけではありません。
この状況では、ALTER SERVER CONFIGURATION コマンドを実行してサーバーを中断して後続のスナップショットバックアップのためにサーバーを中断すると、次のエラーが発生します。
メッセージ 3081、レベル 16、状態 4、行 <LineNumber>
データベース <DatabaseName> は、以前に スナップショット バックアップのために中断されていました。
解決策
この問題は、次の SQL Server 用の累積的な更新プログラムで修正されています。
SQL Server 2022 の累積的な更新プログラム 16
SQL Server 用の累積的な更新プログラムについて
SQL Server 用の新しい累積的な更新プログラムには、以前のビルドであったすべての修正プログラムとセキュリティ修正プログラムが含まれます。 ご使用のバージョンの SQL Server 用の最新ビルドをインストールすることをお勧めします。
SQL Server 2022 の最新の累積的な更新プログラム
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。