この資料は Windows 2000 に適用されます。Windows 2000 のサポートは 2010 年 7 月 13 日で終了しています。Windows 2000 からの移行をご検討のお客様は、Windows 2000 エンド オブ サポート ソリューションセンターを参照してください。詳細については、マイクロソフト サポート ライフサイクル ポリシーを参照してください。
現象
Windows インストーラー 2.0 へのアップグレード後、Windows インストーラー サービスが開始せず、次のエラー メッセージが表示されることがあります。
Windows インストーラー サービスにアクセスできませんでした。セーフ モードで Windows を実行している場合、または Windows インストーラーが正しくインストールされていない場合に発生する可能性があります。サポート担当者に問い合わせてください。
注: この現象は次の製品では発生しません。
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Microsoft Windows XP
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Microsoft Windows Millennium Edition
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Microsoft Windows 98
原因
この現象は、次のいずれかの条件に該当する場合に発生することがあります。
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DCOM のアクセス許可で、[既定の認証レベル] が [なし] に設定され、[既定の偽装レベル] が [匿名] に設定されている。
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Windows インストーラーのアクセス先のフォルダーまたはレジストリ キーに対するフル コントロールのアクセス許可が SYSTEM アカウントに与えられていない。この条件は、NTFS ファイル システムを使用している場合にのみ当てはまります。
解決方法
問題に応じて、次のいずれかまたはすべての方法を実行します。
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方法 1: Windows インストーラーの登録を解除してから再登録する
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方法 2: DCOM のアクセス許可を確認する
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方法 3: SYSTEM アカウントにフル コントロールのアクセス許可を与える
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方法 4: レジストリのアクセス許可を確認する
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方法 5: MsiServer サービスの破損したセキュリティ キーを修正する
手順を実行する前に: Service Pack がインストールされていることを確認する
Windows 2000 を使用している場合、SP2 がインストールされていることを確認します。
Windows NT 4.0 を使用している場合、SP6 がインストールされていることを確認します。 適切な Service Pack がインストールされていない場合、この資料の「詳細」の手順が正常に実行できないことがあります。詳細
方法 1: Windows インストーラーの登録を解除してから再登録する
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[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「MSIEXEC /UNREGISTER」と入力し、[OK] をクリックします。この操作を正しく実行しても、処理が行われていないように見えることがあります。
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[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「MSIEXEC /REGSERVER」と入力し、[OK] をクリックします。この操作を正しく実行しても、処理が行われていないように見えるか、または砂時計が一瞬表示されることがあります。このコマンドを実行したら、操作は完了です。
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Windows インストーラー ベースのアプリケーションを再実行します。
方法 2: DCOM のアクセス許可を確認する
この方法では、DCOM の [既定の偽装レベル] を [識別する] に変更し、Msisip.dll ファイルを削除した後、Windows 2000 SP3 を再インストールします。
これを行うには、次の手順を実行します。-
[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「dcomcnfg」と入力し、[OK] をクリックします。
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[既定のプロパティ] タブをクリックします。
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[既定の認証レベル] ボックスの一覧の [接続] をクリックします。
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[既定の偽装レベル] ボックスの一覧の [識別する] をクリックし、[OK] をクリックします。
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[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「explorer /select, %windir%\system32\msisip.dll」と入力し、[OK] をクリックします。
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Msisip.dll ファイルの名前を Msisip.old に変更します。
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Windows 2000 Service Pack 3 を再インストールします。
方法 3: SYSTEM アカウントにフル コントロールのアクセス許可を与える
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エクスプローラーを起動し、Windows がインストールされているドライブを右クリックし、[プロパティ] をクリックします。
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[セキュリティ] タブをクリックし、[追加] (または [アクセス権]) をクリックします。
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[ユーザー、コンピューター、またはグループの選択] ダイアログ ボックスで [SYSTEM] アカウントをクリックします。[追加] をクリックし、[OK] をクリックします。
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[フル コントロール] の [許可] チェック ボックスをオンにし、[OK] をクリックします。
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TEMP フォルダーをクリックし、SYSTEM アカウントにフル コントロールのアクセス許可が与えられていることを確認します。
方法 4: レジストリのアクセス許可を確認する
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[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「Regedt32」と入力します。
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レジストリ ハイブごとに、次の手順を実行します。
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ハイブを選択します。
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Windows XP の場合、[編集] メニューの [アクセス許可] をクリックします。
Windows 2000 および Windows NT 4.0 の場合、[セキュリティ] メニューの [アクセス許可] をクリックします。
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SYSTEM アカウントが追加されていて、フル コントロールのアクセス許可が与えられていることを確認します。SYSTEM アカウントが追加されていない場合は、SYSTEM アカウントを追加し、フル コントロールのアクセス許可を与えます。
方法 5: MsiServer サービスの破損したセキュリティ キーを修正する
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Windows 2000 を使用してコンピューターを起動します。
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[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「regedit.exe」と入力し、次のキーの名前を Old_Security に変更します。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security
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コンピューターを再起動します (これは必ず行う必要があります)。
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Windows インストーラー 2.0 の Instmsiw.exe を実行します。これによって、MSI サービスの破損したセキュリティ キーが修正されます。
プログラムを追加または削除すると表示される場合があるエラー メッセージの詳細については、以下のサポート技術情報番号をクリックしてください。
315346エラー メッセージ "Windows インストーラー サービスにアクセスできませんでした" が、Windows XP または Windows Server 2003 を搭載しているコンピューターでプログラムを追加または削除すると表示される