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現象

次のような状況で問題が発生します。

  • Microsoft Forefront Threat Management Gateway 2010は、Microsoft Forefront Threat Management Gateway 2010 Service Pack 1 (SP1) で導入されたブロックされるカテゴリ機能にユーザー オーバーライドを使用するために構成します。

  • 拒否ルールを上書きしているユーザーを監視できるよう、Forefront Threat Management Gateway 2010 でレポートを生成する構成を行います。


このシナリオでは、上位上書き URL テーブルと上位ルール上書きユーザー テーブルの概要情報に誤った情報が表示され、値が予想よりはるかに大きいように見える場合があります。

原因

この問題は、この情報を集計するストアド プロシージャが誤って値を累積し、前の日の値が翌日の値にロール インする場合に発生します。

解決方法

この問題を解決するには、次の Microsoft サポート技術情報の記事に記載されている修正プログラム パッケージをインストールします。

2649961 Forefront Threat Management Gateway (TMG) 2010 Service Pack 2010 のロールアップ 1 この修正を有効にするには、Forefront Threat Management Gateway サーバーの 1 つで FixSoftBlockSummaries.js スクリプトを実行します。 このスクリプトは、Forefront Threat Management Gateway サーバー、配列ノード、またはエンタープライズ管理サーバーで実行できます。

注: スクリプトは使用可能なすべての配列を列挙し、ストアド プロシージャを修正して、概要情報が正しく作成されるようにします。 新しい配列が記憶域に追加された場合は、スクリプトの実行がもう一度必要な場合があります。


この修正プログラムを有効にするには、「問題を解決する」セクション移動してください。 この修正プログラムを自分で有効にする場合は、"自分で修正する"セクションに移動します。

Fix it で解決する



この修正プログラムを自動的に有効にするには、[ 修正] ボタンまたはリンクをクリックします。 次に 、[ファイルの ダウンロード] ダイアログ ボックスで [実行] をクリックし、修正ウィザードの手順に従います。




メモ

  • この修正プログラム ソリューションを実行する前に、Microsoft サポート技術情報 (KB) の記事 2649961 に記載されている修正プログラムをインストールします。

  • このウィザードは英語版のみである場合があります。 しかし、自動的な解決は英語版以外の Windows でも機能します。

  • 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。


次に、"問題は解決しましたか?" セクションに移動します。



自分で解決する

  1. メモ帳を起動します。 メモ帳を起動するには、[スタート] をクリックし、[ファイルを開く] ボックスにnotepad.exeを入力して、[OK]をクリックします。

  2. 次のスクリプトを新しいメモ帳ファイルに貼り付けます。

    var guidGenerator = new ActiveXObject("Scriptlet.TypeLib");
    var fpcRoot = new ActiveXObject("FPC.Root");
    try
    {
    WScript.Echo("Enumerating arrays:");
    var arraysCollection = new Enumerator(fpcRoot.Arrays);
    for (; !arraysCollection.atEnd(); arraysCollection.moveNext())
    {
    try
    {
    var array = arraysCollection.item();
    var found = false;
    WScript.Echo(" " + array.Name);
    var sumDefsCollection = new Enumerator(array.Reports.ReportSummaryDefinitions);
    for(; !sumDefsCollection.atEnd(); sumDefsCollection.moveNext())
    {
    var sumDef = sumDefsCollection.item();
    if(sumDef.Name != "spTrimArraySoftBlockSummary")
    {
    continue;
    }

    if (sumDef.AggregationStatement.indexOf("@ToDate AS [Date]") < 0)
    {
    WScript.Echo("---- spTrimArraySoftBlockSummary.AggregationStatement already contains fix, skipping array");
    break;
    }

    found = true;
    WScript.Echo("Found summary definition " + sumDef.Name + ", will fix the AggregationStatement");
    WScript.Echo("---- Old version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- Old version end");
    sumDef.AggregationStatement = sumDef.AggregationStatement.replace(/@ToDate AS \[Date\]/g, "@FromDate AS [Date]");
    WScript.Echo("---- New version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- New version end");
    break;
    }
    if (found)
    {
    WScript.Echo("Updating configuration ID...");
    WScript.Echo("Old configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);
    array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId = guidGenerator.Guid;
    WScript.Echo("New configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);

    WScript.Echo("Saving the current configuration...");
    array.Save();
    WScript.Echo("Waiting for configuration reload...");
    array.WaitForReload();
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
  3. ファイルをメモ帳としてFixSoftBlockSummaries.jsし、メモ帳を終了します。

  4. サーバーで、管理コマンド プロンプトを開きます。

  5. 次のコマンドを使用してスクリプトを実行します。

    cscript.exe FixSoftBlockSummaries.js

スクリプトが完了し、構成が同期されるのを待ちます。 この後、拒否ルールを上書きしたユーザーに関する情報が正しく作成されます。 以前の集計データの場合、スクリプトではこの問題を解決できません。

問題が解決されたかどうかの確認

  • 問題が解決されたかどうかを確認します。 問題が解決された場合、このセクションの作業は完了していることになります。 問題が解決されていない場合は、サポートに問い合わせることができます。

  • マイクロソフトではフィードバックをお待ちしております。 この解決方法に関するフィードバックを提供するか、または問題を報告するには、「Fix it for me」ブログ (英語) にコメントを記入するか、電子メール メッセージ (日本語可) を送信してください。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

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824684 Microsoft ソフトウェアの更新プログラムの説明に使用される標準的な用語の説明

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