メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況で問題が発生します。

  • Microsoft BizTalk Server 2009年または BizTalk Server 2010 を実行しているコンピューターがあります。

  • Windows Communication Foundation (WCF) をサポートするための次の構成データは、Machine.config ファイルの< serviceBehaviors >要素を追加します。

    <behavior name="WindowsAuthenticationBehavior"> <serviceMetadata httpGetEnabled="true"/> <serviceDebug includeExceptionDetailInFaults="false"/> <serviceCredentials> <windowsAuthentication includeWindowsGroups="true" allowAnonymousLogons="false"/> </serviceCredentials> <serviceAuthorization principalPermissionMode="UseWindowsGroups"/> </behavior>注: これらの確認手順は、Windows クライアントにのみ適用されます。 Machine.config ファイルは、次のフォルダーに格納されます。

    %Systemdrive%\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\

  • WCF ベースを作成する受信場所を BizTalk アプリケーションにします。

  • BizTalk Server 2009年または BizTalk Server 2010 管理コンソールで受信場所のバインドをエクスポートしようとするとします。

このシナリオでは、エクスポートが失敗し、次のようなエラー メッセージが表示。

複数のルート要素があります。 行 1、49 を配置します。 (System.Xml)

< ServiceBehaviors >要素で構成データを削除する場合にこのエラー メッセージを表示した後、エクスポートは他のエクスポート操作に失敗します。

原因

この問題は、WCF ベース アダプターでエラーが発生したために発生します。

解決方法

累積的な更新プログラムの情報

BizTalk Server 2010の累積的な更新パッケージを入手する方法の詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。

2497789 BizTalk 2010 用の累積的な更新プログラム パッケージ 1 BizTalk Server 2009 年この問題を解決する修正プログラムは、BizTalk Server 2009年用の累積的な更新プログラム パッケージ 2 に含まれます。詳細については、累積的な更新プログラム パッケージの入手については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックする方法。

2497794 BizTalk Server 2009年用の累積的な更新プログラム パッケージ 2

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細情報

BizTalk Server の修正プログラムに関する詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。

2003907 BizTalk Server の修正プログラムに関する情報

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×