現象
デスクトップ フローの無人実行は、次のスクリーンショットに示すように、エラー コード AADMachineAlwaysPromptingForPassword で失敗します。
原因
デスクトップ用 Power Automateマシンで Azure Active Directory 資格情報を検証できませんでした。 これは通常、コンピューターのグループ ポリシー設定が原因で発生します。
解決方法
グループ ポリシー設定で問題が発生しているかどうかを確認するには、ローカル グループ ポリシー エディター ([スタート] > [実行] > "gpedit.msc") に移動します。 その中から、リモート デスクトップ サービス>リモート デスクトップ セッション ホスト > セキュリティ> Windows コンポーネント>ローカル コンピューター ポリシー > > コンピューターの構成>管理用テンプレートを参照し、[接続時に常にパスワードを求める] の値を確認します。 これが true に設定されている場合は、IT 部門と連携して、そのマシンのポリシーを無効にする必要があります。 この値は、次のパスのレジストリにも反映されることに注意 してください:Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services。 Terminal Services キーに値 fPromptForPassword が 1 に設定されている場合は、設定が有効になっており、IT 部門と連携して無効にする必要があります (一般に、レジストリ値を変更するだけでは、元に戻す可能性があるため、十分ではありません)。
"接続時に常にパスワードの入力を求める" がまだ有効になっていない場合は、regedit を使用して次のレジストリ キーを開きます: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp。 次に、DWORD fPromptForPassword を探して 0 に設定します。DWORD が存在しない場合は作成できます。