Adobe Acrobat 7.0 のインストール後、Word で変更が保存できない、または Office プログラムでエラー メッセージが表示される

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。

256986 Microsoft Windows レジストリの説明

現象

この資料の対象製品として記載されている Microsoft Office プログラムを使用すると、以下のいずれかまたは複数の現象が発生する場合があります。

  • Microsoft Word でワークスペースを変更しても、Word の終了時に変更が保存されません。ワークスペースの変更には、以下のものが含まれます。

    • マクロの作成

    • デフォルト フォントの変更

    • 定型句の追加

    • ツール バーの作成

    Word を再起動しても、変更または追加した項目が利用できません。



    注 : この動作は、[標準設定を変更するかどうかを確認する] チェック ボックスがオンになっている場合でも発生します。

  • Office プログラムを起動するときに、次のいずれかのようなエラー メッセージが表示されます。

    visual c++ runtime error

    Microsoft visual c++ runtime library

    Program files\Microsoft office\office10\product name.exe

    This application has requested the runtime to terminate it in an unusual way.

  • Word の文書を開いたときに、次のエラー メッセージが表示されます。

    ディスクの空き容量またはメモリが不足しています。指定されたフォントを表示できません。

原因

この問題は、Adobe Acrobat 7.0 Professional、Adobe Acrobat 7.0 Standard、または Adobe Acrobat 7.0 Elements をインストールした後で発生する場合があります。



Acrobat 7.0 は、COM アドインを次のフォルダにインストールします。

\Acrobat 7.0\PDFMaker\Office
この COM アドインによって PDFMaker アイコンと Office プログラム用のメニュー コマンドが提供されます。

回避策

この問題を回避するには、状況に応じて次のいずれかの方法を使用します。Word の終了時に変更が保存されない場合は、下記の方法 1 または方法 2 を使用します。Office プログラムを起動するとき、または Word 文書を開くときにエラー メッセージが表示される場合は、方法 3 または方法 4 を使用します。

方法 1 : Word のマクロ、基本設定、カスタム設定を、[ファイル] メニューの [すべて保存] コマンドを使用して保存する



注 : この方法は、Microsoft Office Word 2007 では使用できません。



Word 2003 およびそれ以前のバージョンの Word で、マクロ、基本設定、およびカスタム設定を手動で保存するには、次の手順を実行します。

  1. Shift キーを押したままにします。

  2. [ファイル] メニューの [すべて保存] をクリックします。

変更が保存されます。また、この変更が他の Word 文書からも利用可能になります。

方法 2 : [すべて保存] コマンドを追加する


Word でマクロ、基本設定、またはカスタム設定を作成するたびに、[すべて保存] コマンドをクリックします。



Word に [すべて保存] コマンドを追加するには、次のいずれかの操作を実行します。

  • Word 2007 では、以下の手順を実行して、クイック アクセス ツール バーに [すべて保存] コマンドを追加します。

    1. Microsoft Office ボタンをクリックし、[Word のオプション] をクリックします。

    2. [ユーザー設定] をクリックします。

    3. [コマンドの選択] ボックスの一覧で、[すべてのコマンド] をクリックします。

    4. [コマンドの選択] ボックスの下に表示される一覧で、[すべて保存] をクリックして [追加] をクリックします。

    5. [OK] をクリックして [Word のオプション] ダイアログ ボックスを閉じます。

  • Word 2003 およびそれ以前のバージョンの Word では、次の手順を実行して、[ファイル] メニューに [すべて保存] コマンドを追加します。

    1. [ツール] メニューの [ユーザー設定] をクリックします。

    2. [コマンド] タブで、[分類] ボックスの一覧の [ファイル] をクリックします。

    3. [コマンド] ボックスの [すべて保存] を [ファイル] メニューにドラッグします。[ファイル] メニューが開いたら、[すべて保存] コマンドを任意の場所へ配置します。

    4. [ユーザー設定] ダイアログ ボックスを閉じます。

方法 3 : Adobe に問い合わせる


Adobe Systems Incorporated に問い合わせて、Acrobat 7.0 の更新プログラムが入手可能かどうかを確認します。



Adobe Systems Incorporated の問い合わせ先を参照するには、次のうち該当する「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。

65416 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (A ~ K)


60781 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (L ~ P)


60782 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (Q ~ Z)
他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

方法 4 : Adobe アドインを Office から削除する


Adobe アドインを削除すると、Office プログラムからファイルを PDF (Portable Document File) 形式で保存できなくなります。



Adobe アドインを削除するには、以下の手順を実行します。



注 : Microsoft Windows には複数のバージョンが存在するため、使用中のコンピュータによっては以下の手順が異なる場合があります。この場合、製品のマニュアルを参照のうえ、手順を実行するようにしてください。

  1. プログラムをすべて終了します。

  2. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロール パネル] をクリックします。

  3. [プログラムの追加と削除] (または [アプリケーションの追加と削除]) をダブルクリックします。

  4. [現在インストールされているプログラム] の下の [Adobe Acrobat Professional 7.0] をクリックし、[変更] をクリックします。

  5. [変更] をクリックし、[次へ] をクリックします。

  6. [Adobe PDF の作成] を展開します。

  7. [Acrobat PDFMaker ファイル] を展開します。

  8. [Microsoft Office] の横にある矢印をクリックし、[この機能を使用できないようにします。] をクリックします。

  9. Adobe Acrobat Professional 7.0 Setup ウィザードで、[OK] をクリックします。

  10. [プログラムの追加と削除] を閉じます。

この手順を完了しても前述の現象が引き続き発生する場合は、Adobe アドインをレジストリから手動で削除することもできます。



重要 : Adobe アドインを手動で削除する前に、詳細について Adobe にお問い合わせください。



警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。



Adobe アドインを手動で削除するには、以下の手順を実行します。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に regedit と入力し、[OK] をクリックします。

  2. 次のレジストリ サブキーを見つけてクリックします。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin

  3. [ファイル] メニューの [エクスポート] をクリックし、ファイル名を入力して、[保存] をクリックします。

  4. [PDFMaker.OfficeAddin] レジストリ エントリを右クリックし、[削除] をクリックします。

  5. 次のレジストリ サブキーで手順 3. と 4. を繰り返して、アドインのレジストリ エントリを削除します。

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook

  6. レジストリ エディタを終了します。

詳細

全文書対象のテンプレート (Word 2007 では Normal.dotm ファイル、Word 2003 およびそれ以前のバージョンの Word では Normal.dot ファイル) は、Word で使用されるデフォルトのテンプレートです。デフォルトでは、すべての新しいドキュメントに影響する変更は、全文書対象のテンプレートに保存されます。変更を保存する際に別のテンプレートを指定しない限り、この動作が実行されます。Acrobat 7.0 をインストールすると、Word で変更内容が全文書対象のテンプレートに自動的に保存されなくなることがあります。



この問題の詳細については、次の Adobe の Web サイトを参照してください。

http://support.adobe.co.jp/faq/faq/qadoc.sv?225964+002

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

フィードバックをお送りいただきありがとうございます!

×