この資料では、アプリケーションでは、Active Directory サービス インターフェイス (ADSI) Api を使用して、Windows Server 2012 R2 のときに発生する問題について説明します。この問題を解決する修正プログラムがあります。修正プログラムには、前提条件があります。
原因
この問題は、ドメイン コント ローラーに LDAP の呼び出しが行われる場合、ADSI はタイムアウトをサポートしないために発生します。代わりに、ほとんどの API の呼び出しで NULL 値が渡されます。Wldap32.dll がサーバーから応答を受信するまで待機が発生します。
影響を受けるアプリケーション
次のアプリケーションは、この問題が発生しているに報告されます。
解決策
この問題を解決するには、修正プログラムをリリースしました。場合でも、Windows Server 2012 R2 でこの問題は発生のみ、この修正プログラムは Windows 8.1 および Windows RT 8.1 にも適用されます。
重要 この修正プログラムをインストールした後に言語パックをインストールする場合は、この修正プログラムを再インストールする必要があります。したがって、この修正プログラムをインストールする前に、必要な言語パックをインストールすることを推奨します。詳細については、「Windows への言語パックの追加」を参照してください。
修正プログラムの情報
サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、この資料に記載されている問題のみを修正するものです。この問題が発生しているシステムにのみ適用してください。
修正プログラムがダウンロード可能な場合は、このサポート技術情報の記事の上部にある「修正プログラム ダウンロード使用可能な"セクションがあります。このセクションが表示されない場合は、修正プログラムを取得するには、マイクロソフト カスタマー サービス & サポートに要求を送信します。
注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。追加の質問およびこの特定の修正プログラムに該当しない問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support