メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況で問題が発生します。

  • Exchange Server 2013 環境で、Microsoft Exchange サーバーのさまざまな累積更新プログラムを展開します。

  • HTTP と PowerShell の名前空間のセッションアフィニティを使わないロードバランサーを構成します。

  • 次の Exchange 管理シェルを使用して、ロードバランサーを介してリモート PowerShell セッションを作成します。 $Session = New-PSSession-ConfigurationName http://shell.contoso.com-AllowRedirectionImport-$Session PSSession Uri

このシナリオでは、接続が失敗します。 さらに、次のような WSMan-InvalidShellID エラーが表示されます。

新しい-PSSession: [shell.contoso.com] リモートサーバー shell.contoso.com からデータを処理するときに、次のエラーメッセージが表示されました。 [ClientAccessServer = Server1、BackEndServer =IDNumber、TimeStamp =Date/Time] [FailureCategory = WSMan-InvalidShellID] シェルがサーバーで見つからなかったため、ShellId ShellIDNumnerで Windows リモートシェルの要求を送信できませんでした。次の原因が考えられます。指定された ShellId が正しくないか、シェルがサーバーに存在しなくなっています。 適切な ShellId を提供するか、新しいシェルを作成して、操作をもう一度実行します。 詳細については、bout_Remote_Troubleshooting のヘルプトピックを参照してください。[....]

原因

この問題は、リモート PowerShell セッションが常に同じメールボックスサーバーにルーティングされないために発生します。

回避策

この問題を回避するには、以下のいずれかの方法を使用します。

  • セッションのアフィニティまたは永続性を使用するようにロードバランサーを構成します。

  • Exchange サーバーで、ロードバランシングで同じ累積的な更新プログラムのビルドを使うようにします。

解決方法

この問題を解決するには、累積更新プログラム 11またはそれ以降の Exchange Server 2013 の累積的な更新プログラムをインストールします。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×