KB3173666-トランザクションログの配布で SQL Server 2016 をセカンダリとして構成する場合は、.NET Framework 3.5 が必要です。

どこにいても、どのデバイスからでも、 Microsoft 365

Microsoft 365 にアップグレードして、最新の機能と更新プログラムを利用できます。

今すぐアップグレード

現象

次のような状況で問題が発生します。

  • SQL Server 2016 をコンピューターにインストールします。

  • トランザクションログの配布を使用し、SQL Server 2016 をセカンダリとして構成します。

このシナリオでは、セカンダリで Lscopy ジョブを開始すると、エラーが記録されずにエラーが発生する場合があります。セカンダリ上の SQL Server エージェントで lscopy ジョブを編集している場合は、コマンドラインで完全な sqllogship コマンドをコピーして貼り付け、enter キーを押すと、.net Framework 3.5 が必要に応じて一覧表示されます。注: このシナリオで .NET Framework 3.5 をインストールしてサーバーを再起動すると、 Lscopy ジョブと lscopy ジョブが正常に実行されます。

解決方法

この問題の修正プログラムは、SQL Server の次の累積的な更新プログラムに含まれています。

SQL Server 2016 の累積更新プログラム1

SQL Server 用の新しい累積更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正が含まれています。 SQL Server の最新の累積的な更新プログラムを確認します。

SQL Server 2016 の最新の累積的な更新プログラム

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

関連情報

Microsoft でソフトウェアの更新について説明する 用語 について説明します。

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

フィードバックをお送りいただきありがとうございます!

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×