メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

Extender ウィンドウにリンクされている SmartList オブジェクトの列としてExtenderフィールドを追加する場合、SmartList オブジェクトの Type値は Microsoft Dynamics GP で定義されていません。

原因

この問題は、次の条件の 1 つ以上が当てはまるため発生します。

  • SmartList オブジェクトが破損し、修復する必要があります。

  • SmartList オブジェクトにリンクされている Extender ウィンドウのリンクが削除されます。

  • [Extender] ウィンドウが削除され、同じフィールド名を持つ Extender ウィンドウが作成されます。

この問題は、Extender は会社固有ですが、SmartList は会社固有ではないので発生します。

解決策

この問題を解決するには、次の手順を実行します。

  1. Microsoft Dynamics GP のメイン企業で、[ ツール]をクリックし、[拡張] クリックし、[オプション] を クリックします

  2. [SmartLists の自動更新] チェック ボックスをオンにします

  3. メイン会社以外のすべての会社で 、[SmartLists の自動更新] チェック ボックスをオフにします。

    注意 この手順では、作成した可能性があるテスト会社を含みます。

  4. すべての会社で、SmartList オブジェクトにリンクされているすべての Extender ウィンドウから SmartList リンクを削除します。

  5. メイン会社で SmartList を開きます。

  6. [ 追加] をクリックし、[ 追加] をクリックし、[拡張] をクリックします

  7. [種類] の値が [定義されていません] の SmartListオブジェクトをクリックします

  8. [Extender フィールド] 領域の最初の Extender フィールドをクリックし、赤い [X] をクリックしてフィールドを削除します。

  9. すべての Extender フィールドに対して手順 8 を繰り返します。

  10. Microsoft Dynamics GP を終了して起動します。

  11. メイン会社を開きます。

  12. Extender ウィンドウを SmartList オブジェクトに再びリンクします。

  13. SmartList を開き、[ 追加] をクリックし、[追加] をクリックして、[拡張] をクリックします。 リストに Extender フィールドが 1 回だけ表示されるのを確認します。

    注意 Extender フィールドが表示されない場合は、終了してから Microsoft Dynamics GP を起動します。

詳細情報

プログラムが正常に動作するには、Microsoft Dynamics GP のメイン企業で SmartList のすべての変更を行う必要があります。 そのため、その Extender ウィンドウを使用しない場合でも、メイン会社に Extender ウィンドウを置いすることをお勧めします。

関連情報

SmartList オブジェクトに Extender ウィンドウ フィールドを追加するときに複数の会社を使用する方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を表示します。

914170 Microsoft Great Plains の Extender から SmartList にフィールドを追加するためのガイドライン

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×