現象
Business Portal for Microsoft Dynamics GP または Microsoft Dynamics SL のタスクをクリックすると、次のメッセージが表示されることがあります。
Windows ターミナル サーバー名が設定されません。
原因
原因 1
この問題は、ターミナル サービスのセットアップ ウィンドウの設定が正しく構成されていない場合に発生する可能性があります。 「解決策」セクションの「解決策 1」を参照してください。
原因 2
この問題は、ターミナル サーバーとターミナル サーバー ライセンスがターミナル サーバーで有効になっていないため発生する可能性があります。 「解決策」セクションの「解決策 2」を参照してください。
原因 3
この問題は、バックオフィス アプリケーションがターミナル サーバーにインストールされていない場合に発生する可能性があります。 「解決策」セクションの「解決策 3」を参照してください。
解決策
解決方法 1
-
Business Portal を起動し、ターミナル サービスのセットアップ ウィンドウを見つける。 この場合、次の手順を実行します。
-
Business Portal for Microsoft Dynamics GP 10 または Microsoft Dynamics SL 7.0を実行している場合は、[サイトの操作] をクリックし、[サイト 設定] をクリックし、[電子メールとターミナル サービス] をクリックします。
-
Business Portal 3.0 または Business Portal 2 を実行している場合。xをクリックし、[サイト 設定]をクリックし、[全般] 設定をクリックし、[Setup Back Office ターミナル サーバー アクセス]をクリックします。
-
-
[Windows ターミナルアクセスに使用する Internet Explorer] ボックスに、ターミナル サーバーの名前を入力します。
-
[ユーザーが ターミナル サービス にログインするときに開始する初期アプリケーションのパスとファイル名] ボックスに、使用しているアプリケーションに応じて次を入力し、[保存] をクリック します。
-
Microsoft Dynamics GP を実行している場合は、Microsoft Great Plains Dynamics.exe ファイルのパスと、ターミナル サーバー上の Dynamics.set ファイルのパスを入力します。 既定では、これらのファイルは、実行しているバージョンに応じて次の場所に保存されます。
-
Microsoft Business Solutions - Great Plains 8.0 を実行している場合、入力する既定のパスは C:\Program Files\Microsoft Business Solutions\Great Plains\Dynamics.exe C:\Program Files\Microsoft Business Solutions\Great Plains\Dynamics.set です。
-
Microsoft Dynamics GP 9.0 または Microsoft Dynamics GP 10.0 を実行している場合、入力する既定のパスは C:\Program Files\Microsoft Dynamics\GP\Dynamics.exe C:\Program Files\Microsoft Dynamics\GP\Dynamics.set です。
注意 Microsoft Great Plains のショートカットからパスをコピーできます。 パスを確認するには、デスクトップ上の Microsoft Great Plains ショートカットを右クリックします。 次に、[プロパティ] を クリックします。 [ターゲット] ボックスからパス をコピー します。 Microsoft Business Portal でパスを貼り付けるときに引用符を削除する必要があります。
-
-
Microsoft Dynamics SL を実行している場合は、「/s」と入力C:\PathName\sdwtsshell.exe
入力します。
注意 この手順では 、PathName は Microsoft Dynamics SL アプリケーションのパスのプレースホルダーです。
-
-
ターミナル サーバーへのアクセスを構成した後、[現象] セクションに記載されているメッセージを受信せずに、センター ページ上の任意のタスクをクリックできます。
注意 ターミナル サーバー クライアント プログラムが開き、[サイトの構成] ページで指定されているターミナル サーバー設定されます。 このコンピューターに対する管理アクセス許可を持つターミナル サーバーローカル アカウントを使用して、ターミナル サーバーにログオンします。 ターミナル サーバーにログオンすると、Microsoft Great Plains が自動的に起動し、ユーザー ID の入力を求めるメッセージが表示されます。 ユーザー ID とパスワードを入力すると、Microsoft Business Portal でクリックしたリンクに対応する [Microsoft Great Plains] ウィンドウが開きます。
解決方法 2
ターミナル サーバーとターミナル サーバー ライセンスがターミナル サーバーで有効になっている必要があります。 この場合、次の手順を実行します。
-
[ スタート] をクリックし 、[実行]をクリックし、「appwiz.cpl」と入力し 、[OK] をクリックします。
-
[プログラムの追加と削除] ウィンドウで、[コンポーネントの追加/削除Windowsクリックします。
-
次の 2 つのオプションをクリックして選択します。
-
ターミナル サーバー
-
ターミナル サーバー のライセンス
-
解決方法 3
バックオフィス アプリケーションがターミナル サーバーにインストールされていることを確認します。
詳細情報
問題の再現手順
-
Microsoft Business Portal を起動します。
-
[ 財務] をクリックします。
-
[ジャーナル エントリの作成] をクリックします。
注意 Microsoft Business Portal のすべてのセンター ページでタスクをクリックすると、エラー メッセージが表示されます。