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現象

RemoteFX の RDP 接続試行は、クライアント上で次のエラーの結果として、ターミナル サーバーの失敗を有効にします。

"リモート コンピューターは、ライセンス プロトコルにエラーが発生したため、セッションを切断します。 かしてください、リモート コンピューターに接続し直して、サーバーの管理者に問い合わせてください。」

ターミナル サーバーでは、次のイベントが記録されます。

イベント ID: 1152

ソース: TerminalServices-RemoteConnectionManager

メッセージ: リモート デスクトップ仮想化ホスト サーバーは、クライアント ライセンスを発行することはできません。 変更された (一致しない) クライアント ライセンス、メモリ不足、または内部エラーのため、ライセンスを発行することでした。

原因

RemoteFX サーバーに接続するクライアントが標準の RDP セキュリティを使用する場合、この問題が発生します。

これは、次の条件下で発生します。

  1. クライアントは、リモート デスクトップのアクティブなコントロールを使用してカスタム アプリケーションです。 このコントロールは、既定で標準の RDP セキュリティを使用します。

  2. クライアントは、サード ・ パーティ製または標準の RDP セキュリティを使用して構成されている Windows のリモート デスクトップ クライアントです。 Windows XP SP3 とリモート デスクトップ クライアントを新しい RDP の強化されたセキュリティを使用して、既定でと、この問題は発生しません。 以前のクライアント オペレーティング システムでは、既定では、標準の RDP セキュリティを使用しはこの資料に記載されている現象が発生します。

解決方法

RDP の強化されたセキュリティを使用するクライアントを構成する必要があります。

クライアントが最小管理バージョン IMsRdpClientAdvancedSettings4 のインタ フェースを使用する必要があり、1 または 2 のいずれかに AuthenticationLevel プロパティを設定するクライアントが、リモート デスクトップ ActiveX コントロールを使用してカスタム アプリケーションの場合は、(デフォルトのレベルは 0 になります)。

Windows XP SP2 クライアントが実行されている MSTSC.exe は、RDP を使用してこのライセンスの問題を回避することができます、強化されたセキュリティでリモート デスクトップ接続クライアントのセキュリティ] タブのプロパティで「の認証を試みる」ドロップダウン ・ リストを選択します。

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