UML データベース表記図を作成する

適用先
Visio Plan 1 Visio Professional 2024 Visio Professional 2021 Visio Professional 2019 Visio Professional 2016

Visio で UML データベース表記図を作成して、リレーショナル データベースの構造を定義できます。

UML にはデータ モデリングの仕様はありませんが、特にデータベースからのデータをオブジェクト指向プログラミングで使用できるため、図を作成するのに便利なツールになります。 Visio UML データベース図形は、オブジェクト指向クラスのモデル化に使用される UML クラス図の図形によく似ており、システム全体で一貫した表記を提供します。

まず、 UML データベース表記法 の図面を開きます。この図面には、Visio のバージョンに応じて、UML 2.5 または 2.0 標準に準拠した図形を持つデータベース表記ステンシルが含まれています。

  1. Visio を起動します。 または、既にファイルを開いている場合は、[ ファイル>新規作成] をクリックします。
  2. [検索] ボックスに「 UML database notation」と入力します。
  3. UML データベース表記法テンプレートを選択します。
  4. ダイアログ ボックスで、[ メートル法] または [米国単位] を選択します。
  5. [作成] を選択します。
  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 表示されない場合は、[表示] >[作業ウィンドウ] に移動し、[図形] が選択されていることを確認します。 それでも表示されない場合は、左側の [図形の展開 ] ウィンドウ ボタンをクリックします。
  7. [表示] タブで、[接続ポイント] の横のチェック ボックスがオンになっていることを確認します。 これで、図形の接続を開始すると、接続ポイントが表示されます。
  8. 図面の描画を開始する準備ができました。 ステンシルを選択し、そこから 図に [エンティティ] 図形をドラッグして開始します。
    エンティティの図形。

関連項目

UML 図形に多重度を指定する

Visio での UML 図