Microsoft Excel 98 verziu tohto článku nájdete v téme 192907.
Príznaky
Pri ukladaní zošita v Microsoft Exceli sa môže zobraziť nasledujúce chybové hlásenie
Disk je plný.
nasleduje:
Dokument sa neuložil.
Príčina
Tieto chyby sa zobrazia pri ukladaní zošita na disk, v ktorom nie je dostatok voľného miesta. Tento problém sa napríklad vyskytne, ak otvoríte zošit 710-kilobajtov (KB) uložený z diskety 1,44 – megabajt (MB) a vykonáte zmeny, ktoré sa pridávajú do veľkosti súboru a zošit uložíte na rovnaký disk. Ďalšie informácie o požiadavkách na miesto na disku pre veľkosti súborov nájdete v časti Ďalšie informácie.
Riešenie
Ak sa chcete vyhnúť týmto chybovým hláseniam, skopírujte súbor na pevný disk alebo na iný disk, ktorý má dostatok voľného miesta pred jeho otvorením v Exceli. Ak potrebujete súbor uložiť na diskete, najskôr uložte súbor na pevný disk a potom ho skopírujte na disketu pomocou Windows Prieskumníka.
Ďalšie informácie
Keď pracujete v súbore, Microsoft Excel uloží súbor s dočasným názvom súboru (prípona súboru. tmp) a umiestni tento súbor do rovnakého adresára ako pôvodný súbor. Keď súbor uložíte, pôvodný súbor sa potom odstráni a dočasný súbor sa prepremenuje s pôvodným názvom súboru. Veľkosť voľného miesta na disku musí byť preto väčšia ako dvojnásobok veľkosti súboru, ktorá sa uloží. Ak to tak nie je, zobrazí sa hlásenie disk je plný. Ak napríklad otvoríte zošit 710-kilobajtov (KB) a vykonáte zmeny, ktoré pridajú 10kb do veľkosti súboru a uložíte zošit, disk musí mať viac ako 720 KB x 2 alebo viac ako 1,44 MB priestoru pre Excel, aby mohol pracovať s týmto súborom.
Odkazy
Ďalšie informácie o procese, ktorý Microsoft Excel používa na ukladanie súborov, nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
214073 Pri pokuse o uloženie súboru v Exceli sa zobrazí chybové hlásenie