Applies ToWindows Vista Business Windows Vista Business 64-bit Edition Windows Vista Enterprise Windows Vista Enterprise 64-bit Edition Windows Vista Home Basic Windows Vista Home Basic 64-bit Edition Windows Vista Home Premium Windows Vista Home Premium 64-bit Edition Windows Vista Ultimate Windows Vista Ultimate 64-bit Edition Windows Vista Starter Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptoms

Assume that you use multiple USB audio devices (such as microphones) at the same time to play audio on a computer that is running Windows Vista or Windows Server 2008. In this situation, the audio stops playing.

Cause

This issue occurs because the audio device is reset incorrectly when a missed micro-frame error is reported by the USB Enhanced Host Controller Interface (EHCI) host controller. Therefore, the audio stops playing.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service packFor more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600 2. 22xxx

    Windows Vista and Windows Server 2008

    SP2

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Platform

Usbccgp.sys

6.0.6002.22734

73,216

28-Oct-2011

14:08

x86

Usbhub.sys

6.0.6002.22734

197,632

28-Oct-2011

14:08

x86

Hccoin.dll

6.0.6002.22734

8,704

28-Oct-2011

16:07

x86

Hcrstco.dll

6.0.6002.22734

15,872

28-Oct-2011

16:07

x86

Usbd.sys

6.0.6002.22734

5,888

28-Oct-2011

14:08

x86

Usbehci.sys

6.0.6002.22734

40,448

28-Oct-2011

14:08

x86

Usbhub.sys

6.0.6002.22734

197,632

28-Oct-2011

14:08

x86

Usbohci.sys

6.0.6002.22734

19,968

28-Oct-2011

14:08

x86

Usbport.sys

6.0.6002.22734

228,352

28-Oct-2011

14:08

x86

Usbuhci.sys

6.0.6002.22734

23,552

28-Oct-2011

14:08

x86

For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Platform

Usbccgp.sys

6.0.6002.22734

95,744

28-Oct-2011

14:45

x64

Usbhub.sys

6.0.6002.22734

275,456

28-Oct-2011

14:45

x64

Hccoin.dll

6.0.6002.22734

10,752

28-Oct-2011

16:16

x64

Hcrstco.dll

6.0.6002.22734

17,920

28-Oct-2011

16:16

x64

Usbd.sys

6.0.6002.22734

7,680

28-Oct-2011

14:45

x64

Usbehci.sys

6.0.6002.22734

50,176

28-Oct-2011

14:45

x64

Usbhub.sys

6.0.6002.22734

275,456

28-Oct-2011

14:45

x64

Usbohci.sys

6.0.6002.22734

24,576

28-Oct-2011

14:45

x64

Usbport.sys

6.0.6002.22734

262,144

28-Oct-2011

14:45

x64

Usbuhci.sys

6.0.6002.22734

29,184

28-Oct-2011

14:45

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about a similar issue that occurs in Windows 7, click the following article number to view the article in the Microsoft Knowledge Base:

2484031 A USB audio device stops playing audio in Windows 7For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File name

X86_usb.inf_31bf3856ad364e35_6.0.6002.22734_none_cd4c182324cae7eb.manifest

File version

Not Applicable

File size

2,644

Date (UTC)

28-Oct-2011

Time (UTC)

21:25

File name

X86_usbport.inf_31bf3856ad364e35_6.0.6002.22734_none_c01610a019e635d2.manifest

File version

Not Applicable

File size

6,734

Date (UTC)

28-Oct-2011

Time (UTC)

21:25

Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File name

Amd64_usb.inf_31bf3856ad364e35_6.0.6002.22734_none_296ab3a6dd285921.manifest

File version

Not Applicable

File size

2,646

Date (UTC)

28-Oct-2011

Time (UTC)

21:25

File name

Amd64_usbport.inf_31bf3856ad364e35_6.0.6002.22734_none_1c34ac23d243a708.manifest

File version

Not Applicable

File size

6,736

Date (UTC)

28-Oct-2011

Time (UTC)

21:25

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.