Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Puede experimentar problemas de conectividad ocasional cuando intenta conectarse a un volumen de StorSimple de ESX Server. Este problema se produce cuando los registros de Control de acceso (ACRs) están configurados para ESX Server mediante direcciones IP.

Este artículo analiza los detalles de este problema y las mejores prácticas para evitarlo. En este artículo se aplica a v1.2.1 StorSimple, v2.0.1 y v2.1.1.

Causa

Cuando un ACR se configura con una dirección IP en un servidor ESX, se realiza la correspondencia de direcciones IP antes de habilita el acceso a los volúmenes de StorSimple. Esto significa que sólo las conexiones que coincidan con la dirección IP específica pueden tener acceso a los volúmenes. Si el servidor en cuestión tiene varias direcciones IP, pero la ACRs están configurados para que no todas las rutas de acceso a la red se incluyen, el usuario puede experimentar problemas de conectividad.

Por ejemplo, supongamos que el servidor host tiene dos direcciones de IP (iSCSI) de 10.2.43.60 y 10.2.43.61 (administración). Estos pueden utilizarse para conectarse a los respectivos volúmenes de StorSimple. A continuación, el usuario crea un ACR y lo asocia con sólo una de estas direcciones IP: 10.2.43.60, por ejemplo. En este escenario, hay una ruta de acceso de red (para 10.2.43.61) para el cual no se ha definido ningún ACR. Si hay más de una ruta de acceso de red al servidor, deben configurarse el ACRs para incluir todos esos trazados.

Si un usuario tiene esta configuración, él o ella es probable que surjan problemas de conectividad. Por ejemplo, si la dirección de la conexión del usuario del iniciador que utiliza la dirección IP de iSCSI se detiene y el iniciador se conecta de nuevo utilizando la dirección IP (con el núcleo de la máquina virtual habilitado), el usuario puede conectarse en este momento. Sin embargo, no se expondrán los volúmenes StorSimple. Por lo tanto, los volúmenes desaparecerá.

Solución

Para resolver este problema, configure el ACR para utilizar la coincidencia de iSCSI (IQN) nombre completo en lugar de una dirección IP. Esto garantiza que una conexión que viene desde cualquier puerto de núcleo VM tendrá acceso al volumen.

Esta resolución requiere un proceso de dos pasos.

Paso 1: Buscar IQN del servidor ESX

  1. Apague todas las máquinas virtuales en ejecución que están almacenadas en el volumen de StorSimple.

  2. Acceso al servidor ESX para extraer el IQN de los iniciadores de iSCSI del servidor ESX. Para ello, siga estos pasos:

    1. Inicie sesión en su VSphere.

    2. Haga clic en Inicio, haga clic en inventarioy, a continuación, haga clic en Hosts y clústeres.

    3. En el panel de exploración, seleccione el servidor ESX. En el panel de detalles, haga clic en la ficha configuración .

    4. Seleccione adaptadores de almacenamiento.

    5. Adaptador de Software de iSCSI para el dispositivo, haga clic en vmhba ##. En el panel de detalles, haga clic en Propiedades.

    6. En el panel Propiedades , seleccione el IQN que se muestra y, a continuación, cópielo.

  3. Repita el paso 2 en todos los servidores ESX.


También se debe configurar la interfaz de usuario (IU) de web. Para ello, el IQN debe aplicarse en el registro de Control de acceso en la interfaz de usuario Web del dispositivo de StorSimple:

  1. Inicie sesión en la interfaz de usuario Web StorSimple.

  2. Haga clic en configuración, haga clic en Configuración de seguridady, a continuación, haga clic en Registro de Control de acceso.

  3. Para el registro de Control de acceso que se especifica para el servidor ESX que se menciona en el paso 2 de la "paso 1: buscar IQN en el ESX server" sección, haga clic en el icono de edición.

  4. En el cuadro dirección IP , elimine la dirección IP que incluye un asterisco (*) y, a continuación, pegue en el cuadro IQN el IQN que copió en el paso 2F de la "paso 1: buscar IQN en el ESX server" sección.

  5. Haga clic en la marca de verificación verde para guardar el registro de Control de acceso.

Repita estos pasos en todos los servidores ESX.

Nota: La conexión iSCSI de ESX server debe ser desconectada y vuelto a conectar.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×